summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-01-12 16:34:10 +0000
committerMichał Górny <mgorny@gentoo.org>2012-01-12 16:34:10 +0000
commitdb2a814b910697b37d580a9bc81165538fb7ca9a (patch)
tree7db05064b85ec80be010b315cd0534b7c13eef6c /app-accessibility/sphinx3
parentFix invalid use of autotools-utils.eclass. (diff)
downloadgentoo-2-db2a814b910697b37d580a9bc81165538fb7ca9a.tar.gz
gentoo-2-db2a814b910697b37d580a9bc81165538fb7ca9a.tar.bz2
gentoo-2-db2a814b910697b37d580a9bc81165538fb7ca9a.zip
Fix invalid use of autotools-utils.eclass.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility/sphinx3')
-rw-r--r--app-accessibility/sphinx3/ChangeLog7
-rw-r--r--app-accessibility/sphinx3/sphinx3-0.8.ebuild22
2 files changed, 13 insertions, 16 deletions
diff --git a/app-accessibility/sphinx3/ChangeLog b/app-accessibility/sphinx3/ChangeLog
index 62090c55be5a..4905e1911b92 100644
--- a/app-accessibility/sphinx3/ChangeLog
+++ b/app-accessibility/sphinx3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/sphinx3
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.5 2011/11/17 17:45:56 neurogeek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/ChangeLog,v 1.6 2012/01/12 16:34:10 mgorny Exp $
+
+ 12 Jan 2012; Michał Górny <mgorny@gentoo.org> sphinx3-0.8.ebuild:
+ Fix invalid use of autotools-utils.eclass.
*sphinx3-0.8 (17 Nov 2011)
diff --git a/app-accessibility/sphinx3/sphinx3-0.8.ebuild b/app-accessibility/sphinx3/sphinx3-0.8.ebuild
index 08fa4df81c44..33a795579518 100644
--- a/app-accessibility/sphinx3/sphinx3-0.8.ebuild
+++ b/app-accessibility/sphinx3/sphinx3-0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/sphinx3-0.8.ebuild,v 1.1 2011/11/17 17:45:56 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx3/sphinx3-0.8.ebuild,v 1.2 2012/01/12 16:34:10 mgorny Exp $
EAPI=3
PYTHON_DEPEND="python? 2:2.6"
@@ -22,18 +22,16 @@ RDEPEND="${DEPEND}"
RESTRICT_PYTHON_ABIS="3*"
+# Due to generated Python setup.py.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
src_prepare() {
epatch "${FILESDIR}/${P}_heap_fix.patch"
eprefixify 'python/setup.py'
}
-src_configure() {
- econf \
- $( use_enable static-libs static )
-}
-
src_compile() {
- default
+ autotools-utils_src_compile
if use python; then
python_copy_sources python
@@ -47,9 +45,8 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README
+ local DOCS=( AUTHORS ChangeLog NEWS README )
+ autotools-utils_src_install
if use doc; then
cd doc
@@ -57,7 +54,6 @@ src_install() {
fi
if use python; then
-
installing() {
"$(PYTHON)" setup.py install \
--install-lib="${D}/$(python_get_sitedir)"
@@ -65,6 +61,4 @@ src_install() {
python_execute_function -s --source-dir python installing
fi
-
- remove_libtool_files
}