summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-09-22 15:46:03 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-09-22 15:46:03 +0000
commit27c6133311e5066bf25a7081c521a57d37c2a9f7 (patch)
treedb4f468eecad1ceea119134f4a02996ee9889b49 /app-accessibility/sphinx2/sphinx2-0.6.ebuild
parentStable for HPPA (bug #285975). (diff)
downloadgentoo-2-27c6133311e5066bf25a7081c521a57d37c2a9f7.tar.gz
gentoo-2-27c6133311e5066bf25a7081c521a57d37c2a9f7.tar.bz2
gentoo-2-27c6133311e5066bf25a7081c521a57d37c2a9f7.zip
fixed --as-needed issues.
(Portage version: 2.2_rc41/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/sphinx2/sphinx2-0.6.ebuild')
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-accessibility/sphinx2/sphinx2-0.6.ebuild b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
index 8ccfcb013fd1..f4a6571ee187 100644
--- a/app-accessibility/sphinx2/sphinx2-0.6.ebuild
+++ b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/sphinx2-0.6.ebuild,v 1.6 2009/08/21 19:28:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/sphinx2-0.6.ebuild,v 1.7 2009/09/22 15:46:02 williamh Exp $
+
+EAPI="2"
+
+inherit autotools eutils
MY_P=${P/_/}
S=${WORKDIR}/${MY_P}
@@ -14,6 +18,11 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old