summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-09 05:45:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-09 05:45:10 +0000
commitfebfce4fc7848522c54930788ffecd47ec36cf67 (patch)
tree2194970cb865a561b6dab086f105e28de57048f1
parentfix bug #30731 (diff)
downloadgentoo-2-febfce4fc7848522c54930788ffecd47ec36cf67.tar.gz
gentoo-2-febfce4fc7848522c54930788ffecd47ec36cf67.tar.bz2
gentoo-2-febfce4fc7848522c54930788ffecd47ec36cf67.zip
fix bug #30731
-rw-r--r--sys-apps/acl/ChangeLog7
-rw-r--r--sys-apps/acl/Manifest4
-rw-r--r--sys-apps/acl/acl-2.2.13-r2.ebuild55
-rw-r--r--sys-apps/acl/files/digest-acl-2.2.13-r21
4 files changed, 64 insertions, 3 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index 23ed38b9e391..1ac1e4915987 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/acl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.18 2003/10/02 04:29:37 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.19 2003/10/09 05:45:08 robbat2 Exp $
+
+*acl-2.2.13-r2 (08 Oct 2003)
+
+ 08 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> acl-2.2.13-r2.ebuild:
+ fix bug #30731
02 Oct 2003; Bartosch Pixa <darkspecter@gentoo.org> acl-2.2.13-r1.ebuild,
acl-2.2.13.ebuild:
diff --git a/sys-apps/acl/Manifest b/sys-apps/acl/Manifest
index 862b28e8bed2..aa8a9b6d9f83 100644
--- a/sys-apps/acl/Manifest
+++ b/sys-apps/acl/Manifest
@@ -1,8 +1,8 @@
MD5 1e803e9219ab1fbb76c8c1ceed451a77 acl-2.2.13-r1.ebuild 1329
MD5 b2ec6f40ae8313a382a3c329a738fe64 acl-2.1.1-r1.ebuild 1144
MD5 0c83b952131e59c7a2795cb2be08a67d acl-2.2.13.ebuild 1264
-MD5 76dc19b2da574afd5eb845dc459bd550 ChangeLog 3029
-MD5 013865aceffe52df0b40565c81e6fb6f acl-2.2.13-r2.ebuild 1449
+MD5 b75876dccafaaa2d41cd7f4f116518d3 ChangeLog 3148
+MD5 6f5eac60448c60570665b498792448a8 acl-2.2.13-r2.ebuild 1445
MD5 9241e1ad126b0fe64c7d1c5cff51fd02 files/digest-acl-2.1.1-r1 65
MD5 ebb544ef383bcd9ab77497e414a31528 files/digest-acl-2.2.13-r1 66
MD5 ebb544ef383bcd9ab77497e414a31528 files/digest-acl-2.2.13-r2 66
diff --git a/sys-apps/acl/acl-2.2.13-r2.ebuild b/sys-apps/acl/acl-2.2.13-r2.ebuild
new file mode 100644
index 000000000000..5e5eaeab1d0c
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.13-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.13-r2.ebuild,v 1.1 2003/10/09 05:45:08 robbat2 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Access control list utilities, libraries and headers"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND} sys-devel/autoconf"
+
+src_compile() {
+ OPTIMIZER="${CFLAGS}"
+ DEBUG=-DNDEBUG
+
+ autoconf || die
+
+ local myconf
+ use nls && myconf="${myconf} --enable-gettext" || myconf="${myconf} --disable-gettext"
+
+ ./configure \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --libdir=/lib \
+ ${myconf}
+
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e 's:-O1::' -i include/builddefs || die "failed to update builddefs"
+
+ emake || die
+
+}
+
+src_install() {
+ make DIST_ROOT=${D} install install-dev install-lib || die
+ #einstall DESTDIR=${D} install install-dev install-lib || die
+
+ rm -f ${D}/usr/lib/libacl.so
+ rm -f ${D}/lib/*a
+ dosym /lib/libacl.so /usr/lib/libacl.so
+ dosym /usr/lib/libacl.la /lib/libacl.la
+ dosym /usr/lib/libacl.a /lib/libacl.a
+
+ dodir /bin
+ mv ${D}/usr/bin/* ${D}/bin/
+ rmdir ${D}/usr/bin/
+}
diff --git a/sys-apps/acl/files/digest-acl-2.2.13-r2 b/sys-apps/acl/files/digest-acl-2.2.13-r2
new file mode 100644
index 000000000000..3507bc54f5cb
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-2.2.13-r2
@@ -0,0 +1 @@
+MD5 179890f6dbd0b31701713947e6b8270f acl-2.2.13.src.tar.gz 124741