summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2010-05-05 18:52:30 +0000
committerMark Loeser <halcy0n@gentoo.org>2010-05-05 18:52:30 +0000
commitfbe2961731e7fa6a8120ea6c9b5a277550abb066 (patch)
treef39acc75dad617cc00855268bd289ac1207567ae
parentVersion bump (bug #316433). Thanks to Ricardo Salveti (ricardo.salveti@openbo... (diff)
downloadgentoo-2-fbe2961731e7fa6a8120ea6c9b5a277550abb066.tar.gz
gentoo-2-fbe2961731e7fa6a8120ea6c9b5a277550abb066.tar.bz2
gentoo-2-fbe2961731e7fa6a8120ea6c9b5a277550abb066.zip
Revert removal of math-pari version
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
-rw-r--r--dev-perl/math-pari/ChangeLog5
-rw-r--r--dev-perl/math-pari/math-pari-2.010801.ebuild40
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 3288407cc59b..5f27cdd12d1c 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/math-pari
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.58 2010/05/05 18:18:19 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.59 2010/05/05 18:52:30 halcy0n Exp $
+
+ 05 May 2010; Mark Loeser <halcy0n@gentoo.org> +math-pari-2.010801.ebuild:
+ Revert removal of math-pari version
05 May 2010; Mark Loeser <halcy0n@gentoo.org> -math-pari-2.010801.ebuild:
Depended on version of sci-mathematics/pari that was removed from the tree
diff --git a/dev-perl/math-pari/math-pari-2.010801.ebuild b/dev-perl/math-pari/math-pari-2.010801.ebuild
new file mode 100644
index 000000000000..06d7b916c58c
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010801.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010801.ebuild,v 1.7 2010/05/05 18:52:30 halcy0n Exp $
+
+inherit perl-module eutils
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+SRC_URI="mirror://cpan/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-2.1.7.tgz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~mips ppc sparc x86"
+IUSE=""
+
+SRC_TEST="do"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+# Math::Pari does NOT work with 2.3. The Makefile.PL gives warnings, and if you
+# run the tests, you get failures.
+DEPEND="~sci-mathematics/pari-2.1.7
+ !=sci-mathematics/pari-2.3*
+ dev-lang/perl"
+
+src_compile() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_compile
+}