summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-07-01 19:26:54 +0000
committerMichael Januszewski <spock@gentoo.org>2008-07-01 19:26:54 +0000
commitf981c3b005c8fdb43bd0fe72cc803674f593cd58 (patch)
treed56bc44c5f764e91620d04f665a2449f1a790d8d
parentVersion bump, bug #227349. gcc43 patch and .desktop file fix are no longer ne... (diff)
downloadgentoo-2-f981c3b005c8fdb43bd0fe72cc803674f593cd58.tar.gz
gentoo-2-f981c3b005c8fdb43bd0fe72cc803674f593cd58.tar.bz2
gentoo-2-f981c3b005c8fdb43bd0fe72cc803674f593cd58.zip
Version bump (bug #230385).
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/nmap-4.68.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 3496aee9f436..c9fb338df57a 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.173 2008/06/09 19:31:17 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.174 2008/07/01 19:26:54 spock Exp $
+
+*nmap-4.68 (01 Jul 2008)
+
+ 01 Jul 2008; Michał Januszewski <spock@gentoo.org> +nmap-4.68.ebuild:
+ Version bump (bug #230385).
*nmap-4.65 (09 Jun 2008)
diff --git a/net-analyzer/nmap/nmap-4.68.ebuild b/net-analyzer/nmap/nmap-4.68.ebuild
new file mode 100644
index 000000000000..72ff3341af6c
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.68.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.68.ebuild,v 1.1 2008/07/01 19:26:54 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use gtk && has_version ">=dev-lang/python-2.5" &&
+ ! has_version ">=dev-python/pysqlite-2" &&
+ ! built_with_use dev-lang/python sqlite ; then
+ eerror "In order to use the nmap GUI you have to either emerge dev-lang/python"
+ eerror "with the 'sqlite' USE flag, or install dev-python/pysqlite-2*."
+ die "sqlite support missing"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+
+ if use lua ; then
+ if has_version ">=dev-lang/lua-5.1.3-r1" &&
+ built_with_use dev-lang/lua deprecated ; then
+ myconf="--with-liblua"
+ else
+ myconf="--with-liblua=included"
+ fi
+ else
+ myconf="--without-liblua"
+ fi
+
+ econf \
+ --with-libdnet=included \
+ "${myconf}" \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}