summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-04-30 10:51:48 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-04-30 10:51:48 +0000
commitf4922e33102ce32aa0977e2ecaad03f9fd978751 (patch)
treead40a3ef1109203c89af75a90c5bcc68d8b80535
parentrm old version (fetch fails) (diff)
downloadgentoo-2-f4922e33102ce32aa0977e2ecaad03f9fd978751.tar.gz
gentoo-2-f4922e33102ce32aa0977e2ecaad03f9fd978751.tar.bz2
gentoo-2-f4922e33102ce32aa0977e2ecaad03f9fd978751.zip
Add support for using ecj instead of virtual/jdk-1.6
(Portage version: 2.1.5_rc6)
-rw-r--r--dev-java/gnu-classpath/ChangeLog6
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.97-r1.ebuild19
2 files changed, 22 insertions, 3 deletions
diff --git a/dev-java/gnu-classpath/ChangeLog b/dev-java/gnu-classpath/ChangeLog
index 02780f9abe35..e1e23ac32a73 100644
--- a/dev-java/gnu-classpath/ChangeLog
+++ b/dev-java/gnu-classpath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/gnu-classpath
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.78 2008/04/10 19:42:19 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.79 2008/04/30 10:51:48 betelgeuse Exp $
+
+ 30 Apr 2008; Petteri Räty <betelgeuse@gentoo.org>
+ gnu-classpath-0.97-r1.ebuild:
+ Add support for using ecj instead of virtual/jdk-1.6
09 Apr 2008; Markus Meier <maekke@gentoo.org>
gnu-classpath-0.97-r1.ebuild:
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.97-r1.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.97-r1.ebuild
index f879f441aa1e..45eb9b28b426 100644
--- a/dev-java/gnu-classpath/gnu-classpath-0.97-r1.ebuild
+++ b/dev-java/gnu-classpath/gnu-classpath-0.97-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.97-r1.ebuild,v 1.4 2008/04/10 19:42:19 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.97-r1.ebuild,v 1.5 2008/04/30 10:51:48 betelgeuse Exp $
EAPI=1
@@ -57,7 +57,10 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
sys-apps/file"
DEPEND="app-arch/zip
- >=virtual/jdk-1.6.0
+ || (
+ dev-java/eclipse-ecj:3.3
+ >=virtual/jdk-1.6.0
+ )
gtk? (
x11-proto/xextproto
x11-proto/xproto
@@ -66,6 +69,15 @@ DEPEND="app-arch/zip
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ has_version dev-java/eclipse-ecj:3.3 && export HAVE_ECJ=true
+ if [[ ${HAVE_ECJ} ]]; then
+ export JAVAC="/usr/bin/ecj-3.3 -nowarn"
+ else
+ java-pkg-2_pkg_setup
+ fi
+}
+
src_compile() {
# Upstreams sets proper -source and -target
unset JAVACFLAGS
@@ -80,6 +92,9 @@ src_compile() {
# die "Unusable JDK + compiler combination"
#fi
+ if [[ ${HAVE_ECJ} ]]; then
+ local myconf="--with-ecj-jar=$(java-pkg_getjars --build-only eclipse-ecj-3.3)"
+ fi
# don't use econf, because it ends up putting things under /usr, which may
# collide with other slots of classpath
./configure ${compiler} \