summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-23 23:57:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-23 23:57:07 +0000
commitf209a9064c0c8ba34e953526a0258cf91a8df94a (patch)
treee5e94a93114849b81c678b9cb025f749a0287115
parentdont set EXTRA_ECONF (Manifest recommit) (diff)
downloadgentoo-2-f209a9064c0c8ba34e953526a0258cf91a8df94a.tar.gz
gentoo-2-f209a9064c0c8ba34e953526a0258cf91a8df94a.tar.bz2
gentoo-2-f209a9064c0c8ba34e953526a0258cf91a8df94a.zip
dont set EXTRA_EMAKE
-rw-r--r--app-sci/clustalw/clustalw-1.83.ebuild20
-rw-r--r--app-sci/phylip/phylip-3.5.ebuild16
-rw-r--r--app-sci/phylip/phylip-3.61.ebuild18
3 files changed, 21 insertions, 33 deletions
diff --git a/app-sci/clustalw/clustalw-1.83.ebuild b/app-sci/clustalw/clustalw-1.83.ebuild
index 00921c80bb22..f38c83343ccc 100644
--- a/app-sci/clustalw/clustalw-1.83.ebuild
+++ b/app-sci/clustalw/clustalw-1.83.ebuild
@@ -1,39 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# Author: Gontran Zepeda <gontran@gontran.net>
-# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83.ebuild,v 1.6 2004/07/01 11:50:28 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/clustalw/clustalw-1.83.ebuild,v 1.7 2004/09/23 23:56:02 vapier Exp $
inherit eutils
DESCRIPTION="Improving the sensitivity of progressive multiple sequence alignment through sequence weighting, position specific gap penalties and weight matrix choice."
-
-# ClustalW is ubiquitous, but this is the contact group.
HOMEPAGE="http://www.embl-heidelberg.de/~seqanal/"
-
-# One source.
SRC_URI="ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/${PN}${PV}.UNIX.tar.gz"
LICENSE="clustalw"
SLOT="0"
-KEYWORDS="x86 sparc ppc alpha"
+KEYWORDS="alpha ppc sparc x86"
IUSE=""
+
DEPEND="virtual/libc"
S=${WORKDIR}/${PN}${PV}
src_unpack(){
- # let's use gentoo CFLAGS, et al.
unpack ${A}
cd ${S}
epatch ${FILESDIR}/optimize-${PN}${PV}.patch
}
+
src_compile() {
- # clustalw uses only makefile. cool: stupid emake tricks.
- EXTRA_EMAKE="-e ${CFLAGS}"
- emake || die
+ emake -e ${CFLAGS} || die
}
+
src_install() {
- # a mano
- dobin clustalw
+ dobin clustalw || die
dodoc README clustalw.doc clustalw.ms clustalw_help
}
diff --git a/app-sci/phylip/phylip-3.5.ebuild b/app-sci/phylip/phylip-3.5.ebuild
index da3afd2280a2..5eef8b21d524 100644
--- a/app-sci/phylip/phylip-3.5.ebuild
+++ b/app-sci/phylip/phylip-3.5.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/phylip/phylip-3.5.ebuild,v 1.5 2004/06/24 22:14:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/phylip/phylip-3.5.ebuild,v 1.6 2004/09/23 23:57:07 vapier Exp $
DESCRIPTION="PHYLIP (the PHYLogeny Inference Package) is a package of programs for inferring phylogenies (evolutionary trees)"
-
HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
SRC_URI="ftp://evolution.genetics.washington.edu/pub/phylip/${PN}.tar.Z"
@@ -11,17 +10,16 @@ LICENSE="freedist"
SLOT="0"
KEYWORDS="x86"
IUSE=""
+
DEPEND=""
+S=${WORKDIR}
+
src_compile() {
- cd ${WORKDIR}
- # uses only makefile.
- EXTRA_EMAKE="-e ${CFLAGS}"
- emake || die
+ emake -e ${CFLAGS} || die
}
-src_install()
-{
- cd ${WORKDIR}
+
+src_install() {
dobin clique consense contml contrast dnacomp dnadist dnainvar
dobin dnaml dnamlk dnamove dnapars dnapenny dollop dolmove dolpenny
dobin drawgram drawtree factor fitch gendist kitsch mix move neighbor
diff --git a/app-sci/phylip/phylip-3.61.ebuild b/app-sci/phylip/phylip-3.61.ebuild
index 5bd99f8f414f..f120a8be87e9 100644
--- a/app-sci/phylip/phylip-3.61.ebuild
+++ b/app-sci/phylip/phylip-3.61.ebuild
@@ -1,33 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/phylip/phylip-3.61.ebuild,v 1.1 2004/08/07 18:54:54 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/phylip/phylip-3.61.ebuild,v 1.2 2004/09/23 23:57:07 vapier Exp $
-DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
+DESCRIPTION="The PHYLogeny Inference Package"
HOMEPAGE="http://evolution.genetics.washington.edu/${PN}.html"
SRC_URI="ftp://evolution.genetics.washington.edu/pub/${PN}/${P}.tar.gz"
-LICENSE="freedist"
+LICENSE="freedist"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~ppc ~x86"
IUSE=""
DEPEND="virtual/libc
virtual/x11"
-S=${WORKDIR}/${P}/src
-
src_compile() {
+ cd src
mkdir ../fonts
emake -j1 -e all put || die
mv ../exe/font* ../fonts
mv ../doc/phylip.html ../phylip.html
}
-src_install()
-{
- cd ${WORKDIR}/${P}
-
- dobin exe/*
+src_install() {
+ dobin exe/* || die
dohtml phylip.html
insinto /usr/share/doc/${PF}/html/doc