summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-01 15:43:28 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-01 15:43:28 +0000
commitef1c96999bae244eed7136677389c60394257b62 (patch)
tree491bd7bf70c876d939c157d0b6813fd20f3e7808
parentAdd patch to fix linking when using --as-needed, to fix bug #335205. (diff)
downloadgentoo-2-ef1c96999bae244eed7136677389c60394257b62.tar.gz
gentoo-2-ef1c96999bae244eed7136677389c60394257b62.tar.bz2
gentoo-2-ef1c96999bae244eed7136677389c60394257b62.zip
Version bump with most of fixes already included in 2.28.4-r1 and updated translations. This also fixes important segfaults suffered by me with gnome-bluetooth and empathy plugins (upstream bug #626362).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--gnome-extra/nautilus-sendto/ChangeLog12
-rw-r--r--gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-commandline-help.patch34
-rw-r--r--gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-fix-memleaks.patch55
-rw-r--r--gnome-extra/nautilus-sendto/nautilus-sendto-2.28.5.ebuild89
4 files changed, 189 insertions, 1 deletions
diff --git a/gnome-extra/nautilus-sendto/ChangeLog b/gnome-extra/nautilus-sendto/ChangeLog
index d33bb4ec2cce..e0277399af1c 100644
--- a/gnome-extra/nautilus-sendto/ChangeLog
+++ b/gnome-extra/nautilus-sendto/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for gnome-extra/nautilus-sendto
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.40 2010/08/07 17:30:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.41 2010/09/01 15:43:28 pacho Exp $
+
+*nautilus-sendto-2.28.5 (01 Sep 2010)
+
+ 01 Sep 2010; Pacho Ramos <pacho@gentoo.org>
+ +nautilus-sendto-2.28.5.ebuild,
+ +files/nautilus-sendto-2.28.5-commandline-help.patch,
+ +files/nautilus-sendto-2.28.5-fix-memleaks.patch:
+ Version bump with most of fixes already included in 2.28.4-r1 and updated
+ translations. This also fixes important segfaults suffered by me with
+ gnome-bluetooth and empathy plugins (upstream bug #626362).
07 Aug 2010; Raúl Porcel <armin76@gentoo.org>
nautilus-sendto-2.28.4-r1.ebuild:
diff --git a/gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-commandline-help.patch b/gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-commandline-help.patch
new file mode 100644
index 000000000000..0f086522649b
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-commandline-help.patch
@@ -0,0 +1,34 @@
+From aff367791fdd6535021fd0c95ecf2067363073c2 Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Tue, 31 Aug 2010 15:49:00 +0000
+Subject: Fix command-line help glitch
+
+nautilus-sendo --help says
+
+Usage:
+nautilus-sendto [OPTION...] [FILES...] nautilus-sendto
+
+The second 'nautilus-sendto' here is redundant and confusing. With the
+patch below, it says just
+
+Usage:
+nautilus-sendto [OPTION...] [FILES...]
+which is the intended output
+
+https://bugzilla.gnome.org/show_bug.cgi?id=627849
+---
+diff --git a/src/nautilus-sendto-command.c b/src/nautilus-sendto-command.c
+index 4dcbb1a..722386c 100644
+--- a/src/nautilus-sendto-command.c
++++ b/src/nautilus-sendto-command.c
+@@ -804,7 +804,7 @@ int main (int argc, char **argv)
+ textdomain (GETTEXT_PACKAGE);
+
+ g_thread_init (NULL);
+- context = g_option_context_new ("nautilus-sendto");
++ context = g_option_context_new ("");
+ g_option_context_add_main_entries (context, entries, GETTEXT_PACKAGE);
+ g_option_context_add_group (context, gtk_get_option_group (TRUE));
+ if (g_option_context_parse (context, &argc, &argv, &error) == FALSE) {
+--
+cgit v0.8.3.1
diff --git a/gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-fix-memleaks.patch b/gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-fix-memleaks.patch
new file mode 100644
index 000000000000..937c7d7ef2e9
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/nautilus-sendto-2.28.5-fix-memleaks.patch
@@ -0,0 +1,55 @@
+From 52a1a4433dd5087baed79f948aec96aab409e3d2 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Mon, 16 Aug 2010 15:21:05 +0000
+Subject: Fix a few memory leaks
+
+On startup, and when sending packed files
+
+https://bugzilla.gnome.org/show_bug.cgi?id=626754
+---
+diff --git a/src/nautilus-sendto-command.c b/src/nautilus-sendto-command.c
+index 92b96bb..4dcbb1a 100644
+--- a/src/nautilus-sendto-command.c
++++ b/src/nautilus-sendto-command.c
+@@ -265,7 +265,7 @@ status_label_clear (gpointer data)
+ static void
+ send_button_cb (GtkWidget *widget, NS_ui *ui)
+ {
+- char *f, *error;
++ char *error;
+ NstPlugin *p;
+ GtkWidget *w;
+
+@@ -305,11 +305,14 @@ send_button_cb (GtkWidget *widget, NS_ui *ui)
+ NAUTILUS_SENDTO_LAST_MEDIUM, p->info->id, NULL);
+
+ if (gtk_toggle_button_get_active(GTK_TOGGLE_BUTTON(ui->pack_checkbutton))){
++ char *f;
++
+ f = pack_files (ui);
+ if (f != NULL) {
+ GList *packed_file = NULL;
+ packed_file = g_list_append (packed_file, f);
+ if (!p->info->send_files (p, w, packed_file)) {
++ g_free (f);
+ g_list_free (packed_file);
+ return;
+ }
+@@ -318,6 +321,7 @@ send_button_cb (GtkWidget *widget, NS_ui *ui)
+ gtk_widget_set_sensitive (ui->dialog, TRUE);
+ return;
+ }
++ g_free (f);
+ } else {
+ if (!p->info->send_files (p, w, file_list)) {
+ g_list_foreach (file_list, (GFunc) g_free, NULL);
+@@ -763,6 +767,7 @@ nautilus_sendto_init (void)
+
+ file = g_file_new_for_commandline_arg (filenames[i]);
+ filename = g_file_get_path (file);
++ g_object_unref (file);
+ if (filename == NULL)
+ continue;
+
+--
+cgit v0.8.3.1
diff --git a/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.5.ebuild b/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.5.ebuild
new file mode 100644
index 000000000000..652c9f2e0239
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.5.ebuild,v 1.1 2010/09/01 15:43:28 pacho Exp $
+
+EAPI="2"
+
+inherit gnome2 multilib eutils autotools
+
+DESCRIPTION="A nautilus extension for sending files to locations"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="bluetooth doc gajim cdr pidgin upnp +mail"
+
+RDEPEND=">=x11-libs/gtk+-2.18
+ >=dev-libs/glib-2.6
+ >=gnome-base/nautilus-2.14
+ >=gnome-base/gconf-2.13.0
+ bluetooth? (
+ || ( >=net-wireless/gnome-bluetooth-2.27
+ >=net-wireless/bluez-gnome-1.8 )
+ >=dev-libs/dbus-glib-0.60 )
+ cdr? ( >=app-cdr/brasero-2.26.0[nautilus] )
+ gajim? (
+ net-im/gajim
+ >=dev-libs/dbus-glib-0.60 )
+ mail? ( >=gnome-extra/evolution-data-server-1.5.3 )
+ pidgin? (
+ >=net-im/pidgin-2.0.0
+ >=dev-libs/dbus-glib-0.60 )
+ upnp? ( >=net-libs/gupnp-0.13.0 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ >=gnome-base/gnome-common-0.12
+ dev-util/gtk-doc-am"
+# Needed for eautoreconf
+# >=gnome-base/gnome-common-0.12
+# dev-util/gtk-doc-am
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+_use_plugin() {
+ if use ${1}; then
+ G2CONF="${G2CONF}${2:-"${1}"},"
+ fi
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-plugins=removable-devices,"
+ _use_plugin bluetooth
+ _use_plugin cdr nautilus-burn
+ _use_plugin mail evolution
+ _use_plugin pidgin
+ _use_plugin gajim
+ _use_plugin upnp
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix a few memory leaks
+ epatch "${FILESDIR}/${P}-fix-memleaks.patch"
+
+ # Fix command-line help glitch
+ epatch "${FILESDIR}/${P}-commandline-help.patch"
+
+ # Remove plugin to use sendto from Evolution
+ epatch "${FILESDIR}/${PN}-2.28.4-remove-old-evo.patch"
+
+ # Remove Empathy plugin since it now lives in Empathy itself.
+ epatch "${FILESDIR}/${PN}-2.28.4-remove-empathy.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Nautilus does not use *.la files
+ find "${D}/usr/$(get_libdir)/nautilus" -name "*.la" -delete \
+ || die "failed to delete *.la files"
+}