summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-08 22:25:20 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-08 22:25:20 +0000
commitee37a189519a974eb8bb9c41b49abb75ce557dc5 (patch)
treeddddf284e466bdb7c5facf3d4c3b316fb7cda202
parentRemoved two unnecessary patches wrt 340194. (diff)
downloadgentoo-2-ee37a189519a974eb8bb9c41b49abb75ce557dc5.tar.gz
gentoo-2-ee37a189519a974eb8bb9c41b49abb75ce557dc5.tar.bz2
gentoo-2-ee37a189519a974eb8bb9c41b49abb75ce557dc5.zip
New package. Provides syntax highlighting, filetype detection, folding, macros, and templates for Csound files.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
-rw-r--r--app-vim/csound-syntax/ChangeLog11
-rw-r--r--app-vim/csound-syntax/csound-syntax-3.1.ebuild18
-rw-r--r--app-vim/csound-syntax/files/csound-syntax-3.1-doc.patch16
-rw-r--r--app-vim/csound-syntax/metadata.xml5
4 files changed, 50 insertions, 0 deletions
diff --git a/app-vim/csound-syntax/ChangeLog b/app-vim/csound-syntax/ChangeLog
new file mode 100644
index 000000000000..280512b469e4
--- /dev/null
+++ b/app-vim/csound-syntax/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-vim/csound-syntax
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/csound-syntax/ChangeLog,v 1.1 2010/10/08 22:25:20 radhermit Exp $
+
+*csound-syntax-3.1 (08 Oct 2010)
+
+ 08 Oct 2010; Tim Harder <radhermit@gentoo.org> +csound-syntax-3.1.ebuild,
+ +files/csound-syntax-3.1-doc.patch, +metadata.xml:
+ New package. Provides syntax highlighting, filetype detection, folding,
+ macros, and templates for Csound files.
+
diff --git a/app-vim/csound-syntax/csound-syntax-3.1.ebuild b/app-vim/csound-syntax/csound-syntax-3.1.ebuild
new file mode 100644
index 000000000000..efd3d7ea5b89
--- /dev/null
+++ b/app-vim/csound-syntax/csound-syntax-3.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/csound-syntax/csound-syntax-3.1.ebuild,v 1.1 2010/10/08 22:25:20 radhermit Exp $
+
+EAPI=3
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Syntax highlighting, filetype detection, folding, macros, and templates for Csound files"
+HOMEPAGE="http://www.eumus.edu.uy/docentes/jure/csound/vim/"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-doc.patch
+}
diff --git a/app-vim/csound-syntax/files/csound-syntax-3.1-doc.patch b/app-vim/csound-syntax/files/csound-syntax-3.1-doc.patch
new file mode 100644
index 000000000000..a7f2c9fbda03
--- /dev/null
+++ b/app-vim/csound-syntax/files/csound-syntax-3.1-doc.patch
@@ -0,0 +1,16 @@
+--- csound-syntax-3.1/doc/csound.txt.orig 2010-10-08 14:46:23.375008988 -0700
++++ csound-syntax-3.1/doc/csound.txt 2010-10-08 15:12:10.349064245 -0700
+@@ -1,4 +1,6 @@
++*csound.txt* Csound Syntax Reference
+
++ *csound-syntax*
+ --------------------------------------------------------------------------
+ *#*
+
+@@ -7880,3 +7882,6 @@
+ Bitwise NOT operator.
+
+ ~ a (bitwise NOT)
++
++--------------------------------------------------------------------------
++vim:tw=78:ts=8:ft=help
diff --git a/app-vim/csound-syntax/metadata.xml b/app-vim/csound-syntax/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/csound-syntax/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>