summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-10-11 15:04:33 +0000
committerFabian Groffen <grobian@gentoo.org>2009-10-11 15:04:33 +0000
commitebd6be1cecbfbe3865392f2fe0c6a781be5c7fc7 (patch)
tree91c9f8b3ec295b744b33ec1d6d6bfb9a5a0ed83d
parentStable on alpha, bug #285280 (diff)
downloadgentoo-2-ebd6be1cecbfbe3865392f2fe0c6a781be5c7fc7.tar.gz
gentoo-2-ebd6be1cecbfbe3865392f2fe0c6a781be5c7fc7.tar.bz2
gentoo-2-ebd6be1cecbfbe3865392f2fe0c6a781be5c7fc7.zip
Use ED for Prefix compatability, marked ~ppc-macos and ~x64-solaris
(Portage version: 2.2.00.14552-prefix/cvs/Darwin powerpc, RepoMan options: --force)
-rw-r--r--net-mail/getmail/ChangeLog5
-rw-r--r--net-mail/getmail/getmail-4.9.2.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 1ca6332d281a..f2998860e8ad 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/getmail
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.170 2009/10/02 22:53:36 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.171 2009/10/11 15:04:33 grobian Exp $
+
+ 11 Oct 2009; Fabian Groffen <grobian@gentoo.org> getmail-4.9.2.ebuild:
+ Use ED for Prefix compatability, marked ~ppc-macos and ~x64-solaris
02 Oct 2009; Tiago Cunha <tcunha@gentoo.org> getmail-4.9.1.ebuild:
stable sparc, bug 278891
diff --git a/net-mail/getmail/getmail-4.9.2.ebuild b/net-mail/getmail/getmail-4.9.2.ebuild
index b08d94dad60f..38ab8974dec0 100644
--- a/net-mail/getmail/getmail-4.9.2.ebuild
+++ b/net-mail/getmail/getmail-4.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.9.2.ebuild,v 1.1 2009/07/23 19:27:29 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.9.2.ebuild,v 1.2 2009/10/11 15:04:33 grobian Exp $
inherit distutils
@@ -10,7 +10,7 @@ SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="4"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~ppc-macos ~x64-solaris"
IUSE=""
DEPEND=">=dev-lang/python-2.3.3"
@@ -19,14 +19,15 @@ RDEPEND="${DEPEND}"
PYTHON_MODNAME=getmailcore
src_install() {
+ [[ -z ${ED} ]] && local ED=${D}
distutils_src_install
# handle docs the gentoo way
- rm "${D}"/usr/share/doc/${P}/COPYING || die
+ rm "${ED}"/usr/share/doc/${P}/COPYING || die
if [[ ${P} != ${PF} ]] ; then
- mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF} || die
+ mv "${ED}"/usr/share/doc/${P} "${ED}"/usr/share/doc/${PF} || die
fi
dodir /usr/share/doc/${PF}/html
- mv "${D}"/usr/share/doc/${PF}/*.{html,css} "${D}"/usr/share/doc/${PF}/html || die
+ mv "${ED}"/usr/share/doc/${PF}/*.{html,css} "${ED}"/usr/share/doc/${PF}/html || die
}