summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-01-28 07:26:59 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-01-28 07:26:59 +0000
commite7dc883982b0edde6ab9227a07374de37404b3dc (patch)
tree9c7f0629a600b83ce1405a79a83a587be3d2ad6a
parentAdded ~ppc (diff)
downloadgentoo-2-e7dc883982b0edde6ab9227a07374de37404b3dc.tar.gz
gentoo-2-e7dc883982b0edde6ab9227a07374de37404b3dc.tar.bz2
gentoo-2-e7dc883982b0edde6ab9227a07374de37404b3dc.zip
Updated init script to capture std out per bug# 162379
(Portage version: 2.1.2-r1)
-rw-r--r--www-servers/tomcat/ChangeLog13
-rwxr-xr-xwww-servers/tomcat/files/5.5.20/tomcat.init6
-rwxr-xr-xwww-servers/tomcat/files/6/tomcat.init6
-rw-r--r--www-servers/tomcat/files/digest-tomcat-5.5.20-r10 (renamed from www-servers/tomcat/files/digest-tomcat-5.5.20-r9)0
-rw-r--r--www-servers/tomcat/files/digest-tomcat-6.0.7_beta-r5 (renamed from www-servers/tomcat/files/digest-tomcat-6.0.7_beta-r4)0
-rw-r--r--www-servers/tomcat/files/digest-tomcat-6.0.8_alpha-r2 (renamed from www-servers/tomcat/files/digest-tomcat-6.0.8_alpha-r1)0
-rw-r--r--www-servers/tomcat/tomcat-5.5.20-r10.ebuild (renamed from www-servers/tomcat/tomcat-5.5.20-r9.ebuild)2
-rw-r--r--www-servers/tomcat/tomcat-6.0.7_beta-r5.ebuild (renamed from www-servers/tomcat/tomcat-6.0.7_beta-r4.ebuild)2
-rw-r--r--www-servers/tomcat/tomcat-6.0.8_alpha-r2.ebuild (renamed from www-servers/tomcat/tomcat-6.0.8_alpha-r1.ebuild)2
9 files changed, 19 insertions, 12 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 9a0c02a39589..50a43330c12d 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for www-servers/tomcat
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.109 2007/01/27 05:16:11 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.110 2007/01/28 07:26:59 wltjr Exp $
+
+*tomcat-6.0.8_alpha-r2 (28 Jan 2007)
+*tomcat-6.0.7_beta-r5 (28 Jan 2007)
+*tomcat-5.5.20-r10 (28 Jan 2007)
+
+ 28 Jan 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ files/5.5.20/tomcat.init, files/6/tomcat.init, -tomcat-5.5.20-r9.ebuild,
+ +tomcat-5.5.20-r10.ebuild, -tomcat-6.0.7_beta-r4.ebuild,
+ +tomcat-6.0.7_beta-r5.ebuild, -tomcat-6.0.8_alpha-r1.ebuild,
+ +tomcat-6.0.8_alpha-r2.ebuild:
+ Updated init script to capture std out per bug# 162379
*tomcat-5.5.20-r9 (27 Jan 2007)
diff --git a/www-servers/tomcat/files/5.5.20/tomcat.init b/www-servers/tomcat/files/5.5.20/tomcat.init
index 3b083cd2d844..677bdbde0b94 100755
--- a/www-servers/tomcat/files/5.5.20/tomcat.init
+++ b/www-servers/tomcat/files/5.5.20/tomcat.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.5.20/tomcat.init,v 1.3 2007/01/10 21:06:33 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/5.5.20/tomcat.init,v 1.4 2007/01/28 07:26:59 wltjr Exp $
init_env_vars() {
# Set some sane defaults
@@ -38,8 +38,6 @@ init_env_vars() {
touch "${CATALINA_BASE}logs/catalina.out"
chown tomcat:tomcat "${CATALINA_BASE}logs/catalina.out"
fi
-
- STD_OUT=" 2<&1 >> ${CATALINA_BASE}logs/catalina.out"
}
start-helper() {
@@ -47,7 +45,7 @@ start-helper() {
shift
local arguments="--start --quiet --background --chuid ${CATALINA_USER}:${CATALINA_GROUP} \
--make-pidfile --pidfile /var/run/tomcat.pid"
- start-stop-daemon ${arguments} --exec ${executor} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${STD_OUT} ${TOMCAT_START}
+ start-stop-daemon ${arguments} --exec ${executor} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START} >> "$CATALINA_BASE"/logs/catalina.out 2>&1
return $?
}
diff --git a/www-servers/tomcat/files/6/tomcat.init b/www-servers/tomcat/files/6/tomcat.init
index 6b32e6b32e31..c4e863f61d0f 100755
--- a/www-servers/tomcat/files/6/tomcat.init
+++ b/www-servers/tomcat/files/6/tomcat.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init,v 1.3 2007/01/10 21:06:33 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init,v 1.4 2007/01/28 07:26:59 wltjr Exp $
init_env_vars() {
# Set some sane defaults
@@ -36,8 +36,6 @@ init_env_vars() {
touch "${CATALINA_BASE}logs/catalina.out"
chown tomcat:tomcat "${CATALINA_BASE}logs/catalina.out"
fi
-
- STD_OUT=" 2<&1 >> ${CATALINA_BASE}logs/catalina.out"
}
start-helper() {
@@ -45,7 +43,7 @@ start-helper() {
shift
local arguments="--start --quiet --background --chuid ${CATALINA_USER}:${CATALINA_GROUP} \
--make-pidfile --pidfile /var/run/tomcat.pid"
- start-stop-daemon ${arguments} --exec ${executor} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${STD_OUT} ${TOMCAT_START}
+ start-stop-daemon ${arguments} --exec ${executor} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START} >> "$CATALINA_BASE"/logs/catalina.out 2>&1
return $?
}
diff --git a/www-servers/tomcat/files/digest-tomcat-5.5.20-r9 b/www-servers/tomcat/files/digest-tomcat-5.5.20-r10
index 25cb711a112c..25cb711a112c 100644
--- a/www-servers/tomcat/files/digest-tomcat-5.5.20-r9
+++ b/www-servers/tomcat/files/digest-tomcat-5.5.20-r10
diff --git a/www-servers/tomcat/files/digest-tomcat-6.0.7_beta-r4 b/www-servers/tomcat/files/digest-tomcat-6.0.7_beta-r5
index 1309a094c51c..1309a094c51c 100644
--- a/www-servers/tomcat/files/digest-tomcat-6.0.7_beta-r4
+++ b/www-servers/tomcat/files/digest-tomcat-6.0.7_beta-r5
diff --git a/www-servers/tomcat/files/digest-tomcat-6.0.8_alpha-r1 b/www-servers/tomcat/files/digest-tomcat-6.0.8_alpha-r2
index d9ae7e3b1bba..d9ae7e3b1bba 100644
--- a/www-servers/tomcat/files/digest-tomcat-6.0.8_alpha-r1
+++ b/www-servers/tomcat/files/digest-tomcat-6.0.8_alpha-r2
diff --git a/www-servers/tomcat/tomcat-5.5.20-r9.ebuild b/www-servers/tomcat/tomcat-5.5.20-r10.ebuild
index 61c333826e6d..15541a5306d4 100644
--- a/www-servers/tomcat/tomcat-5.5.20-r9.ebuild
+++ b/www-servers/tomcat/tomcat-5.5.20-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.5.20-r9.ebuild,v 1.1 2007/01/27 05:16:11 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-5.5.20-r10.ebuild,v 1.1 2007/01/28 07:26:59 wltjr Exp $
inherit eutils java-pkg-2 java-ant-2
diff --git a/www-servers/tomcat/tomcat-6.0.7_beta-r4.ebuild b/www-servers/tomcat/tomcat-6.0.7_beta-r5.ebuild
index 774e32534814..1b693a826af2 100644
--- a/www-servers/tomcat/tomcat-6.0.7_beta-r4.ebuild
+++ b/www-servers/tomcat/tomcat-6.0.7_beta-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.7_beta-r4.ebuild,v 1.2 2007/01/27 05:16:11 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.7_beta-r5.ebuild,v 1.1 2007/01/28 07:26:59 wltjr Exp $
inherit eutils java-pkg-2 java-ant-2
diff --git a/www-servers/tomcat/tomcat-6.0.8_alpha-r1.ebuild b/www-servers/tomcat/tomcat-6.0.8_alpha-r2.ebuild
index 7f201203846c..72485f99adfd 100644
--- a/www-servers/tomcat/tomcat-6.0.8_alpha-r1.ebuild
+++ b/www-servers/tomcat/tomcat-6.0.8_alpha-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.8_alpha-r1.ebuild,v 1.2 2007/01/27 05:16:11 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-6.0.8_alpha-r2.ebuild,v 1.1 2007/01/28 07:26:59 wltjr Exp $
inherit eutils java-pkg-2 java-ant-2