summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2006-08-11 11:53:42 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2006-08-11 11:53:42 +0000
commite6dbc76d397fbf6ccf58c894ec1a090aa820a665 (patch)
treea2869a90f007c351029c505c557e240b130a8c55
parentMarked ~hppa (bug #141223). (diff)
downloadgentoo-2-e6dbc76d397fbf6ccf58c894ec1a090aa820a665.tar.gz
gentoo-2-e6dbc76d397fbf6ccf58c894ec1a090aa820a665.tar.bz2
gentoo-2-e6dbc76d397fbf6ccf58c894ec1a090aa820a665.zip
Fixed bug #143125
(Portage version: 2.1-r1)
-rw-r--r--media-sound/listen/ChangeLog12
-rw-r--r--media-sound/listen/files/digest-listen-0.4.3-r23
-rw-r--r--media-sound/listen/listen-0.4.3-r2.ebuild82
3 files changed, 90 insertions, 7 deletions
diff --git a/media-sound/listen/ChangeLog b/media-sound/listen/ChangeLog
index 1049e7be542c..73150e6148f2 100644
--- a/media-sound/listen/ChangeLog
+++ b/media-sound/listen/ChangeLog
@@ -1,14 +1,12 @@
# ChangeLog for media-sound/listen
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/ChangeLog,v 1.7 2006/07/13 09:48:37 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/ChangeLog,v 1.8 2006/08/11 11:53:42 bass Exp $
- 13 Jul 2006; J. Alberto Suárez López <bass@gentoo.org>
- -listen-0.4.2-r2.ebuild, +listen-0.4.3-r1.ebuild:
- Fixed sqlite depend
+*listen-0.4.3-r2 (11 Aug 2006)
- 13 Jul 2006; J. Alberto Suárez López <bass@gentoo.org>
- -listen-0.4.2-r2.ebuild, +listen-0.4.3-r1.ebuild:
- Fixed sqlite depend
+ 11 Aug 2006; J. Alberto Suárez López <bass@gentoo.org>
+ +listen-0.4.3-r2.ebuild:
+ Fixed bug #143125
*listen-0.4.3-r1 (13 Jul 2006)
diff --git a/media-sound/listen/files/digest-listen-0.4.3-r2 b/media-sound/listen/files/digest-listen-0.4.3-r2
new file mode 100644
index 000000000000..4b3db5d1660c
--- /dev/null
+++ b/media-sound/listen/files/digest-listen-0.4.3-r2
@@ -0,0 +1,3 @@
+MD5 998a9df094ee72efc84253f36a957b5c listen-0.4.3.tar.gz 376435
+RMD160 b1edb46dcb3231a15da3fc6aeec7959e6c9239ce listen-0.4.3.tar.gz 376435
+SHA256 31c7ba063a6df08c2ab74fa8c118881dc7989efe1ed3b2e9e9a84699cdaad3b4 listen-0.4.3.tar.gz 376435
diff --git a/media-sound/listen/listen-0.4.3-r2.ebuild b/media-sound/listen/listen-0.4.3-r2.ebuild
new file mode 100644
index 000000000000..a2c3b13d95c1
--- /dev/null
+++ b/media-sound/listen/listen-0.4.3-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/listen-0.4.3-r2.ebuild,v 1.1 2006/08/11 11:53:42 bass Exp $
+
+inherit eutils virtualx
+
+DESCRIPTION="A Music player and management for GNOME"
+HOMEPAGE="http://listengnome.free.fr"
+SRC_URI="mirror://sourceforge/listengnome/${P}.tar.gz"
+
+LICENSE="GPL-2"
+IUSE="aac cdr flac ipod mad vorbis"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.0
+ >=media-libs/gst-plugins-good-0.10.0
+ >=media-plugins/gst-plugins-gnomevfs-0.10.0
+ >=media-plugins/gst-plugins-gconf-0.10.0
+ >=media-plugins/gst-plugins-cdparanoia-0.10.0
+ >=media-plugins/gst-plugins-xvideo-0.10.0
+ mad? ( >=media-plugins/gst-plugins-mad-0.10.0 )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.10.0
+ >=media-plugins/gst-plugins-vorbis-0.10.0 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10.0 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10.0
+ dev-python/ctypes )
+ ipod? ( >=media-libs/libgpod-0.3.2-r1 )
+ cdr? ( app-cdr/serpentine )"
+
+DEPEND="${RDEPEND}
+ >=x11-libs/gtk+-2.8
+ >=media-libs/gstreamer-0.10.0
+ >=sys-apps/dbus-0.50
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.6
+ >=dev-python/gst-python-0.10
+ dev-python/pyvorbis
+ dev-python/pymad
+ >=dev-db/sqlite-3.2.7-r1
+ >=dev-python/pysqlite-2.0
+ dev-python/gnome-python-extras"
+
+pkg_setup() {
+ if use ipod && ! built_with_use media-libs/libgpod python ; then
+ echo
+ eerror "In order to install iPod suport, you need to have media-libs/libgpod"
+ eerror "with 'python' in your USE flags. Please add that flag,"
+ eerror "re-emerge libgpod, and then emerge listen."
+ die "media-libs/libgpod is missing the python binding."
+ fi
+
+ if ! built_with_use sys-apps/dbus python ; then
+ echo
+ eerror "In order to install Listen, you need to have sys-apps/dbus"
+ eerror "with 'python' in your USE flags. Please add that flag,"
+ eerror "re-emerge dbus, and then emerge listen."
+ die "sys-apps/dbus is missing the python binding."
+ fi
+
+ if ! built_with_use gnome-base/gnome-vfs hal ; then
+ echo
+ eerror "In order to install Listen, you need to have gnome-base/gnome-vfs"
+ eerror "with 'hal' in your USE flags. Please add that flag,"
+ eerror "re-emerge gnome-vfs, and then emerge listen."
+ die "gnome-base/gnome-vfs is missing the hal binding."
+ fi
+}
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ addpredict /var/lib/cache/gstreamer-0.10
+ Xemake || die "make failed"
+}
+
+src_install() {
+ Xmake DESTDIR="${D}" PREFIX="/usr" install || die "Install failure"
+}