summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 16:07:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 16:07:47 +0000
commite6319d822f72be1162a9dc5f228243c99228e687 (patch)
tree301cf0e4c892ff14e4fabd70b1a7267f642a05fc
parentBuild fix. See bug #55393. (Manifest recommit) (diff)
downloadgentoo-2-e6319d822f72be1162a9dc5f228243c99228e687.tar.gz
gentoo-2-e6319d822f72be1162a9dc5f228243c99228e687.tar.bz2
gentoo-2-e6319d822f72be1162a9dc5f228243c99228e687.zip
change glibc to libc
-rw-r--r--sys-apps/daemontools/daemontools-0.76-r3.ebuild4
-rw-r--r--sys-apps/daemontools/daemontools-0.76-r4.ebuild4
-rw-r--r--sys-apps/dcfldd/dcfldd-1.0.ebuild4
-rw-r--r--sys-apps/dcron/dcron-2.7-r10.ebuild11
-rw-r--r--sys-apps/dcron/dcron-2.9-r1.ebuild16
-rw-r--r--sys-apps/dcron/dcron-2.9-r2.ebuild4
-rw-r--r--sys-apps/dcron/dcron-2.9.ebuild16
-rw-r--r--sys-apps/debianutils/debianutils-1.16.7-r4.ebuild5
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r3.ebuild25
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r4.ebuild6
-rw-r--r--sys-apps/diffutils/diffutils-2.8.7.ebuild8
-rw-r--r--sys-apps/discover-data/discover-data-2.2003.02.05.ebuild4
-rw-r--r--sys-apps/ed/ed-0.2-r3.ebuild4
-rw-r--r--sys-apps/eject/eject-2.0.12-r1.ebuild12
-rw-r--r--sys-apps/eject/eject-2.0.13.ebuild10
-rw-r--r--sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild5
-rw-r--r--sys-apps/fakeroot/fakeroot-0.4.4.ebuild12
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild5
-rw-r--r--sys-apps/file/file-3.41.ebuild12
-rw-r--r--sys-apps/file/file-4.02.ebuild10
-rw-r--r--sys-apps/file/file-4.06.ebuild10
-rw-r--r--sys-apps/file/file-4.07-r1.ebuild10
-rw-r--r--sys-apps/file/file-4.07.ebuild10
-rw-r--r--sys-apps/file/file-4.08.ebuild4
-rw-r--r--sys-apps/file/file-4.09.ebuild4
-rw-r--r--sys-apps/findutils/findutils-4.1.20-r1.ebuild6
-rw-r--r--sys-apps/findutils/findutils-4.1.20.ebuild9
-rw-r--r--sys-apps/findutils/findutils-4.1.7-r1.ebuild19
28 files changed, 117 insertions, 132 deletions
diff --git a/sys-apps/daemontools/daemontools-0.76-r3.ebuild b/sys-apps/daemontools/daemontools-0.76-r3.ebuild
index be082e97d215..1d538855db65 100644
--- a/sys-apps/daemontools/daemontools-0.76-r3.ebuild
+++ b/sys-apps/daemontools/daemontools-0.76-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/daemontools/daemontools-0.76-r3.ebuild,v 1.10 2004/06/24 22:01:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/daemontools/daemontools-0.76-r3.ebuild,v 1.11 2004/06/28 16:02:57 vapier Exp $
inherit eutils gcc
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64"
IUSE="selinux"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
RDEPEND="selinux? ( sec-policy/selinux-daemontools )"
S=${WORKDIR}/admin/${P}
diff --git a/sys-apps/daemontools/daemontools-0.76-r4.ebuild b/sys-apps/daemontools/daemontools-0.76-r4.ebuild
index 3e2bada0d95c..763437b6435d 100644
--- a/sys-apps/daemontools/daemontools-0.76-r4.ebuild
+++ b/sys-apps/daemontools/daemontools-0.76-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/daemontools/daemontools-0.76-r4.ebuild,v 1.10 2004/06/24 22:01:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/daemontools/daemontools-0.76-r4.ebuild,v 1.11 2004/06/28 16:02:57 vapier Exp $
inherit eutils gcc
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc mips alpha arm hppa ~amd64 ~ia64"
IUSE="selinux"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
RDEPEND="selinux? ( sec-policy/selinux-daemontools )"
S=${WORKDIR}/admin/${P}
diff --git a/sys-apps/dcfldd/dcfldd-1.0.ebuild b/sys-apps/dcfldd/dcfldd-1.0.ebuild
index b4d2b3d7b70b..1e29b6d433be 100644
--- a/sys-apps/dcfldd/dcfldd-1.0.ebuild
+++ b/sys-apps/dcfldd/dcfldd-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcfldd/dcfldd-1.0.ebuild,v 1.3 2004/06/24 22:02:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcfldd/dcfldd-1.0.ebuild,v 1.4 2004/06/28 16:03:19 vapier Exp $
DESCRIPTION="Enhanced dd with md5 checksums"
HOMEPAGE="http://biatchux.dmzs.com/"
@@ -11,7 +11,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/dcron/dcron-2.7-r10.ebuild b/sys-apps/dcron/dcron-2.7-r10.ebuild
index ce49f6d6e23a..df9afea0a7cb 100644
--- a/sys-apps/dcron/dcron-2.7-r10.ebuild
+++ b/sys-apps/dcron/dcron-2.7-r10.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r10.ebuild,v 1.7 2004/06/24 22:02:31 agriffis Exp $
-
-# to use this, you must be part of the "cron" group
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r10.ebuild,v 1.8 2004/06/28 16:03:39 vapier Exp $
inherit eutils
@@ -11,17 +9,16 @@ DESCRIPTION="A cute little cron from Matt Dillon"
HOMEPAGE="http://apollo.backplane.com/"
SRC_URI="http://apollo.backplane.com/FreeSrc/dcron27.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 amd64 ppc sparc hppa mips"
+IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4"
-
RDEPEND="!virtual/cron
sys-apps/cronbase
virtual/mta"
-
PROVIDE="virtual/cron"
src_unpack() {
diff --git a/sys-apps/dcron/dcron-2.9-r1.ebuild b/sys-apps/dcron/dcron-2.9-r1.ebuild
index 1d97faa1ebd9..75fc18796d71 100644
--- a/sys-apps/dcron/dcron-2.9-r1.ebuild
+++ b/sys-apps/dcron/dcron-2.9-r1.ebuild
@@ -1,27 +1,25 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r1.ebuild,v 1.4 2004/06/24 22:02:31 agriffis Exp $
-
-# to use this, you must be part of the "cron" group
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r1.ebuild,v 1.5 2004/06/28 16:03:39 vapier Exp $
inherit eutils
MY_PV=29
S=${WORKDIR}/${PN}
DESCRIPTION="A cute little cron from Matt Dillon"
-SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
HOMEPAGE="http://apollo.backplane.com/"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa ~alpha ~mips"
-SLOT="0"
+SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64"
+IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4"
-
RDEPEND="!virtual/cron
>=sys-apps/cronbase-0.2.1-r3
virtual/mta"
-
PROVIDE="virtual/cron"
src_unpack() {
diff --git a/sys-apps/dcron/dcron-2.9-r2.ebuild b/sys-apps/dcron/dcron-2.9-r2.ebuild
index 93c55552e231..7e50c87dddd9 100644
--- a/sys-apps/dcron/dcron-2.9-r2.ebuild
+++ b/sys-apps/dcron/dcron-2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r2.ebuild,v 1.10 2004/06/24 22:02:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r2.ebuild,v 1.11 2004/06/28 16:03:39 vapier Exp $
inherit eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4"
RDEPEND="!virtual/cron
>=sys-apps/cronbase-0.2.1-r3
diff --git a/sys-apps/dcron/dcron-2.9.ebuild b/sys-apps/dcron/dcron-2.9.ebuild
index 36947c941ee2..e6f652eb1010 100644
--- a/sys-apps/dcron/dcron-2.9.ebuild
+++ b/sys-apps/dcron/dcron-2.9.ebuild
@@ -1,27 +1,25 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9.ebuild,v 1.13 2004/06/24 22:02:31 agriffis Exp $
-
-# to use this, you must be part of the "cron" group
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9.ebuild,v 1.14 2004/06/28 16:03:39 vapier Exp $
inherit eutils
MY_PV=29
S=${WORKDIR}/${PN}
DESCRIPTION="A cute little cron from Matt Dillon"
-SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
HOMEPAGE="http://apollo.backplane.com/"
-KEYWORDS="x86 amd64 ~ppc sparc hppa alpha mips"
-SLOT="0"
+SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc mips alpha hppa amd64"
+IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4"
-
RDEPEND="!virtual/cron
sys-apps/cronbase
virtual/mta"
-
PROVIDE="virtual/cron"
src_unpack() {
diff --git a/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild b/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild
index 67425ee51876..c90edaff7fdb 100644
--- a/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild
+++ b/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild,v 1.8 2004/06/24 22:02:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-1.16.7-r4.ebuild,v 1.9 2004/06/28 16:04:01 vapier Exp $
inherit eutils
@@ -13,8 +13,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
IUSE="static build"
-DEPEND="virtual/glibc"
-
+DEPEND="virtual/libc"
RDEPEND="app-arch/bzip2
sys-apps/coreutils"
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
index 5517eca4381e..69a6838d0d61 100644
--- a/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
+++ b/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
@@ -1,31 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild,v 1.20 2004/06/25 20:41:21 agriffis Exp $
-
-IUSE="nls build static"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild,v 1.21 2004/06/28 16:04:27 vapier Exp $
inherit eutils flag-o-matic
-# sdiff SIGSEGVs with this on gcc-3.2.1, so take it out
-# this fixes bug #13502
-filter-flags "-mpowerpc-gfxopt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Tools to make diffs and compare files"
-SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
+SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
-KEYWORDS="x86 amd64 ppc sparc alpha mips hppa "
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64"
+IUSE="nls build static"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4
nls? ( sys-devel/gettext )
!build? ( sys-apps/texinfo sys-apps/help2man )"
-
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
@@ -54,6 +47,10 @@ src_unpack() {
}
src_compile() {
+ # sdiff SIGSEGVs with this on gcc-3.2.1, so take it out
+ # this fixes bug #13502
+ filter-flags -mpowerpc-gfxopt
+
econf --build=${CHOST} `use_enable nls` || die "econf"
if use static ; then
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
index f98c8baf973c..d5adf7e69236 100644
--- a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
+++ b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.14 2004/06/24 22:03:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.15 2004/06/28 16:04:27 vapier Exp $
inherit eutils flag-o-matic
@@ -13,12 +13,12 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc mips alpha arm hppa ~amd64 ia64 ppc64 s390"
IUSE="nls build static"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4
nls? ( sys-devel/gettext )
!build? ( sys-apps/texinfo sys-apps/help2man )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/diffutils/diffutils-2.8.7.ebuild b/sys-apps/diffutils/diffutils-2.8.7.ebuild
index 43fc92628c96..43cbcfd028d6 100644
--- a/sys-apps/diffutils/diffutils-2.8.7.ebuild
+++ b/sys-apps/diffutils/diffutils-2.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.7.ebuild,v 1.5 2004/06/24 22:03:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.7.ebuild,v 1.6 2004/06/28 16:04:27 vapier Exp $
inherit eutils flag-o-matic
@@ -10,15 +10,15 @@ SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~x86 ppc ~hppa ~ppc64 amd64"
+KEYWORDS="-* ~x86 ppc ~hppa amd64 ~ppc64"
IUSE="nls build static"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4
nls? ( sys-devel/gettext )
!build? ( sys-apps/texinfo sys-apps/help2man )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/discover-data/discover-data-2.2003.02.05.ebuild b/sys-apps/discover-data/discover-data-2.2003.02.05.ebuild
index c0e3fcd44ecb..6061f7056ef2 100644
--- a/sys-apps/discover-data/discover-data-2.2003.02.05.ebuild
+++ b/sys-apps/discover-data/discover-data-2.2003.02.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/discover-data/discover-data-2.2003.02.05.ebuild,v 1.7 2004/06/24 22:03:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/discover-data/discover-data-2.2003.02.05.ebuild,v 1.8 2004/06/28 16:04:50 vapier Exp $
DESCRIPTION="data for discover. list of pci ids. pnp ids etc."
HOMEPAGE="http://hackers.progeny.com/discover/"
@@ -10,7 +10,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc -sparc mips ~alpha hppa amd64"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_install() {
make prefix=/usr DESTDIR=${D} install || die
diff --git a/sys-apps/ed/ed-0.2-r3.ebuild b/sys-apps/ed/ed-0.2-r3.ebuild
index d243d9d6946d..edcb844e3c66 100644
--- a/sys-apps/ed/ed-0.2-r3.ebuild
+++ b/sys-apps/ed/ed-0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r3.ebuild,v 1.27 2004/06/24 22:04:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r3.ebuild,v 1.28 2004/06/28 16:05:20 vapier Exp $
inherit eutils
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-apps/texinfo"
src_unpack() {
diff --git a/sys-apps/eject/eject-2.0.12-r1.ebuild b/sys-apps/eject/eject-2.0.12-r1.ebuild
index c16eb8c20d04..9f98c1861398 100644
--- a/sys-apps/eject/eject-2.0.12-r1.ebuild
+++ b/sys-apps/eject/eject-2.0.12-r1.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.12-r1.ebuild,v 1.8 2004/06/24 22:04:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.12-r1.ebuild,v 1.9 2004/06/28 16:05:39 vapier Exp $
inherit eutils
-S="${WORKDIR}/${P}"
DESCRIPTION="A command to eject a disc from the CD-ROM drive"
+HOMEPAGE="http://eject.sourceforge.net/"
SRC_URI="http://www.ibiblio.org/pub/Linux/utils/disk-management/${P}.tar.gz
http://www.pobox.com/~tranter/${P}.tar.gz"
-HOMEPAGE="http://eject.sourceforge.net/"
-KEYWORDS="x86 amd64 ppc sparc alpha hppa ia64"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa ia64 amd64"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/eject/eject-2.0.13.ebuild b/sys-apps/eject/eject-2.0.13.ebuild
index 88246455a210..493ec1cd3060 100644
--- a/sys-apps/eject/eject-2.0.13.ebuild
+++ b/sys-apps/eject/eject-2.0.13.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.13.ebuild,v 1.11 2004/06/24 22:04:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.13.ebuild,v 1.12 2004/06/28 16:05:39 vapier Exp $
inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="A command to eject a disc from the CD-ROM drive"
HOMEPAGE="http://eject.sourceforge.net/"
SRC_URI="http://www.ibiblio.org/pub/Linux/utils/disk-management/${P}.tar.gz
http://www.pobox.com/~tranter/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 amd64 ~ppc sparc alpha hppa ppc64 ia64 mips"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc mips alpha hppa amd64 ia64 ppc64"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild b/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
index d8aeffb650a1..a215945c5a2f 100644
--- a/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
+++ b/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild,v 1.10 2004/06/24 22:05:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4-r1.ebuild,v 1.11 2004/06/28 16:06:17 vapier Exp $
inherit gnuconfig
@@ -13,8 +13,9 @@ SRC_URI="http://ftp.debian.org/debian/dists/potato/main/source/utils/${MY_P}.tar
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha amd64"
+IUSE=""
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/fakeroot/fakeroot-0.4.4.ebuild b/sys-apps/fakeroot/fakeroot-0.4.4.ebuild
index 53c490a6663d..a60f7557d16a 100644
--- a/sys-apps/fakeroot/fakeroot-0.4.4.ebuild
+++ b/sys-apps/fakeroot/fakeroot-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4.ebuild,v 1.6 2004/06/24 22:05:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-0.4.4.ebuild,v 1.7 2004/06/28 16:06:17 vapier Exp $
MY_P="${PN}_${PV}-4.1"
@@ -10,14 +10,10 @@ SRC_URI="http://ftp.debian.org/debian/dists/potato/main/source/utils/${MY_P}.tar
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ~hppa"
+KEYWORDS="x86 ~hppa amd64"
+IUSE=""
-RDEPEND="virtual/glibc"
-
-src_compile() {
- econf || die "configure problem"
- emake || die "compile problem"
-}
+RDEPEND="virtual/libc"
src_install() {
make DESTDIR=${D} install || die "install problem"
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
index 9a4a8debcc88..957f48fbc5c6 100644
--- a/sys-apps/fbset/fbset-2.1.ebuild
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/fbset-2.1.ebuild,v 1.24 2004/06/24 22:05:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/fbset-2.1.ebuild,v 1.25 2004/06/28 16:06:36 vapier Exp $
inherit gcc
@@ -11,8 +11,9 @@ SRC_URI="http://home.tvd.be/cr26864/Linux/fbdev/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha arm hppa amd64 ia64 ppc64 s390"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/file/file-3.41.ebuild b/sys-apps/file/file-3.41.ebuild
index 4bf65ae23d69..7ce0e441da8d 100644
--- a/sys-apps/file/file-3.41.ebuild
+++ b/sys-apps/file/file-3.41.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.41.ebuild,v 1.7 2004/06/25 20:43:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.41.ebuild,v 1.8 2004/06/28 16:07:10 vapier Exp $
inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
ftp://ftp.astron.com/pub/file/${P}.tar.gz"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-KEYWORDS="x86 amd64 ppc sparc alpha mips hppa "
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/file/file-4.02.ebuild b/sys-apps/file/file-4.02.ebuild
index 0ad4fe390f4a..e623c916da8d 100644
--- a/sys-apps/file/file-4.02.ebuild
+++ b/sys-apps/file/file-4.02.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.02.ebuild,v 1.13 2004/06/25 20:43:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.02.ebuild,v 1.14 2004/06/28 16:07:10 vapier Exp $
inherit flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
HOMEPAGE="ftp://ftp.astron.com/pub/file/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-KEYWORDS="x86 amd64 ppc sparc alpha hppa"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa amd64"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
diff --git a/sys-apps/file/file-4.06.ebuild b/sys-apps/file/file-4.06.ebuild
index 72b48a0197f4..9544ba26cee5 100644
--- a/sys-apps/file/file-4.06.ebuild
+++ b/sys-apps/file/file-4.06.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.06.ebuild,v 1.18 2004/06/25 20:43:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.06.ebuild,v 1.19 2004/06/28 16:07:10 vapier Exp $
inherit flag-o-matic gnuconfig eutils
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
ftp://ftp.astron.com/pub/file/${P}.tar.gz"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-KEYWORDS="x86 amd64 ~ppc sparc alpha hppa mips ia64 ppc64"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc mips alpha hppa amd64 ia64 ppc64"
IUSE="uclibc"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/file/file-4.07-r1.ebuild b/sys-apps/file/file-4.07-r1.ebuild
index c8a5231d5c27..8f5cc33bedd0 100644
--- a/sys-apps/file/file-4.07-r1.ebuild
+++ b/sys-apps/file/file-4.07-r1.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.07-r1.ebuild,v 1.6 2004/06/25 20:43:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.07-r1.ebuild,v 1.7 2004/06/28 16:07:10 vapier Exp $
inherit flag-o-matic gnuconfig eutils
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
ftp://ftp.astron.com/pub/file/${P}.tar.gz"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~ppc64 s390"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64 s390"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/file/file-4.07.ebuild b/sys-apps/file/file-4.07.ebuild
index 5aa953b20b81..ffbc57e9102a 100644
--- a/sys-apps/file/file-4.07.ebuild
+++ b/sys-apps/file/file-4.07.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.07.ebuild,v 1.6 2004/06/25 20:43:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.07.ebuild,v 1.7 2004/06/28 16:07:10 vapier Exp $
inherit flag-o-matic gnuconfig eutils
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
ftp://ftp.astron.com/pub/file/${P}.tar.gz"
-HOMEPAGE="ftp://ftp.astron.com/pub/file/"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~ppc64"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/file/file-4.08.ebuild b/sys-apps/file/file-4.08.ebuild
index b996949e6c7e..de19b18a0f0c 100644
--- a/sys-apps/file/file-4.08.ebuild
+++ b/sys-apps/file/file-4.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.08.ebuild,v 1.8 2004/06/24 22:06:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.08.ebuild,v 1.9 2004/06/28 16:07:10 vapier Exp $
inherit flag-o-matic gnuconfig eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ppc ~sparc ~mips ~alpha arm hppa ~amd64 ~ia64 ~ppc64 s390"
IUSE="build uclibc"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/file/file-4.09.ebuild b/sys-apps/file/file-4.09.ebuild
index f9c1678b1cec..ff288af72e0a 100644
--- a/sys-apps/file/file-4.09.ebuild
+++ b/sys-apps/file/file-4.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.09.ebuild,v 1.7 2004/06/25 23:45:58 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.09.ebuild,v 1.8 2004/06/28 16:07:10 vapier Exp $
inherit flag-o-matic gnuconfig eutils
use python && inherit distutils
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~x86 ~ppc sparc mips alpha ~arm ~hppa amd64 ~ia64 ~ppc64 s390"
IUSE="python build"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
!build? ( python? ( virtual/python ) )"
src_unpack() {
diff --git a/sys-apps/findutils/findutils-4.1.20-r1.ebuild b/sys-apps/findutils/findutils-4.1.20-r1.ebuild
index cb2309d63967..a5c50d94dd94 100644
--- a/sys-apps/findutils/findutils-4.1.20-r1.ebuild
+++ b/sys-apps/findutils/findutils-4.1.20-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.20-r1.ebuild,v 1.21 2004/06/25 20:59:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.20-r1.ebuild,v 1.22 2004/06/28 16:07:47 vapier Exp $
inherit eutils flag-o-matic gnuconfig
@@ -19,12 +19,12 @@ SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa alpha amd64 ia64 ppc64 s390"
IUSE="nls build afs selinux"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4
nls? ( sys-devel/gettext )
x86? ( afs? ( net-fs/openafs ) )
selinux? ( sys-libs/libselinux )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/findutils/findutils-4.1.20.ebuild b/sys-apps/findutils/findutils-4.1.20.ebuild
index c44c81b8fc65..426cdf50388b 100644
--- a/sys-apps/findutils/findutils-4.1.20.ebuild
+++ b/sys-apps/findutils/findutils-4.1.20.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.20.ebuild,v 1.7 2004/06/24 22:06:58 agriffis Exp $
-
-IUSE="nls build afs"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.20.ebuild,v 1.8 2004/06/28 16:07:47 vapier Exp $
inherit eutils
@@ -18,12 +16,13 @@ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa ~alpha ~ia64"
SLOT="0"
LICENSE="GPL-2"
+IUSE="nls build afs"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4
nls? ( sys-devel/gettext )
x86? ( afs? ( net-fs/openafs ) )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/findutils/findutils-4.1.7-r1.ebuild b/sys-apps/findutils/findutils-4.1.7-r1.ebuild
index 04586ba81370..272d83259b4a 100644
--- a/sys-apps/findutils/findutils-4.1.7-r1.ebuild
+++ b/sys-apps/findutils/findutils-4.1.7-r1.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.7-r1.ebuild,v 1.20 2004/06/25 20:59:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.1.7-r1.ebuild,v 1.21 2004/06/28 16:07:47 vapier Exp $
-IUSE="nls build"
-
-S=${WORKDIR}/${P}
DESCRIPTION="GNU utilities to find files"
-SRC_URI="ftp://alpha.gnu.org/gnu/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
-KEYWORDS="x86 amd64 ppc sparc alpha mips hppa"
-SLOT="0"
+SRC_URI="ftp://alpha.gnu.org/gnu/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64"
+IUSE="nls build"
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
-RDEPEND="virtual/glibc"
+DEPEND="virtual/libc
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/libc"
src_compile() {