summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-11-08 21:06:22 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-11-08 21:06:22 +0000
commite1ed7ecbf6f2995e36cc6389b926254ab8ed231d (patch)
tree3ba58082a1417d3e4be0642cd2693cc3f91e9e2b
parentStable for HPPA PPC (bug #344571). (diff)
downloadgentoo-2-e1ed7ecbf6f2995e36cc6389b926254ab8ed231d.tar.gz
gentoo-2-e1ed7ecbf6f2995e36cc6389b926254ab8ed231d.tar.bz2
gentoo-2-e1ed7ecbf6f2995e36cc6389b926254ab8ed231d.zip
Version bump; various bug fixes.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-2.4.1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 742403e435f8..2101c0b05aa2 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.215 2010/11/02 14:50:33 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.216 2010/11/08 21:06:22 chainsaw Exp $
+
+*audacious-2.4.1 (08 Nov 2010)
+
+ 08 Nov 2010; <chainsaw@gentoo.org> +audacious-2.4.1.ebuild:
+ Version bump; various bug fixes.
02 Nov 2010; Thomas Kahle <tomka@gentoo.org> audacious-2.4.0.ebuild:
x86 stable per bug 297894
diff --git a/media-sound/audacious/audacious-2.4.1.ebuild b/media-sound/audacious/audacious-2.4.1.ebuild
new file mode 100644
index 000000000000..c4d04257b79b
--- /dev/null
+++ b/media-sound/audacious/audacious-2.4.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-2.4.1.ebuild,v 1.1 2010/11/08 21:06:22 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="altivec chardet nls session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ >=dev-libs/libmcs-0.7.1-r2
+ >=dev-libs/libmowgli-0.7.0
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/pango-1.8.0
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-2.4.1"
+
+src_compile() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}