summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-06-12 15:24:28 +0000
committerJon Hood <squinky86@gentoo.org>2006-06-12 15:24:28 +0000
commitdeb8cdd5352e2d753f43bdadd3dcddfa9d84a1b9 (patch)
tree43d82de45ed4214781e356de1f414cadb1c23636
parentMarking sparc stable (diff)
downloadgentoo-2-deb8cdd5352e2d753f43bdadd3dcddfa9d84a1b9.tar.gz
gentoo-2-deb8cdd5352e2d753f43bdadd3dcddfa9d84a1b9.tar.bz2
gentoo-2-deb8cdd5352e2d753f43bdadd3dcddfa9d84a1b9.zip
Version bump for bugfixes from upstream
(Portage version: 2.1_rc4-r5)
-rw-r--r--net-p2p/amule/ChangeLog7
-rw-r--r--net-p2p/amule/amule-2.1.3.ebuild119
-rw-r--r--net-p2p/amule/files/digest-amule-2.1.33
3 files changed, 128 insertions, 1 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index abc64055f377..1c26eb144c05 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.72 2006/06/10 14:52:21 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.73 2006/06/12 15:24:28 squinky86 Exp $
+
+*amule-2.1.3 (12 Jun 2006)
+
+ 12 Jun 2006; Jon Hood <squinky86@gentoo.org> +amule-2.1.3.ebuild:
+ Version bump, small bugfixes.
10 Jun 2006; Thomas Cort <tcort@gentoo.org> amule-2.1.2.ebuild:
Droped the ~alpha keyword wrt security Bug #134792.
diff --git a/net-p2p/amule/amule-2.1.3.ebuild b/net-p2p/amule/amule-2.1.3.ebuild
new file mode 100644
index 000000000000..f9f93c85d73e
--- /dev/null
+++ b/net-p2p/amule/amule-2.1.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.1.3.ebuild,v 1.1 2006/06/12 15:24:28 squinky86 Exp $
+
+inherit eutils flag-o-matic wxwidgets
+
+MY_P=${P/m/M}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="aMule, the all-platform eMule p2p client"
+HOMEPAGE="http://www.amule.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="amuled debug gtk nls remote stats unicode"
+
+DEPEND=">=x11-libs/wxGTK-2.6.0
+ >=sys-libs/zlib-1.2.1
+ stats? ( >=media-libs/gd-2.0.26 )
+ remote? ( >=media-libs/libpng-1.2.0 )
+ !net-p2p/xmule"
+
+pkg_setup() {
+ export WX_GTK_VER="2.6"
+
+ if ! use gtk && ! use remote && ! use amuled; then
+ eerror ""
+ eerror "You have to specify at least one of gtk, remote or amuled"
+ eerror "USE flag to build amule."
+ eerror ""
+ die "Invalid USE flag set"
+ fi
+
+ if use unicode && use gtk; then
+ einfo "wxGTK with gtk2 and unicode support will be used"
+ need-wxwidgets unicode
+ elif use gtk; then
+ einfo "wxGTK with gtk2 support will be used"
+ need-wxwidgets gtk2
+ elif use unicode; then
+ einfo "wxGTK with unicode and without X support will be used"
+ need-wxwidgets base-unicode
+ else
+ einfo "wxGTK without X support will be used"
+ need-wxwidgets base
+ fi
+
+ if use stats && ! use gtk; then
+ einfo "Note: You would need both the gtk and stats USE flags"
+ einfo "to compile aMule Statistics GUI."
+ einfo "I will now compile console versions only."
+ fi
+
+ if use stats && ! built_with_use media-libs/gd jpeg; then
+ die "media-libs/gd should be compiled with the jpeg use flag when you have the stats use flag set"
+ fi
+}
+
+pkg_preinst() {
+ if use amuled || use remote; then
+ if ! id p2p >/dev/null; then
+ enewgroup p2p
+ enewuser p2p -1 -1 /home/p2p p2p
+ fi
+ fi
+}
+
+src_compile() {
+ local myconf=""
+
+ if use gtk ; then
+ use stats && myconf="${myconf}
+ --enable-wxcas
+ --enable-alc"
+ use remote && myconf="${myconf}
+ --enable-amule-gui"
+ else
+ myconf="
+ --disable-monolithic
+ --disable-amule-gui
+ --disable-wxcas
+ --disable-alc"
+ fi
+
+ econf \
+ --with-wx-config=${WX_CONFIG} \
+ --with-wxbase-config=${WX_CONFIG} \
+ --enable-amulecmd \
+ `use_enable debug` \
+ `use_enable !debug optimize` \
+ `use_enable amuled amule-daemon` \
+ `use_enable nls` \
+ `use_enable remote webserver` \
+ `use_enable stats cas` \
+ `use_enable stats alcc` \
+ ${myconf} || die
+
+ # we filter ssp until bug #74457 is closed to build on hardened
+ if has_hardened; then
+ filter-flags -fstack-protector -fstack-protector-all
+ fi
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if use amuled; then
+ insinto /etc/conf.d; newins ${FILESDIR}/amuled.confd amuled
+ exeinto /etc/init.d; newexe ${FILESDIR}/amuled.initd amuled
+ fi
+
+ if use remote; then
+ insinto /etc/conf.d; newins ${FILESDIR}/amuleweb.confd amuleweb
+ exeinto /etc/init.d; newexe ${FILESDIR}/amuleweb.initd amuleweb
+ fi
+}
diff --git a/net-p2p/amule/files/digest-amule-2.1.3 b/net-p2p/amule/files/digest-amule-2.1.3
new file mode 100644
index 000000000000..a568a5eda4ef
--- /dev/null
+++ b/net-p2p/amule/files/digest-amule-2.1.3
@@ -0,0 +1,3 @@
+MD5 0aafdd159edb8ad5f0064da87998b47d aMule-2.1.3.tar.bz2 3248530
+RMD160 fcc345000e5ad0a221d1e96d0d514f3be36428c3 aMule-2.1.3.tar.bz2 3248530
+SHA256 6e97e947bb7ac231b75e3b21a509a2ec0239bcd7e9dbfc6062c520a6d13b0244 aMule-2.1.3.tar.bz2 3248530