summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-08-12 18:13:09 +0000
committerSteve Dibb <beandog@gentoo.org>2008-08-12 18:13:09 +0000
commitde612f501d901f1e15904aabf38d4cc58ff6c6fb (patch)
tree8e2caa26981899c6701037290a708f7bcc212a64
parentremove unused version (diff)
downloadgentoo-2-de612f501d901f1e15904aabf38d4cc58ff6c6fb.tar.gz
gentoo-2-de612f501d901f1e15904aabf38d4cc58ff6c6fb.tar.bz2
gentoo-2-de612f501d901f1e15904aabf38d4cc58ff6c6fb.zip
Version bump, bug 234462
(Portage version: 2.2_rc7/cvs/Linux 2.6.25-tuxonice-r6 x86_64)
-rw-r--r--dev-lang/yasm/ChangeLog7
-rw-r--r--dev-lang/yasm/yasm-0.7.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index cb44e19f021e..1928ac61f618 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.25 2008/04/16 12:36:43 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.26 2008/08/12 18:13:09 beandog Exp $
+
+*yasm-0.7.1 (12 Aug 2008)
+
+ 12 Aug 2008; Steve Dibb <beandog@gentoo.org> +yasm-0.7.1.ebuild:
+ Version bump, bug 234462
*yasm-0.7.0 (16 Apr 2008)
diff --git a/dev-lang/yasm/yasm-0.7.1.ebuild b/dev-lang/yasm/yasm-0.7.1.ebuild
new file mode 100644
index 000000000000..0db523c29c6f
--- /dev/null
+++ b/dev-lang/yasm/yasm-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.7.1.ebuild,v 1.1 2008/08/12 18:13:09 beandog Exp $
+
+DESCRIPTION="Assembler that supports amd64"
+HOMEPAGE="http://www.tortall.net/projects/yasm/"
+SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Remove macho tests (gas{32,64},nasm{32,64}) until fixed upstream.
+ # Necessary to pass test phase on at least amd64 with gcc-4.1.2.
+ sed -i \
+ -e '/modules\/objfmts\/macho\/tests\/.*\/.*macho.*_test.sh/d' \
+ Makefile.in
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS INSTALL
+}