summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-03-16 14:06:11 +0000
committerBen de Groot <yngwin@gentoo.org>2010-03-16 14:06:11 +0000
commitda29c0c1f4929e2a3c36b803ee2e46324db227db (patch)
tree5e19339d9735e87dd707dd00bdbce619ed08cb25
parentVersion bump wrt #303711, thanks to Hubert Kowalski for reporting. (diff)
downloadgentoo-2-da29c0c1f4929e2a3c36b803ee2e46324db227db.tar.gz
gentoo-2-da29c0c1f4929e2a3c36b803ee2e46324db227db.tar.bz2
gentoo-2-da29c0c1f4929e2a3c36b803ee2e46324db227db.zip
Fix snafu
-rw-r--r--eclass/php5_2-sapi.eclass24
1 files changed, 12 insertions, 12 deletions
diff --git a/eclass/php5_2-sapi.eclass b/eclass/php5_2-sapi.eclass
index d4f908fa685a..57e6bacafffb 100644
--- a/eclass/php5_2-sapi.eclass
+++ b/eclass/php5_2-sapi.eclass
@@ -1,6 +1,6 @@
-# cOPYRIGht 1999-2007 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/php5_2-sapi.eclass,v 1.32 2010/03/16 13:17:26 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/php5_2-sapi.eclass,v 1.33 2010/03/16 14:06:11 yngwin Exp $
# ========================================================================
# Based on robbat2's work on the php4 sapi eclass
@@ -41,7 +41,7 @@ if [[ "${PHP_PACKAGE}" == 1 ]] ; then
LICENSE="PHP-3"
SRC_URI="http://www.php.net/distributions/${MY_PHP_P}.tar.bz2"
S="${WORKDIR}/${MY_PHP_P}"
-FI
+fi
IUSE="adabas bcmath berkdb birdstep bzip2 calendar cdb cjk crypt ctype curl curlwrappers db2 dbase dbmaker debug doc empress empress-bcs esoob exif frontbase fdftk filter firebird flatfile ftp gd gd-external gdbm gmp hash iconv imap inifile interbase iodbc ipv6 java-external json kerberos ldap ldap-sasl libedit mcve mhash msql mssql mysql mysqli ncurses nls oci8 oci8-instant-client odbc pcntl pcre pdo pic posix postgres qdbm readline reflection recode sapdb session sharedext sharedmem simplexml snmp soap sockets solid spell spl sqlite ssl suhosin sybase sybase-ct sysvipc tidy tokenizer truetype unicode wddx xml xmlreader xmlwriter xmlrpc xpm xsl yaz zip zlib"
@@ -84,7 +84,7 @@ DEPEND="adabas? ( >=dev-db/unixODBC-1.8.13 )
odbc? ( >=dev-db/unixODBC-1.8.13 )
postgres? ( || ( >=dev-db/libpq-7.1 ( app-admin/eselect-postgresql
>=dev-db/postgresql-base-7.1 ) ) )
- QDBM? ( Dev-db/qdbm )
+ qdbm? ( dev-db/qdbm )
readline? ( sys-libs/readline )
recode? ( app-text/recode )
sapdb? ( >=dev-db/unixODBC-1.8.13 )
@@ -127,7 +127,7 @@ DEPEND="${DEPEND}
#
# They are in PDEPEND because we need PHP installed first!
PDEPEND="doc? ( app-doc/php-docs )
- FILTER? ( !dev-php5/pecl-filter )
+ filter? ( !dev-php5/pecl-filter )
java-external? ( dev-php5/php-java-bridge )
json? ( !dev-php5/pecl-json )
mcve? ( dev-php5/pecl-mcve )
@@ -170,7 +170,7 @@ EXPORT_FUNCTIONS pkg_setup src_compile src_install src_unpack pkg_postinst
# INTERNAL FUNCTIONS
# ========================================================================
-PHP5_2-SApi_check_use_flags() {
+php5_2-sapi_check_use_flags() {
# Multiple USE dependencies
phpconfutils_use_depend_any "truetype" "gd" "gd" "gd-external"
phpconfutils_use_depend_any "cjk" "gd" "gd" "gd-external"
@@ -299,7 +299,7 @@ php5_2-sapi_install_ini() {
dodir ${PHP_EXT_INI_DIR}
dodir ${PHP_EXT_INI_DIR_ACTIVE}
- # iNSTALL any extensions built as shared objects
+ # Install any extensions built as shared objects
if use sharedext ; then
for x in `ls "${D}/${PHPEXTDIR}/"*.so | sort` ; do
inifilename=${x/.so/.ini}
@@ -342,7 +342,7 @@ php5_2-sapi_src_unpack() {
sed -re "s|^(PHP_)?EXTRA_VERSION=\".*\"|\1EXTRA_VERSION=\"${PHP_EXTRA_BRANDING}-pl${PHPPR}-gentoo\"|g" -i configure.in \
|| die "Unable to change PHP branding to ${PHP_EXTRA_BRANDING}-pl${PHPPR}-gentoo"
- # MULTILIb-strict support
+ # multilib-strict support
if [[ -n "${MULTILIB_PATCH}" ]] && [[ -f "${WORKDIR}/${MULTILIB_PATCH}" ]] ; then
epatch "${WORKDIR}/${MULTILIB_PATCH}"
else
@@ -385,7 +385,7 @@ php5_2-sapi_src_unpack() {
# Suhosin support
if use suhosin ; then
if [[ -n "${SUHOSIN_PATCH}" ]] && [[ -f "${DISTDIR}/${SUHOSIN_PATCH}" ]] ; then
- EPATCH "${DISTDIR}/${SUHOSIN_PATCH}"
+ epatch "${DISTDIR}/${SUHOSIN_PATCH}"
else
ewarn "There is no Suhosin patch available for this PHP release yet!"
fi
@@ -428,7 +428,7 @@ php5_2-sapi_src_compile() {
phpconfutils_extension_with "bz2" "bzip2" 1
phpconfutils_extension_enable "calendar" "calendar" 1
phpconfutils_extension_disable "ctype" "ctype" 0
- PHPCONFUTils_extension_with "curl" "curl" 1
+ phpconfutils_extension_with "curl" "curl" 1
phpconfutils_extension_with "curlwrappers" "curlwrappers" 0
phpconfutils_extension_enable "dbase" "dbase" 1
phpconfutils_extension_disable "dom" "xml" 0
@@ -471,7 +471,7 @@ php5_2-sapi_src_compile() {
phpconfutils_extension_with "sybase-ct" "sybase-ct" 1
phpconfutils_extension_enable "sysvmsg" "sysvipc" 1
phpconfutils_extension_enable "sysvsem" "sysvipc" 1
- PHPCONFUTils_extension_enable "sysvshm" "sysvipc" 1
+ phpconfutils_extension_enable "sysvshm" "sysvipc" 1
phpconfutils_extension_with "tidy" "tidy" 1
phpconfutils_extension_disable "tokenizer" "tokenizer" 0
phpconfutils_extension_enable "wddx" "wddx" 1
@@ -514,7 +514,7 @@ php5_2-sapi_src_compile() {
phpconfutils_extension_enable "gd-jis-conv" "cjk" 0
phpconfutils_extension_with "jpeg-dir" "gd" 0 "/usr"
phpconfutils_extension_with "png-dir" "gd" 0 "/usr"
- PHPCONFUTils_extension_with "xpm-dir" "xpm" 0 "/usr"
+ phpconfutils_extension_with "xpm-dir" "xpm" 0 "/usr"
# enable gd last, so configure can pick up the previous settings
phpconfutils_extension_with "gd" "gd" 0
fi