summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-12-29 06:03:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-12-29 06:03:55 +0000
commitd845df6f0abb5d90072f9c84a2bc58d539bcffb2 (patch)
treee6448e2b0e7dac10d348728ebdb3be85a8064b1e
parentlcms:0 is being removed for security reasons (bug #526846); 1.6.1 is supersed... (diff)
downloadgentoo-2-d845df6f0abb5d90072f9c84a2bc58d539bcffb2.tar.gz
gentoo-2-d845df6f0abb5d90072f9c84a2bc58d539bcffb2.tar.bz2
gentoo-2-d845df6f0abb5d90072f9c84a2bc58d539bcffb2.zip
Bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sys-power/cpupower/ChangeLog7
-rw-r--r--sys-power/cpupower/cpupower-3.18.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-power/cpupower/ChangeLog b/sys-power/cpupower/ChangeLog
index eed92cda7dec..14072f272869 100644
--- a/sys-power/cpupower/ChangeLog
+++ b/sys-power/cpupower/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/cpupower
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/ChangeLog,v 1.20 2014/07/15 05:33:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/ChangeLog,v 1.21 2014/12/29 06:03:55 patrick Exp $
+
+*cpupower-3.18 (29 Dec 2014)
+
+ 29 Dec 2014; Patrick Lauer <patrick@gentoo.org> +cpupower-3.18.ebuild:
+ Bump
15 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> cpupower-3.15.ebuild:
Optimize unpacking wrt #517104 by Ben Kohler
diff --git a/sys-power/cpupower/cpupower-3.18.ebuild b/sys-power/cpupower/cpupower-3.18.ebuild
new file mode 100644
index 000000000000..d194fec0fc3b
--- /dev/null
+++ b/sys-power/cpupower/cpupower-3.18.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpupower/cpupower-3.18.ebuild,v 1.1 2014/12/29 06:03:55 patrick Exp $
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Shows and sets processor power related values"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v3.x/linux-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="cpufreq_bench debug nls"
+
+# File collision w/ headers of the deprecated cpufrequtils
+RDEPEND="sys-apps/pciutils
+ !<sys-apps/linux-misc-apps-3.6-r2
+ !sys-power/cpufrequtils"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/linux-${PV}/tools/power/${PN}
+
+pkg_setup() {
+ myemakeargs=(
+ DEBUG=$(usex debug true false)
+ V=1
+ CPUFREQ_BENCH=$(usex cpufreq_bench true false)
+ NLS=$(usex nls true false)
+ docdir=/usr/share/doc/${PF}/${PN}
+ mandir=/usr/share/man
+ libdir=/usr/$(get_libdir)
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC)"
+ STRIP=true
+ LDFLAGS="${LDFLAGS}"
+ OPTIMIZATION="${CFLAGS}"
+ )
+}
+
+src_unpack() {
+ tar -xf "${DISTDIR}"/linux-${PV}.tar.xz \
+ linux-${PV}/tools/power/${PN} \
+ linux-${PV}/Makefile \
+ || die
+}
+
+src_prepare() {
+ # -Wl,--as-needed compat
+ local libs="-lcpupower -lrt $($(tc-getPKG_CONFIG) --libs-only-l libpci)"
+ sed -i \
+ -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
+ -e "s:-O1 -g::" \
+ Makefile || die
+}
+
+src_compile() {
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" "${myemakeargs[@]}" install
+ dodoc README ToDo
+
+ newconfd "${FILESDIR}"/conf.d-r2 ${PN}
+ newinitd "${FILESDIR}"/init.d-r4 ${PN}
+}