summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-02-19 15:46:59 +0000
committerMichael Januszewski <spock@gentoo.org>2006-02-19 15:46:59 +0000
commitd60448a4937eaacdf957f4c096e71bfced848050 (patch)
treefae432866b0b88570b26bee10b723f15751e1002
parentAdded latest patches. (diff)
downloadgentoo-2-d60448a4937eaacdf957f4c096e71bfced848050.tar.gz
gentoo-2-d60448a4937eaacdf957f4c096e71bfced848050.tar.bz2
gentoo-2-d60448a4937eaacdf957f4c096e71bfced848050.zip
Moved hddtemp db update code to pkg_config (bug #116348).
(Portage version: 2.1_pre4-r1)
-rw-r--r--app-admin/hddtemp/ChangeLog10
-rw-r--r--app-admin/hddtemp/files/digest-hddtemp-0.3_beta14-r13
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta14-r1.ebuild53
-rw-r--r--app-admin/hddtemp/metadata.xml4
4 files changed, 66 insertions, 4 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
index 254c54972356..460ffd771476 100644
--- a/app-admin/hddtemp/ChangeLog
+++ b/app-admin/hddtemp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/hddtemp
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.31 2005/12/23 20:25:02 hansmi Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.32 2006/02/19 15:46:59 spock Exp $
+
+*hddtemp-0.3_beta14-r1 (19 Feb 2006)
+
+ 19 Feb 2006; Michał Januszewski <spock@gentoo.org> metadata.xml,
+ +hddtemp-0.3_beta14-r1.ebuild:
+ Moved hddtemp db update code to pkg_config (bug #116348).
23 Dec 2005; Michael Hanselmann <hansmi@gentoo.org>
hddtemp-0.3_beta14.ebuild:
diff --git a/app-admin/hddtemp/files/digest-hddtemp-0.3_beta14-r1 b/app-admin/hddtemp/files/digest-hddtemp-0.3_beta14-r1
new file mode 100644
index 000000000000..4fef1b310ef2
--- /dev/null
+++ b/app-admin/hddtemp/files/digest-hddtemp-0.3_beta14-r1
@@ -0,0 +1,3 @@
+MD5 bbf8be4539495e18bec54af77511a680 hddtemp-0.3-beta14.tar.bz2 233279
+RMD160 799338a77fb71c4aa2c4cb0ed8b0613dc0022f52 hddtemp-0.3-beta14.tar.bz2 233279
+SHA256 6f2c4de6ee2e369ecd85d4e99fc3b411d93e5b697cd009fb56b939fc91b90579 hddtemp-0.3-beta14.tar.bz2 233279
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta14-r1.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta14-r1.ebuild
new file mode 100644
index 000000000000..7e999bd97355
--- /dev/null
+++ b/app-admin/hddtemp/hddtemp-0.3_beta14-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta14-r1.ebuild,v 1.1 2006/02/19 15:46:59 spock Exp $
+
+inherit eutils
+
+MY_P=${P/_beta/-beta}
+
+DESCRIPTION="A simple utility to read the temperature of SMART capable hard drives"
+HOMEPAGE="http://www.guzu.net/linux/hddtemp.php"
+SRC_URI="http://www.guzu.net/linux/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
+ # disabling nls breaks compiling
+ use nls || myconf="--disable-nls ${myconf}"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README TODO Changelog
+
+ insinto /usr/share/hddtemp
+ doins ${FILESDIR}/hddtemp.db
+
+ newconfd ${FILESDIR}/hddtemp-conf.d hddtemp
+ newinitd ${FILESDIR}/hddtemp-init hddtemp
+}
+
+pkg_postinst() {
+ einfo "In order to update your hddtemp database, run:"
+ einfo " ebuild /var/db/pkg/app-admin/${PF}/${PF}.ebuild config"
+}
+
+pkg_config() {
+ cd ${ROOT}/usr/share/hddtemp
+
+ einfo "Trying to download the latest hddtemp.db file"
+ wget http://www.guzu.net/linux/hddtemp.db -O hddtemp.db
+}
diff --git a/app-admin/hddtemp/metadata.xml b/app-admin/hddtemp/metadata.xml
index 8bf662d61f92..ec043e4abe9d 100644
--- a/app-admin/hddtemp/metadata.xml
+++ b/app-admin/hddtemp/metadata.xml
@@ -3,9 +3,9 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>aliz@gentoo.org</email>
+ <email>aliz@gentoo.org</email>
</maintainer>
<maintainer>
- <email>spock@gentoo.org</email>
+ <email>spock@gentoo.org</email>
</maintainer>
</pkgmetadata>