summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-08-30 20:40:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-08-30 20:40:56 +0000
commitd46a82f585b4ca7d120305010ef5baedbe2e25d0 (patch)
tree9433238b2fe9ad0833510e31efcaddcf02fe8860
parentMask new buildbot/buildbot-slave for testing in production (diff)
downloadgentoo-2-d46a82f585b4ca7d120305010ef5baedbe2e25d0.tar.gz
gentoo-2-d46a82f585b4ca7d120305010ef5baedbe2e25d0.tar.bz2
gentoo-2-d46a82f585b4ca7d120305010ef5baedbe2e25d0.zip
Version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
-rw-r--r--dev-util/buildbot-slave/ChangeLog8
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.8.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-util/buildbot-slave/ChangeLog b/dev-util/buildbot-slave/ChangeLog
index 66876d4947ab..13790f8e3e25 100644
--- a/dev-util/buildbot-slave/ChangeLog
+++ b/dev-util/buildbot-slave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot-slave
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.49 2013/08/03 09:45:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.50 2013/08/30 20:40:56 hwoarang Exp $
+
+*buildbot-slave-0.8.8 (30 Aug 2013)
+
+ 30 Aug 2013; Markos Chandras <hwoarang@gentoo.org>
+ +buildbot-slave-0.8.8.ebuild:
+ Version bump
03 Aug 2013; Michał Górny <mgorny@gentoo.org> buildbot-slave-0.8.7.ebuild,
buildbot-slave-0.8.7_p1.ebuild:
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.8.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.8.ebuild
new file mode 100644
index 000000000000..4ff902629217
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-0.8.8.ebuild,v 1.1 2013/08/30 20:40:56 hwoarang Exp $
+
+EAPI="5"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="trial buildslave"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils readme.gentoo user
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools
+ dev-python/twisted-core
+ !!<dev-util/buildbot-0.8.1
+ !<dev-util/buildbot-0.8.3"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock )"
+
+PYTHON_MODNAME="buildslave"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_pkg_setup
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
+ to support starting buildslave through Gentoo's init system. To use this,
+ set up your build slave following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build slave, just copy the scripts."
+}
+
+src_install() {
+ distutils_src_install
+
+ doman docs/buildslave.1
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildslave.initd" buildslave
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ readme.gentoo_print_elog
+}