summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-13 02:53:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-13 02:53:50 +0000
commitd25a85cc2eca07f7827c26320fda05f69d167a95 (patch)
treef7313213e09f5541ee4f22afaa5d815bc6fa7c0d
parentversion bump (diff)
downloadgentoo-2-d25a85cc2eca07f7827c26320fda05f69d167a95.tar.gz
gentoo-2-d25a85cc2eca07f7827c26320fda05f69d167a95.tar.bz2
gentoo-2-d25a85cc2eca07f7827c26320fda05f69d167a95.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-server/cyphesis/ChangeLog9
-rw-r--r--games-server/cyphesis/cyphesis-0.6.0.ebuild55
-rw-r--r--games-server/cyphesis/files/cyphesis-0.6.0-gentoo.patch32
-rw-r--r--games-server/cyphesis/files/cyphesis-0.6.0-makefile.patch21
4 files changed, 115 insertions, 2 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index 09b587e6f227..20273a5bf493 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/cyphesis
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.26 2012/08/04 10:51:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.27 2012/11/13 02:53:50 mr_bones_ Exp $
+
+*cyphesis-0.6.0 (13 Nov 2012)
+
+ 13 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org> +cyphesis-0.6.0.ebuild,
+ +files/cyphesis-0.6.0-gentoo.patch, +files/cyphesis-0.6.0-makefile.patch:
+ version bump
04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> cyphesis-0.5.26.ebuild:
Stable for amd64, wrt bug #427868
@@ -126,4 +132,3 @@
+metadata.xml, +cyphesis-0.5.11.ebuild:
New ebuild.
Fixes bug #90938 by kalium@gmx.de and partially bug #58213 Boris Smus
-
diff --git a/games-server/cyphesis/cyphesis-0.6.0.ebuild b/games-server/cyphesis/cyphesis-0.6.0.ebuild
new file mode 100644
index 000000000000..3c5eb4b29386
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.6.0.ebuild,v 1.1 2012/11/13 02:53:50 mr_bones_ Exp $
+
+EAPI=2
+PYTHON_DEPEND=2
+inherit autotools python eutils games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=">=media-libs/skstream-0.3.9
+ >=dev-games/wfmath-1.0.1
+ >=dev-games/mercator-0.3.1
+ dev-libs/libgcrypt
+ dev-libs/libsigc++:2
+ sys-libs/ncurses
+ sys-libs/readline
+ =media-libs/atlas-c++-0.6*
+ >=media-libs/varconf-0.6.4
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
+ install || die
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.6.0-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.6.0-gentoo.patch
new file mode 100644
index 000000000000..69aac409ba8d
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.6.0-gentoo.patch
@@ -0,0 +1,32 @@
+diff -ru cyphesis-0.6.0.orig/Makefile.am cyphesis-0.6.0/Makefile.am
+--- cyphesis-0.6.0.orig/Makefile.am 2012-10-02 06:23:10.000000000 -0400
++++ cyphesis-0.6.0/Makefile.am 2012-11-12 16:54:19.306892135 -0500
+@@ -3,7 +3,6 @@
+ tools tests man dox
+
+ docdir = $(datadir)/doc/cyphesis-$(VERSION)
+-dist_doc_DATA = README COPYING AUTHORS THANKS NEWS FIXME
+
+ rulesetdir = $(datadir)/cyphesis/rulesets
+
+diff -ru cyphesis-0.6.0.orig/configure.ac cyphesis-0.6.0/configure.ac
+--- cyphesis-0.6.0.orig/configure.ac 2012-11-09 16:39:13.000000000 -0500
++++ cyphesis-0.6.0/configure.ac 2012-11-12 16:53:51.622839335 -0500
+@@ -381,17 +381,6 @@
+ libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then
diff --git a/games-server/cyphesis/files/cyphesis-0.6.0-makefile.patch b/games-server/cyphesis/files/cyphesis-0.6.0-makefile.patch
new file mode 100644
index 000000000000..a4ca687cb56d
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.6.0-makefile.patch
@@ -0,0 +1,21 @@
+--- Makefile.am.orig 2012-11-12 21:44:40.625023121 -0500
++++ Makefile.am 2012-11-12 21:44:52.862604752 -0500
+@@ -9,18 +9,6 @@
+ socketdir = $(localstatedir)/tmp
+ socket_DATA =
+
+-install-data-hook:
+- chmod 1777 $(DESTDIR)$(socketdir)
+- @echo
+- @echo "Cyphesis is not yet ready to run."
+- @echo "Unless you have configured the server to run without a database, Cyphesis"
+- @echo "requires access to a PostgreSQL database to store rules and account data."
+- @echo "Please run 'sudo $(top_srcdir)/scripts/cyphesis-setup.sh' to create the"
+- @echo "PostgreSQL account and database required, or run it as root."
+- @echo
+- @echo "For detailed instructions please see the README file."
+- @echo
+-
+ EXTRA_DIST = cyphesis.spec Doxyfile autogen.sh \
+ cyphesis.init cyclient.init cyphesis.sysconfig \
+ scripts/compile_python.py scripts/gen_op.py \