summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-09-09 07:08:44 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-09-09 07:08:44 +0000
commitcf044dcfa9a7123d259bcbe10652192778784270 (patch)
treeca182b9f485f30d7670432f0f8bfc6a0b6f041dd
parentRename ESCM_OFFLINE to EVCS_OFFLINE. Drop ESCM_VERSION. Fixes bug 410465. (diff)
downloadgentoo-2-cf044dcfa9a7123d259bcbe10652192778784270.tar.gz
gentoo-2-cf044dcfa9a7123d259bcbe10652192778784270.tar.bz2
gentoo-2-cf044dcfa9a7123d259bcbe10652192778784270.zip
Version bump.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
-rw-r--r--app-text/xchm/ChangeLog8
-rw-r--r--app-text/xchm/files/xchm.desktop2
-rw-r--r--app-text/xchm/xchm-1.21.ebuild52
3 files changed, 60 insertions, 2 deletions
diff --git a/app-text/xchm/ChangeLog b/app-text/xchm/ChangeLog
index aef88d1539e0..ad65cb37c075 100644
--- a/app-text/xchm/ChangeLog
+++ b/app-text/xchm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/xchm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.18 2012/09/05 07:22:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.19 2012/09/09 07:08:44 dirtyepic Exp $
+
+*xchm-1.21 (09 Sep 2012)
+
+ 09 Sep 2012; Ryan Hill <dirtyepic@gentoo.org> +xchm-1.21.ebuild,
+ files/xchm.desktop:
+ Version bump.
05 Sep 2012; Justin Lecher <jlec@gentoo.org> xchm-1.18.ebuild,
xchm-1.20.ebuild:
diff --git a/app-text/xchm/files/xchm.desktop b/app-text/xchm/files/xchm.desktop
index aced6708cb5e..a8842132a170 100644
--- a/app-text/xchm/files/xchm.desktop
+++ b/app-text/xchm/files/xchm.desktop
@@ -8,4 +8,4 @@ Icon=xchm
TryExec=xchm
Exec=xchm %f
MimeType=application/x-chm;
-Categories=Viewer;Utility;
+Categories=Office;Viewer;
diff --git a/app-text/xchm/xchm-1.21.ebuild b/app-text/xchm/xchm-1.21.ebuild
new file mode 100644
index 000000000000..56713dc56e39
--- /dev/null
+++ b/app-text/xchm/xchm-1.21.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/xchm-1.21.ebuild,v 1.1 2012/09/09 07:08:44 dirtyepic Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit eutils fdo-mime flag-o-matic wxwidgets
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files."
+HOMEPAGE="http://xchm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="nls"
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:2.8[X]"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ econf ${myconf} \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}