summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-10-22 20:38:09 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-10-22 20:38:09 +0000
commitc786525ed10b957e6dbe0dc0eb5f8e810ca3044b (patch)
tree71e76b2989631ca3d38bdb9261d728b16f7012a8
parentfix perldoc emptydirs in 5.8.1 (diff)
downloadgentoo-2-c786525ed10b957e6dbe0dc0eb5f8e810ca3044b.tar.gz
gentoo-2-c786525ed10b957e6dbe0dc0eb5f8e810ca3044b.tar.bz2
gentoo-2-c786525ed10b957e6dbe0dc0eb5f8e810ca3044b.zip
gentoofication of initscript for firewall
-rw-r--r--app-admin/bastille/ChangeLog6
-rw-r--r--app-admin/bastille/Manifest7
-rw-r--r--app-admin/bastille/bastille-2.1.1-r1.ebuild3
-rw-r--r--app-admin/bastille/files/bastille-2.1.1-firewall.init41
4 files changed, 52 insertions, 5 deletions
diff --git a/app-admin/bastille/ChangeLog b/app-admin/bastille/ChangeLog
index a52b66feea83..bd99eff74dc9 100644
--- a/app-admin/bastille/ChangeLog
+++ b/app-admin/bastille/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/bastille
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.2 2003/09/26 20:45:47 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.3 2003/10/22 20:38:08 seemant Exp $
+
+ 22 Oct 2003; Seemant Kulleen <seemant@gentoo.org> bastille-2.1.1-r1.ebuild,
+ files/bastille-2.1.1-firewall.init:
+ the bastille-firewall init script has been gentoofied by Battoussai
*bastille-2.1.1-r1 (17 Sep 2003)
diff --git a/app-admin/bastille/Manifest b/app-admin/bastille/Manifest
index 3c03d63ff609..0c1054a6cdb8 100644
--- a/app-admin/bastille/Manifest
+++ b/app-admin/bastille/Manifest
@@ -1,6 +1,7 @@
-MD5 4bc1e2aad8cc80e001baa39cf285583e ChangeLog 1286
-MD5 cb5441a1e97abcdd0ea1520b9562ae9c bastille-2.1.1-r1.ebuild 2404
MD5 1b44f1b1ca25c306324078b603a1ca08 bastille-2.1.1.ebuild 3094
+MD5 da8cf08d3aefc8ab6d9ed73c02a0b14d bastille-2.1.1-r1.ebuild 2469
+MD5 0b0d22ae961bc21472758c6a0c6f38ba ChangeLog 1476
MD5 624441f5e21afa19251eedc583e0c4e7 metadata.xml 433
-MD5 5952693da32f1292a5b6013e8e755799 files/digest-bastille-2.1.1 146
MD5 5952693da32f1292a5b6013e8e755799 files/digest-bastille-2.1.1-r1 146
+MD5 d67fde88483e98fc3147028dda5c01ef files/bastille-2.1.1-firewall.init 1348
+MD5 5952693da32f1292a5b6013e8e755799 files/digest-bastille-2.1.1 146
diff --git a/app-admin/bastille/bastille-2.1.1-r1.ebuild b/app-admin/bastille/bastille-2.1.1-r1.ebuild
index deb07cff44c7..a3b1c3ce79fe 100644
--- a/app-admin/bastille/bastille-2.1.1-r1.ebuild
+++ b/app-admin/bastille/bastille-2.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-2.1.1-r1.ebuild,v 1.1 2003/09/18 23:56:21 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-2.1.1-r1.ebuild,v 1.2 2003/10/22 20:38:08 seemant Exp $
inherit perl-module
@@ -33,6 +33,7 @@ src_unpack() {
src_compile() {
cd ${S}
+ cp ${FILESDIR}/bastille-${PV}-firewall.init ./bastille-firewall
}
src_install() {
diff --git a/app-admin/bastille/files/bastille-2.1.1-firewall.init b/app-admin/bastille/files/bastille-2.1.1-firewall.init
new file mode 100644
index 000000000000..aa81a34b9215
--- /dev/null
+++ b/app-admin/bastille/files/bastille-2.1.1-firewall.init
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/files/bastille-2.1.1-firewall.init,v 1.1 2003/10/22 20:38:08 seemant Exp $
+
+opts="start stop"
+
+depend() {
+ need logger
+}
+
+start() {
+ # "Borrowed" from the original bastille-firewall init script ((c) P. Watkins)
+ REALSCRIPT=/sbin/bastille-ipchains
+ if [ -n "$(uname -r | awk -F. ' $1 == 2 && $2 > 2 {print}')" ]; then
+ # We are using Linux 2.3 or newer; use the netfilter script if available
+ if [ -x /sbin/bastille-netfilter ]; then
+ REALSCRIPT=/sbin/bastille-netfilter
+ fi
+ fi
+
+ ebegin "Starting bastille-firewall"
+ $REALSCRIPT start
+ eend $? "Failed to start bastille-firewall"
+}
+
+stop() {
+ # "Borrowed" from the original bastille-firewall init script ((c) P. Watkins)
+ REALSCRIPT=/sbin/bastille-ipchains
+ if [ -n "$(uname -r | awk -F. ' $1 == 2 && $2 > 2 {print}')" ]; then
+ # We are using Linux 2.3 or newer; use the netfilter script if available
+ if [ -x /sbin/bastille-netfilter ]; then
+ REALSCRIPT=/sbin/bastille-netfilter
+ fi
+ fi
+
+ ebegin "Stopping bastille-firewall"
+ $REALSCRIPT stop
+ eend $? "Failed to stop bastille-firewall"
+}
+