summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-30 05:21:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-30 05:21:57 +0000
commitbf9ac2daa32979a0a78d3856ad571e8ef6c1044d (patch)
treed8ff6bc1af19749a726eed982f0436a607ef0739
parentfixes Makefile so we can allow it to install in ${D} (diff)
downloadgentoo-2-bf9ac2daa32979a0a78d3856ad571e8ef6c1044d.tar.gz
gentoo-2-bf9ac2daa32979a0a78d3856ad571e8ef6c1044d.tar.bz2
gentoo-2-bf9ac2daa32979a0a78d3856ad571e8ef6c1044d.zip
version bump
-rw-r--r--net-misc/wget/ChangeLog10
-rw-r--r--net-misc/wget/files/digest-wget-1.8.22
-rw-r--r--net-misc/wget/wget-1.8.2.ebuild48
3 files changed, 59 insertions, 1 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index bb723d6f8cf7..8560a0fc7fe4 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/wget
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.2 2002/02/23 01:43:15 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.3 2002/05/30 05:21:57 seemant Exp $
+
+*wget-1.8.2 (29 May 2002)
+
+ 29 May 2002; Seemant Kulleen <seemant@gentoo.org> wget-1.8.2.ebuild
+ files/digest-wget-1.8.2 :
+
+ Version bump. The patch still works, so there is no noticeable difference
+ to the user.
*wget-1.8.1-r1 (22 Feb 2002)
diff --git a/net-misc/wget/files/digest-wget-1.8.2 b/net-misc/wget/files/digest-wget-1.8.2
new file mode 100644
index 000000000000..e9052aefd4bc
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.8.2
@@ -0,0 +1,2 @@
+MD5 a2473d7a53ebaf0a1bdb06f17059e8f1 wget-1.8.2.tar.gz 1154648
+MD5 8da1e4f2991384ddbd575f4109c2ab4a wget-new-percentage-cvs-20011209.tar.gz 12196
diff --git a/net-misc/wget/wget-1.8.2.ebuild b/net-misc/wget/wget-1.8.2.ebuild
new file mode 100644
index 000000000000..3972e1e9d859
--- /dev/null
+++ b/net-misc/wget/wget-1.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2.ebuild,v 1.1 2002/05/30 05:21:57 seemant Exp $
+
+NPVER=20011209
+S=${WORKDIR}/${P}
+DESCRIPTION="Network utility to retrieve files from the WWW"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
+ ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
+ http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+RDEPEND="virtual/glibc ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="$RDEPEND nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ unpack wget-new-percentage-cvs-${NPVER}.tar.gz
+ cd ${S}/src
+ patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+ [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+ use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+ ./configure --prefix=/usr --sysconfdir=/etc/wget \
+ --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
+ if use static; then
+ make LDFLAGS="--static" || die
+ else
+ make || die
+ fi
+}
+
+src_install() {
+ if use build || use bootcd; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+ make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}