summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-12-23 17:39:26 +0000
committerHanno Böck <hanno@gentoo.org>2009-12-23 17:39:26 +0000
commitbe8c25dbec5885bf0e73a3f31cf0af5eb02fb6ca (patch)
tree5e622b8631b4028b31f1afe50e46359b379672c2
parentMarked ~x86-solaris, bug #296509 (diff)
downloadgentoo-2-be8c25dbec5885bf0e73a3f31cf0af5eb02fb6ca.tar.gz
gentoo-2-be8c25dbec5885bf0e73a3f31cf0af5eb02fb6ca.tar.bz2
gentoo-2-be8c25dbec5885bf0e73a3f31cf0af5eb02fb6ca.zip
unp: support .tar.xz
(Portage version: 2.2_rc60/cvs/Linux x86_64)
-rw-r--r--app-arch/unp/ChangeLog8
-rw-r--r--app-arch/unp/files/unp-1.0.15-7z-lzma-xz.diff67
-rw-r--r--app-arch/unp/unp-1.0.14.ebuild20
-rw-r--r--app-arch/unp/unp-1.0.15-r2.ebuild (renamed from app-arch/unp/unp-1.0.15.ebuild)17
4 files changed, 86 insertions, 26 deletions
diff --git a/app-arch/unp/ChangeLog b/app-arch/unp/ChangeLog
index fdb6b7455d4d..1e5f74565bb9 100644
--- a/app-arch/unp/ChangeLog
+++ b/app-arch/unp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/unp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/ChangeLog,v 1.25 2009/08/27 12:46:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/ChangeLog,v 1.26 2009/12/23 17:39:25 hanno Exp $
+
+*unp-1.0.15-r2 (23 Dec 2009)
+
+ 23 Dec 2009; Hanno Boeck <hanno@gentoo.org> +unp-1.0.15-r2.ebuild,
+ +files/unp-1.0.15-7z-lzma-xz.diff:
+ Also support .tar.xz.
27 Aug 2009; Christian Faulhammer <fauli@gentoo.org> unp-1.0.15-r1.ebuild:
stable x86, bug 280067
diff --git a/app-arch/unp/files/unp-1.0.15-7z-lzma-xz.diff b/app-arch/unp/files/unp-1.0.15-7z-lzma-xz.diff
new file mode 100644
index 000000000000..58070f82034c
--- /dev/null
+++ b/app-arch/unp/files/unp-1.0.15-7z-lzma-xz.diff
@@ -0,0 +1,67 @@
+diff -Naur unp-1.0.15/unp unp-1.0.15-1/unp
+--- unp-1.0.15/unp 2008-05-18 02:55:54.000000000 +0200
++++ unp-1.0.15-1/unp 2009-12-22 14:01:13.000000000 +0100
+@@ -38,20 +38,23 @@
+ }
+
+ %pkgmap = (
+- cpio, "afio $or cpio",
+- afio, "afio $or cpio",
+- rpm2cpio, "rpm, afio $or cpio",
+- unshar, sharutils,
+- uudecode, sharutils,
+- PPMd, ppmd,
+- rar, "rar $or unrar $or unrar-free",
+- ar, binutils,
+- unarj, "unarj $or arj",
+- hexbin, macutils,
++ "xz", "xz-utils",
++ "lzma", "lzma",
++ "7z", "p7zip $or p7zip-full",
++ "cpio", "afio $or cpio",
++ "afio", "afio $or cpio",
++ "rpm2cpio", "rpm, afio $or cpio",
++ "unshar", "sharutils",
++ "uudecode", "sharutils",
++ "PPMd", "ppmd",
++ "rar", "rar $or unrar $or unrar-free",
++ "ar", "binutils",
++ "unarj", "unarj $or arj",
++ "hexbin", "macutils",
+ #macunpack, macunpack,
+- gunzip, gzip,
+- bunzip2, bzip2,
+- formail, "formail, mpack"
++ "gunzip", "gzip",
++ "bunzip2", "bzip2",
++ "formail", "formail, mpack"
+ );
+
+ &print_usage if ($#ARGV<0 || $ARGV[0] eq "-h");
+@@ -153,6 +156,7 @@
+ if ($UNP_FILEstr =~ /CAB file/i) { set_command 'cabextract $UNP_FILE'; }
+ if ($UNP_FILEstr =~ /cpio/i) { set_command('afio -Z -v -i $UNP_FILE','cpio -i -d --verbose $UNP_ARGS < $UNP_FILE'); }
+ if ($UNP_FILEstr =~ /Zip.*archive/i) { set_command 'unzip $UNP_ARGS $UNP_FILE'; }
++ if ($UNP_FILEstr =~ /7-zip.*archive/i) { set_command '7z x $UNP_ARGS $UNP_FILE'; }
+ if ($UNP_FILEstr =~ /Zoo.*archive/i) { set_command 'unzoo -x $UNP_ARGS $UNP_FILE'; }
+ if ($UNP_FILEstr =~ /shell.*archive/i) { set_command 'unshar $UNP_ARGS $UNP_FILE'; }
+ if ($UNP_FILEstr =~ /Transport Neutral Encapsulation Format/i) { set_command 'tnef -v $UNP_ARGS $UNP_FILE'; }
+@@ -214,12 +218,13 @@
+
+ # check also for _tar, because of broken filenames
+ if ($UNP_FILE =~ /(\.|_)tar$/i) { set_command 'tar -xvf $UNP_FILE $UNP_ARGS'; }
+- if ($UNP_FILE =~ /(\.|_)rpm$/i) { set_command 'rpm2cpio < $UNP_FILE | cpio -i -d --verbose $UNP_ARGS';}
+- if ($UNP_FILE =~ /(\.|_)tar\.gz$/i) { set_command 'tar -xvzf $UNP_FILE $UNP_ARGS'; }
++ if ($UNP_FILE =~ /(\.|_)rpm$/i) { set_command 'rpm2cpio < $UNP_FILE | cpio -i -d --verbose $UNP_ARGS';}
++ if ($UNP_FILE =~ /(\.|_)tar\.gz$/i) { set_command 'tar -xvzf $UNP_FILE $UNP_ARGS'; }
+ if ($UNP_FILE =~ /(\.|_)tar\.bz2$/i) { set_command 'bunzip2 -c $UNP_FILE | tar -xvf - $UNP_ARGS'; }
+-
+- if ($UNP_FILE =~ /\.tgz$/i) { set_command 'tar -xvzf $UNP_FILE $UNP_ARGS'; }
+- if ($UNP_FILE =~ /\.(tzo|tar\.lzop)$/i) { set_command 'lzop -v -d $UNP_FILE | tar -xv $UNP_ARGS'; }
++ if ($UNP_FILE =~ /\.tgz$/i) { set_command 'tar -xvzf $UNP_FILE $UNP_ARGS'; }
++ if ($UNP_FILE =~ /\.(tzo|tar\.lzop)$/i) { set_command 'lzop -v -d $UNP_FILE | tar -xv $UNP_ARGS'; }
++ if ($UNP_FILE =~ /(\.|_)tar\.xz$/i) { set_command 'tar -xvJf $UNP_FILE $UNP_ARGS'; }
++ if ($UNP_FILE =~ /(\.|_)tar\.lzma$/i) { set_command 'lzma -cd $UNP_FILE | tar -xvf - $UNP_ARGS'; }
+ if ($UNP_FILE =~ /\.rar$/i) { set_command('rar x $UNP_ARGS $UNP_FILE || rar x -av- $UNP_ARGS $UNP_FILE','unrar x $UNP_ARGS $UNP_FILE || unrar x -av- $UNP_ARGS $UNP_FILE'); }
+ if ($UNP_FILE =~ /\.(ar|deb)$/i) { set_command 'ar -x -v $UNP_FILE $UNP_ARGS'; }
+ if ($UNP_FILE =~ /\.l(ha|zh)$/i) { set_command 'lha x $UNP_ARGS $UNP_FILE'; }
diff --git a/app-arch/unp/unp-1.0.14.ebuild b/app-arch/unp/unp-1.0.14.ebuild
deleted file mode 100644
index c14d0c843a2f..000000000000
--- a/app-arch/unp/unp-1.0.14.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/unp-1.0.14.ebuild,v 1.4 2008/01/06 01:10:47 hanno Exp $
-
-DESCRIPTION="Script for unpacking various file formats"
-HOMEPAGE="http://packages.qa.debian.org/u/unp.html"
-SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${PV}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc x86"
-IUSE=""
-DEPEND="dev-lang/perl"
-
-src_compile() {
- einfo "Nothing to compile"
-}
-
-src_install() {
- dobin unp
-}
diff --git a/app-arch/unp/unp-1.0.15.ebuild b/app-arch/unp/unp-1.0.15-r2.ebuild
index ea3ae6f24f16..5d988c51b726 100644
--- a/app-arch/unp/unp-1.0.15.ebuild
+++ b/app-arch/unp/unp-1.0.15-r2.ebuild
@@ -1,20 +1,27 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/unp-1.0.15.ebuild,v 1.1 2008/10/09 01:45:18 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unp/unp-1.0.15-r2.ebuild,v 1.1 2009/12/23 17:39:25 hanno Exp $
+
+EAPI=2
+
+inherit eutils
DESCRIPTION="Script for unpacking various file formats"
HOMEPAGE="http://packages.qa.debian.org/u/unp.html"
SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE=""
+
DEPEND="dev-lang/perl"
-src_compile() {
- einfo "Nothing to compile"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-7z-lzma-xz.diff
}
src_install() {
- dobin unp
+ dobin ucat unp || die "dobin failed"
+ doman debian/unp.1 || die "doman failed"
}