summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-04-29 14:59:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-04-29 14:59:51 +0000
commitbe1d48328decd82f4c1e8dba9784c35140493415 (patch)
treeb710eef9ead0256013a295f7e98547f4beb4692f
parentFix glib version requirement (diff)
downloadgentoo-2-be1d48328decd82f4c1e8dba9784c35140493415.tar.gz
gentoo-2-be1d48328decd82f4c1e8dba9784c35140493415.tar.bz2
gentoo-2-be1d48328decd82f4c1e8dba9784c35140493415.zip
version bump
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--media-libs/liblo/ChangeLog9
-rw-r--r--media-libs/liblo/liblo-0.28.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-libs/liblo/ChangeLog b/media-libs/liblo/ChangeLog
index e4b2761891c6..127f18cb00bb 100644
--- a/media-libs/liblo/ChangeLog
+++ b/media-libs/liblo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/liblo
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/liblo/ChangeLog,v 1.27 2013/06/15 16:04:10 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblo/ChangeLog,v 1.28 2015/04/29 14:59:51 aballier Exp $
+
+*liblo-0.28 (29 Apr 2015)
+
+ 29 Apr 2015; Alexis Ballier <aballier@gentoo.org> +liblo-0.28.ebuild:
+ version bump
15 Jun 2013; Alexis Ballier <aballier@gentoo.org> liblo-0.27.ebuild:
Remove threads useflag as switching it on or off breaks the ABI, bugs
diff --git a/media-libs/liblo/liblo-0.28.ebuild b/media-libs/liblo/liblo-0.28.ebuild
new file mode 100644
index 000000000000..38ed38558e58
--- /dev/null
+++ b/media-libs/liblo/liblo-0.28.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblo/liblo-0.28.ebuild,v 1.1 2015/04/29 14:59:51 aballier Exp $
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="http://plugin.org.uk/liblo"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs"
+
+RESTRICT="test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ # switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ipv6) \
+ --enable-threads
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}