summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-03-09 05:03:41 +0000
committerLance Albertson <ramereth@gentoo.org>2012-03-09 05:03:41 +0000
commitbc548b1145af88baf3786b8cc99466349012b1f2 (patch)
tree16b154b09416f1951d3c767343ad0528e9f73f0b
parentwhitespace (diff)
downloadgentoo-2-bc548b1145af88baf3786b8cc99466349012b1f2.tar.gz
gentoo-2-bc548b1145af88baf3786b8cc99466349012b1f2.tar.bz2
gentoo-2-bc548b1145af88baf3786b8cc99466349012b1f2.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
-rw-r--r--app-admin/drush/ChangeLog9
-rw-r--r--app-admin/drush/drush-4.5.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/app-admin/drush/ChangeLog b/app-admin/drush/ChangeLog
index b2d23e34dfce..3e308fafad5f 100644
--- a/app-admin/drush/ChangeLog
+++ b/app-admin/drush/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/drush
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v 1.1 2011/05/26 22:22:01 ramereth Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v 1.2 2012/03/09 05:03:41 ramereth Exp $
+
+*drush-4.5 (09 Mar 2012)
+
+ 09 Mar 2012; Lance Albertson <ramereth@gentoo.org> +drush-4.5.ebuild:
+ Version bump
*drush-4.4 (26 May 2011)
diff --git a/app-admin/drush/drush-4.5.ebuild b/app-admin/drush/drush-4.5.ebuild
new file mode 100644
index 000000000000..35a84c465e9b
--- /dev/null
+++ b/app-admin/drush/drush-4.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/drush-4.5.ebuild,v 1.1 2012/03/09 05:03:41 ramereth Exp $
+
+EAPI="4"
+
+DESCRIPTION="Drush is a command line shell and scripting interface for Drupal"
+HOMEPAGE="http://drupal.org/project/drush"
+SRC_URI="http://ftp.drupal.org/files/projects/${PN}-7.x-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-lang/php[cli,simplexml] dev-php/pear"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ local docs="README.txt docs"
+
+ insinto /usr/share/drush
+ doins -r .
+ exeinto /usr/share/drush
+ doexe drush
+ dosym /usr/share/drush/drush /usr/bin/drush
+ dodoc -r ${docs}
+ # cleanup
+ for i in ${docs} LICENSE.txt drush.bat examples includes/.gitignore ; do
+ rm -rf "${D}/usr/share/drush/${i}"
+ done
+
+ use examples && cp -R examples "${D}"/usr/share/doc/"${PF}"
+}