summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-08 23:59:24 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-08 23:59:24 +0000
commitbb99a98752f64616e96f1bf90929c716de4866f5 (patch)
treef6a9607b9a8964260a1247262fb5c5e42a994285
parentadd experimental USE flag wrt #502098 (diff)
downloadgentoo-2-bb99a98752f64616e96f1bf90929c716de4866f5.tar.gz
gentoo-2-bb99a98752f64616e96f1bf90929c716de4866f5.tar.bz2
gentoo-2-bb99a98752f64616e96f1bf90929c716de4866f5.zip
Clean up sysroot handling a bit -- no real functional changes.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--sys-devel/gdb/ChangeLog6
-rw-r--r--sys-devel/gdb/gdb-7.6.1.ebuild11
-rw-r--r--sys-devel/gdb/gdb-7.6.2.ebuild11
-rw-r--r--sys-devel/gdb/gdb-7.6.ebuild11
-rw-r--r--sys-devel/gdb/gdb-7.7.ebuild11
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild11
6 files changed, 35 insertions, 26 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 3f83e802ea1d..77e09fa35b4f 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.260 2014/03/08 23:09:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.261 2014/03/08 23:59:24 vapier Exp $
+
+ 08 Mar 2014; Mike Frysinger <vapier@gentoo.org> gdb-7.6.1.ebuild,
+ gdb-7.6.2.ebuild, gdb-7.6.ebuild, gdb-7.7.ebuild, gdb-9999.ebuild:
+ Clean up sysroot handling a bit -- no real functional changes.
08 Mar 2014; Mike Frysinger <vapier@gentoo.org> gdb-7.6.1.ebuild,
gdb-7.6.2.ebuild, gdb-7.6.ebuild, gdb-7.7.ebuild, gdb-9999.ebuild,
diff --git a/sys-devel/gdb/gdb-7.6.1.ebuild b/sys-devel/gdb/gdb-7.6.1.ebuild
index 2d61737dc9d4..d217294014c4 100644
--- a/sys-devel/gdb/gdb-7.6.1.ebuild
+++ b/sys-devel/gdb/gdb-7.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.1.ebuild,v 1.6 2014/03/08 23:09:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.1.ebuild,v 1.7 2014/03/08 23:59:24 vapier Exp $
EAPI="3"
@@ -98,14 +98,15 @@ gdb_branding() {
src_configure() {
strip-unsupported-flags
- local sysroot="${EPREFIX}"/usr/${CTARGET}
local myconf=(
--with-pkgversion="$(gdb_branding)"
--with-bugurl='http://bugs.gentoo.org/'
--disable-werror
- $(is_cross && echo \
- --with-sysroot="${sysroot}" \
- --includedir="${sysroot}/usr/include")
+ )
+ local sysroot="${EPREFIX}/usr/${CTARGET}"
+ is_cross && myconf+=(
+ --with-sysroot="${sysroot}"
+ --includedir="${sysroot}/usr/include"
)
if use server && ! use client ; then
diff --git a/sys-devel/gdb/gdb-7.6.2.ebuild b/sys-devel/gdb/gdb-7.6.2.ebuild
index f719b8fd96e1..dc64093b5291 100644
--- a/sys-devel/gdb/gdb-7.6.2.ebuild
+++ b/sys-devel/gdb/gdb-7.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.2.ebuild,v 1.9 2014/03/08 23:09:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.2.ebuild,v 1.10 2014/03/08 23:59:24 vapier Exp $
EAPI="3"
@@ -98,14 +98,15 @@ gdb_branding() {
src_configure() {
strip-unsupported-flags
- local sysroot="${EPREFIX}"/usr/${CTARGET}
local myconf=(
--with-pkgversion="$(gdb_branding)"
--with-bugurl='http://bugs.gentoo.org/'
--disable-werror
- $(is_cross && echo \
- --with-sysroot="${sysroot}" \
- --includedir="${sysroot}/usr/include")
+ )
+ local sysroot="${EPREFIX}/usr/${CTARGET}"
+ is_cross && myconf+=(
+ --with-sysroot="${sysroot}"
+ --includedir="${sysroot}/usr/include"
)
if use server && ! use client ; then
diff --git a/sys-devel/gdb/gdb-7.6.ebuild b/sys-devel/gdb/gdb-7.6.ebuild
index e3d5c310491d..a6b2110bed17 100644
--- a/sys-devel/gdb/gdb-7.6.ebuild
+++ b/sys-devel/gdb/gdb-7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.ebuild,v 1.6 2014/03/08 23:09:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.6.ebuild,v 1.7 2014/03/08 23:59:24 vapier Exp $
EAPI="3"
@@ -87,14 +87,15 @@ gdb_branding() {
src_configure() {
strip-unsupported-flags
- local sysroot="${EPREFIX}"/usr/${CTARGET}
local myconf=(
--with-pkgversion="$(gdb_branding)"
--with-bugurl='http://bugs.gentoo.org/'
--disable-werror
- $(is_cross && echo \
- --with-sysroot="${sysroot}" \
- --includedir="${sysroot}/usr/include")
+ )
+ local sysroot="${EPREFIX}/usr/${CTARGET}"
+ is_cross && myconf+=(
+ --with-sysroot="${sysroot}"
+ --includedir="${sysroot}/usr/include"
)
if use server && ! use client ; then
diff --git a/sys-devel/gdb/gdb-7.7.ebuild b/sys-devel/gdb/gdb-7.7.ebuild
index 26b198034e7a..69255bcdc599 100644
--- a/sys-devel/gdb/gdb-7.7.ebuild
+++ b/sys-devel/gdb/gdb-7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.2 2014/03/08 23:09:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.3 2014/03/08 23:59:24 vapier Exp $
EAPI="4"
@@ -98,17 +98,18 @@ gdb_branding() {
src_configure() {
strip-unsupported-flags
- local sysroot="${EPREFIX}"/usr/${CTARGET}
local myconf=(
--with-pkgversion="$(gdb_branding)"
--with-bugurl='http://bugs.gentoo.org/'
--disable-werror
- $(is_cross && echo \
- --with-sysroot="${sysroot}" \
- --includedir="${sysroot}/usr/include")
# Disable modules that are in a combined binutils/gdb tree. #490566
--disable-{binutils,etc,gas,gold,gprof,ld}
)
+ local sysroot="${EPREFIX}/usr/${CTARGET}"
+ is_cross && myconf+=(
+ --with-sysroot="${sysroot}"
+ --includedir="${sysroot}/usr/include"
+ )
if use server && ! use client ; then
# just configure+build in the gdbserver subdir to speed things up
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 13e471a68f63..ab725dbe355c 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.22 2014/03/08 23:09:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.23 2014/03/08 23:59:24 vapier Exp $
EAPI="4"
@@ -98,17 +98,18 @@ gdb_branding() {
src_configure() {
strip-unsupported-flags
- local sysroot="${EPREFIX}"/usr/${CTARGET}
local myconf=(
--with-pkgversion="$(gdb_branding)"
--with-bugurl='http://bugs.gentoo.org/'
--disable-werror
- $(is_cross && echo \
- --with-sysroot="${sysroot}" \
- --includedir="${sysroot}/usr/include")
# Disable modules that are in a combined binutils/gdb tree. #490566
--disable-{binutils,etc,gas,gold,gprof,ld}
)
+ local sysroot="${EPREFIX}/usr/${CTARGET}"
+ is_cross && myconf+=(
+ --with-sysroot="${sysroot}"
+ --includedir="${sysroot}/usr/include"
+ )
if use server && ! use client ; then
# just configure+build in the gdbserver subdir to speed things up