summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-06-17 03:14:24 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-06-17 03:14:24 +0000
commit9e1db802fc69e46cacbd1a9beb2187d8cf291eb8 (patch)
tree674e5858dbdf7cd22980f1423e7967f7eb515101
parentFix DEPEMD typo (diff)
downloadgentoo-2-9e1db802fc69e46cacbd1a9beb2187d8cf291eb8.tar.gz
gentoo-2-9e1db802fc69e46cacbd1a9beb2187d8cf291eb8.tar.bz2
gentoo-2-9e1db802fc69e46cacbd1a9beb2187d8cf291eb8.zip
Fix USE=-exif build failure (bug #552288, thanks to bill).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
-rw-r--r--media-gfx/eog/ChangeLog6
-rw-r--r--media-gfx/eog/eog-3.16.2.ebuild11
-rw-r--r--media-gfx/eog/files/eog-3.16.2-without-libexif.patch33
3 files changed, 47 insertions, 3 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index 29e34c4aacc7..83416739d4f7 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/eog
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.322 2015/06/09 16:26:48 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.323 2015/06/17 03:14:24 tetromino Exp $
+
+ 17 Jun 2015; Alexandre Rostovtsev <tetromino@gentoo.org> eog-3.16.2.ebuild,
+ +files/eog-3.16.2-without-libexif.patch:
+ Fix USE=-exif build failure (bug #552288, thanks to bill).
*eog-3.16.2 (09 Jun 2015)
diff --git a/media-gfx/eog/eog-3.16.2.ebuild b/media-gfx/eog/eog-3.16.2.ebuild
index 67052252762a..a0ca1072f61a 100644
--- a/media-gfx/eog/eog-3.16.2.ebuild
+++ b/media-gfx/eog/eog-3.16.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-3.16.2.ebuild,v 1.1 2015/06/09 16:26:48 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-3.16.2.ebuild,v 1.2 2015/06/17 03:14:24 tetromino Exp $
EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="The Eye of GNOME image viewer"
HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome"
@@ -43,6 +43,13 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751007
+ epatch "${FILESDIR}"/${PN}-3.16.2-without-libexif.patch
+
+ gnome2_src_prepare
+}
+
src_configure() {
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
gnome2_src_configure \
diff --git a/media-gfx/eog/files/eog-3.16.2-without-libexif.patch b/media-gfx/eog/files/eog-3.16.2-without-libexif.patch
new file mode 100644
index 000000000000..28ae948ee853
--- /dev/null
+++ b/media-gfx/eog/files/eog-3.16.2-without-libexif.patch
@@ -0,0 +1,33 @@
+From 29796d1f24a0a1ab2a463a9b1c33e05014d68132 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 16 Jun 2015 23:04:32 -0400
+Subject: [PATCH] EogMetadataSidebar: fix --without-libexif build
+
+https://bugzilla.gnome.org/show_bug.cgi?id=751007
+---
+ src/eog-metadata-sidebar.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/eog-metadata-sidebar.c b/src/eog-metadata-sidebar.c
+index bf07830..a08c617 100644
+--- a/src/eog-metadata-sidebar.c
++++ b/src/eog-metadata-sidebar.c
+@@ -408,6 +408,7 @@ eog_metadata_sidebar_class_init (EogMetadataSidebarClass *klass)
+ gtk_widget_class_bind_template_child_private (widget_class,
+ EogMetadataSidebar,
+ folder_label);
++#if HAVE_EXIF
+ gtk_widget_class_bind_template_child_private (widget_class,
+ EogMetadataSidebar,
+ aperture_label);
+@@ -432,6 +433,7 @@ eog_metadata_sidebar_class_init (EogMetadataSidebarClass *klass)
+ gtk_widget_class_bind_template_child_private (widget_class,
+ EogMetadataSidebar,
+ time_label);
++#endif /* HAVE_EXIF */
+ }
+
+
+--
+2.4.3
+