summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-07-31 15:33:00 +0000
committerBen de Groot <yngwin@gentoo.org>2013-07-31 15:33:00 +0000
commit9d32b23fcd2d77c68ed3d9d4a436ae7eff626288 (patch)
treee594f31648df79b6ca914a4b73df66e9ec555320
parentfixed license (bug #478944) (diff)
downloadgentoo-2-9d32b23fcd2d77c68ed3d9d4a436ae7eff626288.tar.gz
gentoo-2-9d32b23fcd2d77c68ed3d9d4a436ae7eff626288.tar.bz2
gentoo-2-9d32b23fcd2d77c68ed3d9d4a436ae7eff626288.zip
Version bump, implementing latest eapi, python-r1.eclass, no longer slotted boost, and general cleanup; with thanks to contributors in bug #478840
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 0x2B2474AD43CE296E!)
-rw-r--r--net-p2p/qbittorrent/ChangeLog9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.0.11.ebuild52
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild37
3 files changed, 74 insertions, 24 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index ca57ed39002e..cf6b0abb52a9 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.211 2013/07/17 19:17:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.212 2013/07/31 15:33:00 yngwin Exp $
+
+*qbittorrent-3.0.11 (31 Jul 2013)
+
+ 31 Jul 2013; Ben de Groot <yngwin@gentoo.org> +qbittorrent-3.0.11.ebuild,
+ qbittorrent-9999.ebuild:
+ Version bump, implementing latest eapi, python-r1.eclass, no longer slotted
+ boost, and general cleanup; with thanks to contributors in bug #478840
17 Jul 2013; Markus Meier <maekke@gentoo.org> qbittorrent-3.0.9.ebuild:
add ~arm, bug #473472
diff --git a/net-p2p/qbittorrent/qbittorrent-3.0.11.ebuild b/net-p2p/qbittorrent/qbittorrent-3.0.11.ebuild
new file mode 100644
index 000000000000..936816b45ab2
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.0.11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.0.11.ebuild,v 1.1 2013/07/31 15:33:00 yngwin Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus +X geoip"
+
+# python-2 is a runtime dep only, for the search engine (see INSTALL file)
+CDEPEND="dev-libs/boost
+ dev-qt/qtcore:4
+ >=net-libs/rb_libtorrent-0.16.3
+ X? ( dev-qt/qtgui:4 )
+ dbus? ( dev-qt/qtdbus:4 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libboost-inc=/usr/include/boost \
+ ${myconf} || die "configure failed"
+ eqmake4
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 4cc9e3bd1132..4cac71e89418 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.8 2013/03/02 23:09:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.9 2013/07/31 15:33:00 yngwin Exp $
-EAPI="4"
-PYTHON_DEPEND="2"
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
EGIT_REPO_URI="git://github.com/${PN}/qBittorrent.git
https://github.com/${PN}/qBittorrent.git"
-inherit python qt4-r2 versionator git-2
+inherit python-r1 qt4-r2 git-2
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
@@ -19,25 +19,20 @@ KEYWORDS=""
IUSE="dbus +X geoip"
-QT_MIN="4.6.1"
-# boost version so that we always have thread support
-CDEPEND="net-libs/rb_libtorrent
- >=dev-qt/qtcore-${QT_MIN}:4
- X? ( >=dev-qt/qtgui-${QT_MIN}:4 )
- dbus? ( >=dev-qt/qtdbus-${QT_MIN}:4 )
- dev-libs/boost"
+# python-2 is a runtime dep only, for the search engine (see INSTALL file)
+CDEPEND="dev-libs/boost
+ dev-qt/qtcore:4
+ net-libs/rb_libtorrent
+ X? ( dev-qt/qtgui:4 )
+ dbus? ( dev-qt/qtdbus:4 )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
geoip? ( dev-libs/geoip )"
DOCS="AUTHORS Changelog NEWS README TODO"
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
src_prepare() {
# Respect LDFLAGS
sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
@@ -50,13 +45,9 @@ src_configure() {
use geoip || myconf+=" --disable-geoip-database"
use dbus || myconf+=" --disable-qt-dbus"
- # slotted boost detection, bug #309415
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
-
# econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libboost-inc=/usr/include/boost \
+ ${myconf} || die "configure failed"
eqmake4
}