summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2009-04-05 23:23:41 +0000
committerMatti Bickel <mabi@gentoo.org>2009-04-05 23:23:41 +0000
commit96d5f7131d9a7874f838aaeb56dc9bedfa633517 (patch)
tree69993e907465532fae8c1d3cfd56493f6f8acec8
parentVersion bump (diff)
downloadgentoo-2-96d5f7131d9a7874f838aaeb56dc9bedfa633517.tar.gz
gentoo-2-96d5f7131d9a7874f838aaeb56dc9bedfa633517.tar.bz2
gentoo-2-96d5f7131d9a7874f838aaeb56dc9bedfa633517.zip
fix broken patches, cleanup
(Portage version: 2.1.6.11/cvs/Linux ppc)
-rw-r--r--dev-lang/lua/ChangeLog6
-rw-r--r--dev-lang/lua/files/lua-5.1-make-r1.patch10
-rw-r--r--dev-lang/lua/files/lua-5.1-make_static-r1.patch8
-rw-r--r--dev-lang/lua/lua-5.1.3-r4.ebuild113
4 files changed, 17 insertions, 120 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index 729bb0c1b15e..edac63b313a3 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.130 2009/04/04 16:43:55 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.131 2009/04/05 23:23:41 mabi Exp $
+
+ 05 Apr 2009; Matti Bickel <mabi@gentoo.org> files/lua-5.1-make-r1.patch,
+ files/lua-5.1-make_static-r1.patch, -lua-5.1.3-r4.ebuild:
+ fix broken patches, cleanup
04 Apr 2009; Matti Bickel <mabi@gentoo.org> lua-5.1.4.ebuild:
ppc stable (bug #255191)
diff --git a/dev-lang/lua/files/lua-5.1-make-r1.patch b/dev-lang/lua/files/lua-5.1-make-r1.patch
index b50620099564..8eecbdd40268 100644
--- a/dev-lang/lua/files/lua-5.1-make-r1.patch
+++ b/dev-lang/lua/files/lua-5.1-make-r1.patch
@@ -24,6 +24,12 @@
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
--- lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
+++ lua-5.1.1/src/Makefile 2006-11-16 02:10:27.000000000 +0100
+@@ -54,1 +54,1 @@
+-$(LUA_T): $(LUA_O) $(LUA_A)
++origin$(LUA_T): $(LUA_O) $(LUA_A)
+@@ -57,1 +57,1 @@
+-$(LUAC_T): $(LUAC_O) $(LUA_A)
++origin$(LUAC_T): $(LUAC_O) $(LUA_A)
@@ -176,3 +176,33 @@
ltm.h lzio.h lmem.h lopcodes.h lundump.h
@@ -46,7 +52,7 @@
+ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
+
+$(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ $(LUA_O::.o=.lo) $(LUA_LIBS) -llua
++ $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
+
+lua_test: $(LUA_O:.o=.lo) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -static -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
@@ -57,4 +63,4 @@
+gentoo_clean:
+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
+
-+gentoo_all: $(LIB_NAME) $(LIB_NAME:.la=.a) $(LUA_T) lua_test $(LUAC_T)
++gentoo_all: $(LIB_NAME) $(LUA_T) lua_test $(LUAC_T)
diff --git a/dev-lang/lua/files/lua-5.1-make_static-r1.patch b/dev-lang/lua/files/lua-5.1-make_static-r1.patch
index 2d3d1d31d6c4..a82e1c3baac5 100644
--- a/dev-lang/lua/files/lua-5.1-make_static-r1.patch
+++ b/dev-lang/lua/files/lua-5.1-make_static-r1.patch
@@ -2,11 +2,11 @@ diff -ru lua-5.1.1.orig/src/Makefile lua-5.1.1/src/Makefile
--- lua-5.1.1.orig/src/Makefile 2006-11-21 07:19:31 +0000
+++ lua-5.1.1/src/Makefile 2006-11-21 07:19:52 +0000
@@ -196,7 +196,7 @@
- -rpath $(RPATH) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
+ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
- $(LUA_T): $(LUA_O) $(LIB_NAME)
-- $(LIBTOOL) --mode=link $(CC) -export-dynamic -o $@ $(LUA_O:.o=.lo) $(LUA_LIBS) -llua
-+ $(LIBTOOL) --mode=link $(CC) -static -export-dynamic -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
+ $(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
+- $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LUA_LIBS) $(LUA_LIBS)
++ $(LIBTOOL) --mode=link $(CC) -static -export-dynamic $(LDFLAGS) -o $@ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
$(LUAC_T): $(LUAC_O:.o=.lo) $(LIB_NAME)
$(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O:.o=.lo) $(LIB_NAME)
diff --git a/dev-lang/lua/lua-5.1.3-r4.ebuild b/dev-lang/lua/lua-5.1.3-r4.ebuild
deleted file mode 100644
index 0249148bab2a..000000000000
--- a/dev-lang/lua/lua-5.1.3-r4.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.3-r4.ebuild,v 1.4 2008/09/13 20:24:39 solar Exp $
-
-EAPI="1"
-
-inherit eutils portability versionator toolchain-funcs
-
-DESCRIPTION="A powerful light-weight programming language designed for extending applications"
-HOMEPAGE="http://www.lua.org/"
-SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="+deprecated readline static"
-
-DEPEND="readline? ( sys-libs/readline )"
-
-src_unpack() {
- local PATCH_PV=$(get_version_component_range 1-2)
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
-
- EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch
-
- # correct lua versioning
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:3:1/' src/Makefile
-
- sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
-
- if ! use deprecated ; then
- epatch "${FILESDIR}"/${P}-deprecated.patch
- epatch "${FILESDIR}"/${P}-test.patch
- fi
-
- if ! use readline ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
- fi
-
- # Using dynamic linked lua is not recommended upstream for performance
- # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
- # Mainly, this is of concern if your arch is poor with GPRs, like x86
- # Not that this only affects the interpreter binary (named lua), not the lua
- # compiler (built statically) nor the lua libraries (both shared and static
- # are installed)
- if use static ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static.patch
- fi
-
- # We want packages to find our things...
- sed -i -e 's:/usr/local:/usr:' etc/lua.pc
-}
-
-src_compile() {
- tc-export CC
- myflags=
- # what to link to liblua
- liblibs="-lm"
- mycflags="${mycflags} -DLUA_USE_LINUX"
- liblibs="${liblibs} $(dlopen_lib)"
-
- # what to link to the executables
- mylibs=
- if use readline; then
- mylibs="-lreadline"
- fi
-
- cd src
- emake CC="${CC}" CFLAGS="${mycflags} ${CFLAGS}" \
- RPATH="${ROOT}/usr/$(get_libdir)/" \
- LUA_LIBS="${mylibs}" \
- LIB_LIBS="${liblibs}" \
- V=${PV} \
- gentoo_all || die "emake failed"
-
- mv lua_test ../test/lua.static
-}
-
-src_install() {
- emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
- V=${PV} gentoo_install \
- || die "emake install gentoo_install failed"
-
- dodoc HISTORY README
- dohtml doc/*.html doc/*.gif
-
- insinto /usr/share/pixmaps
- doins etc/lua.ico
- insinto /usr/$(get_libdir)/pkgconfig
- doins etc/lua.pc
-
- doman doc/lua.1 doc/luac.1
-}
-
-src_test() {
- local positive="bisect cf echo env factorial fib fibfor hello printf sieve
- sort trace-calls trace-globals"
- local negative="readonly"
- local test
-
- cd "${S}"
- for test in ${positive}; do
- test/lua.static test/${test}.lua || die "test $test failed"
- done
-
- for test in ${negative}; do
- test/lua.static test/${test}.lua && die "test $test failed"
- done
-}