summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-10-19 21:48:35 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-10-19 21:48:35 +0000
commit9642ad8e2df3dcfec247c7aa023f2fa40a6df1c3 (patch)
treee51e42bca2aeddbb040f875ba4f1f4a116824424
parentnew findutils (diff)
downloadgentoo-2-9642ad8e2df3dcfec247c7aa023f2fa40a6df1c3.tar.gz
gentoo-2-9642ad8e2df3dcfec247c7aa023f2fa40a6df1c3.tar.bz2
gentoo-2-9642ad8e2df3dcfec247c7aa023f2fa40a6df1c3.zip
New ebuild -- kde "biff" (new mail notification).
-rw-r--r--net-mail/kbiff/files/digest-kbiff-3.5.11
-rw-r--r--net-mail/kbiff/kbiff-3.5.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-mail/kbiff/files/digest-kbiff-3.5.1 b/net-mail/kbiff/files/digest-kbiff-3.5.1
new file mode 100644
index 000000000000..42b8a73909f3
--- /dev/null
+++ b/net-mail/kbiff/files/digest-kbiff-3.5.1
@@ -0,0 +1 @@
+MD5 ddd6553e52188a501356b788a1a94d5e kbiff-3.5.1.tar.bz2
diff --git a/net-mail/kbiff/kbiff-3.5.1.ebuild b/net-mail/kbiff/kbiff-3.5.1.ebuild
new file mode 100644
index 000000000000..db42c62b65b2
--- /dev/null
+++ b/net-mail/kbiff/kbiff-3.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/kbiff/kbiff-3.5.1.ebuild,v 1.1 2001/10/19 21:48:35 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="KDE new mail notification utility (biff)"
+SRC_URI="http://devel-home.kde.org/~granroth/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.granroth.org/kbiff/"
+
+#build-time dependencies
+DEPEND=">=kde-base/kdebase-2.0"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ #you must *personally verify* that this trick doesn't install
+ #anything outside of DESTDIR; do this by reading and understanding
+ #the install part of the Makefiles. Also note that this will often
+ #also work for autoconf stuff (usually much more often than DESTDIR,
+ #which is actually quite rare.
+
+ make prefix=${D}/usr install || die
+
+ make DESTDIR=${D} install || die
+ #again, verify the Makefiles! We don't want anything falling outside
+ #of ${D}.
+}
+