summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-09-30 14:41:17 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-09-30 14:41:17 +0000
commit91e7a3cf1ad7bc7cfa41e5556dc450783a370b81 (patch)
tree2055b4287678dc29e1ab92e5252ad82835e221cd
parentDrop keyword for old version (diff)
downloadgentoo-2-91e7a3cf1ad7bc7cfa41e5556dc450783a370b81.tar.gz
gentoo-2-91e7a3cf1ad7bc7cfa41e5556dc450783a370b81.tar.bz2
gentoo-2-91e7a3cf1ad7bc7cfa41e5556dc450783a370b81.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--app-text/mecab/ChangeLog7
-rw-r--r--app-text/mecab/mecab-0.98.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-text/mecab/ChangeLog b/app-text/mecab/ChangeLog
index 6a1c4050c103..182d964c8224 100644
--- a/app-text/mecab/ChangeLog
+++ b/app-text/mecab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/mecab
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.58 2009/08/16 08:36:11 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.59 2009/09/30 14:41:17 matsuu Exp $
+
+*mecab-0.98 (30 Sep 2009)
+
+ 30 Sep 2009; MATSUU Takuto <matsuu@gentoo.org> +mecab-0.98.ebuild:
+ Version bumped.
16 Aug 2009; Akinori Hattori <hattya@gentoo.org> -mecab-0.96.ebuild,
-mecab-0.97.ebuild:
diff --git a/app-text/mecab/mecab-0.98.ebuild b/app-text/mecab/mecab-0.98.ebuild
new file mode 100644
index 000000000000..472ce9332410
--- /dev/null
+++ b/app-text/mecab/mecab-0.98.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.98.ebuild,v 1.1 2009/09/30 14:41:17 matsuu Exp $
+
+EAPI="2"
+inherit autotools
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="unicode"
+
+RESTRICT="test"
+
+DEPEND="dev-lang/perl"
+PDEPEND=">=app-dicts/mecab-ipadic-2.7.0.20070610"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README || die
+ dohtml -r doc || die
+
+}