summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-11-05 02:40:46 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-11-05 02:40:46 +0000
commit8b8a59eaf093bbd9a228804244ca0a0997e4a0b2 (patch)
tree21468fa0bf1ffafb24b9cae5f7b9e82ad4e80e5a
parentversion bump (diff)
downloadgentoo-2-8b8a59eaf093bbd9a228804244ca0a0997e4a0b2.tar.gz
gentoo-2-8b8a59eaf093bbd9a228804244ca0a0997e4a0b2.tar.bz2
gentoo-2-8b8a59eaf093bbd9a228804244ca0a0997e4a0b2.zip
Initial release of xdaf to Gentoo. ~keyworded, but it should only need minimal testing
-rw-r--r--x11-misc/xdaf/ChangeLog15
-rw-r--r--x11-misc/xdaf/files/digest-xdaf-0.01.101
-rw-r--r--x11-misc/xdaf/xdaf-0.01.10.ebuild30
3 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/xdaf/ChangeLog b/x11-misc/xdaf/ChangeLog
new file mode 100644
index 000000000000..b092106e99b4
--- /dev/null
+++ b/x11-misc/xdaf/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for x11-misc/xdaf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header
+
+*xdaf-0.01.10 (4 Nov 2002)
+
+ 4 Nov 2002; Matt Keadle <mkeadle@gentoo.org> xdaf-0.01.10.ebuild
+ files/digest-xdaf-0.01.10:
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way.
+
+ The release version is actually called xdaf-A.01.10, but portage doesn't
+ like an ebuild with that name. Slight workaround with 0.01.10 and munging
+ inside the ebuild, but it works.
diff --git a/x11-misc/xdaf/files/digest-xdaf-0.01.10 b/x11-misc/xdaf/files/digest-xdaf-0.01.10
new file mode 100644
index 000000000000..d06984a5b1ac
--- /dev/null
+++ b/x11-misc/xdaf/files/digest-xdaf-0.01.10
@@ -0,0 +1 @@
+MD5 1e02311423e3ffa76e366a365dde22f9 xdaf-A.01.10.tar.gz 12592
diff --git a/x11-misc/xdaf/xdaf-0.01.10.ebuild b/x11-misc/xdaf/xdaf-0.01.10.ebuild
new file mode 100644
index 000000000000..b3d3545eced9
--- /dev/null
+++ b/x11-misc/xdaf/xdaf-0.01.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header
+
+MY_P="${PN}-A.01.10"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Small tool to provide visual feedback of local disks activity by changing the default X11 mouse pointer"
+SRC_URI="http://ezix.sourceforge.net/software/${MY_P}.tar.gz"
+HOMEPAGE="http://ezix.sourceforge.net/software/xdaf.html"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+
+ cd ${S}
+ xmkmf
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc COPYING README
+}