summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-04 15:41:47 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-04 15:41:47 +0000
commit8b24fbd2c10c7dafd3c4bd954258b60889051fd8 (patch)
tree828905e9bc50d0ecd6750885f975b00989e46770
parentInitial commit. (diff)
downloadgentoo-2-8b24fbd2c10c7dafd3c4bd954258b60889051fd8.tar.gz
gentoo-2-8b24fbd2c10c7dafd3c4bd954258b60889051fd8.tar.bz2
gentoo-2-8b24fbd2c10c7dafd3c4bd954258b60889051fd8.zip
Add ruby20 target
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--dev-ruby/abstract/ChangeLog7
-rw-r--r--dev-ruby/abstract/abstract-1.0.0-r2.ebuild24
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-ruby/abstract/ChangeLog b/dev-ruby/abstract/ChangeLog
index b78dc1b6eed1..fa2a925f934a 100644
--- a/dev-ruby/abstract/ChangeLog
+++ b/dev-ruby/abstract/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/abstract
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/abstract/ChangeLog,v 1.15 2013/09/09 02:48:07 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/abstract/ChangeLog,v 1.16 2013/10/04 15:41:47 mrueg Exp $
+
+*abstract-1.0.0-r2 (04 Oct 2013)
+
+ 04 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +abstract-1.0.0-r2.ebuild:
+ Add ruby20 target
09 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -abstract-1.0.0.ebuild:
Cleanup old.
diff --git a/dev-ruby/abstract/abstract-1.0.0-r2.ebuild b/dev-ruby/abstract/abstract-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..e5669000e2a9
--- /dev/null
+++ b/dev-ruby/abstract/abstract-1.0.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/abstract/abstract-1.0.0-r2.ebuild,v 1.1 2013/10/04 15:41:47 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library which enable you to define abstract method in Ruby."
+HOMEPAGE="http://rubyforge.org/projects/abstract"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test.rb || die "tests failed"
+}