summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-07-31 02:23:51 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-07-31 02:23:51 +0000
commit892ef4107678fbfc1646b8950d4239698b9a472a (patch)
tree2e60694938a8c9a74628136ec9a710866fb2d79b
parentAdded this to rc.d/init.d/mountall (diff)
downloadgentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.tar.gz
gentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.tar.bz2
gentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.zip
Finally getting around to committing some ebuilds I have been working on.
My first 2 ebuilds: freeciv and lrzsz gzip and gdbm just have small fixes to fix the info dir entry problem.
-rw-r--r--net-misc/lrzsz/files/digest-lrzsz-0.12.201
-rw-r--r--net-misc/lrzsz/lrzsz-0.12.20.ebuild37
-rw-r--r--sys-apps/gzip/files/digest-gzip-1.2.4a-r51
-rw-r--r--sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff15
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r5.ebuild80
-rw-r--r--sys-libs/gdbm/files/digest-gdbm-1.8.0-r31
-rw-r--r--sys-libs/gdbm/files/gdbm-1.8.0-r3-gentoo.diff175
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r3.ebuild39
8 files changed, 349 insertions, 0 deletions
diff --git a/net-misc/lrzsz/files/digest-lrzsz-0.12.20 b/net-misc/lrzsz/files/digest-lrzsz-0.12.20
new file mode 100644
index 000000000000..6ef729bf106b
--- /dev/null
+++ b/net-misc/lrzsz/files/digest-lrzsz-0.12.20
@@ -0,0 +1 @@
+MD5 b5ce6a74abc9b9eb2af94dffdfd372a4 lrzsz-0.12.20.tar.gz
diff --git a/net-misc/lrzsz/lrzsz-0.12.20.ebuild b/net-misc/lrzsz/lrzsz-0.12.20.ebuild
new file mode 100644
index 000000000000..a28c312df279
--- /dev/null
+++ b/net-misc/lrzsz/lrzsz-0.12.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Chad Huneycutt <chad.huneycutt@acm.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.5 2001/07/24 22:30:35 lordjoe Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="communication package providing the X, Y, and ZMODEM file transfer protocols"
+SRC_URI="http://www.ohse.de/uwe/releases/lrzsz-0.12.20.tar.gz"
+HOMEPAGE="http://www.ohse.de/uwe/software/lrzsz.html"
+
+DEPEND=""
+
+#RDEPEND=""
+
+src_compile() {
+ local options
+ if [ -z "`use nls`" ]; then
+ options=${options} --disable-nls
+ fi
+ CFLAGS="${CFLAGS} -Wstrict-prototypes" try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} ${options}
+
+ CFLAGS=${CFLAGS} -Wstrict-prototypes try emake
+}
+
+src_install () {
+ try make prefix=${D}/usr install
+
+ dosym /usr/bin/lrb /usr/bin/rb
+ dosym /usr/bin/lrx /usr/bin/rx
+ dosym /usr/bin/lrz /usr/bin/rz
+ dosym /usr/bin/lsb /usr/bin/sb
+ dosym /usr/bin/lsx /usr/bin/sx
+ dosym /usr/bin/lsz /usr/bin/sz
+
+ dodoc ABOUT-NLS AUTHORS COMPATABILITY COPYING ChangeLog NEWS README README.cvs README.gettext README.isdn4linux README.tests THANKS TODO
+}
+
diff --git a/sys-apps/gzip/files/digest-gzip-1.2.4a-r5 b/sys-apps/gzip/files/digest-gzip-1.2.4a-r5
new file mode 100644
index 000000000000..60ae475bc42e
--- /dev/null
+++ b/sys-apps/gzip/files/digest-gzip-1.2.4a-r5
@@ -0,0 +1 @@
+MD5 39053e044b18ecd0627f80fbe7cfeaad gzip-1.2.4a.tar.gz
diff --git a/sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff b/sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff
new file mode 100644
index 000000000000..863117e69f93
--- /dev/null
+++ b/sys-apps/gzip/files/gzip-1.2.4a-r5-gentoo.diff
@@ -0,0 +1,15 @@
+diff -r -C2 -P gzip-1.2.4a.orig/gzip.texi gzip-1.2.4a/gzip.texi
+*** gzip-1.2.4a.orig/gzip.texi Tue Feb 2 18:51:38 1999
+--- gzip-1.2.4a/gzip.texi Thu Jul 26 23:33:25 2001
+***************
+*** 8,11 ****
+--- 8,16 ----
+
+ @ifinfo
++
++ @dircategory Utilities
++ @direntry
++ * gzip: (gzip). The GNU compression utility.
++ @end direntry
+ This file documents the the GNU @code{gzip} command for compressing files.
+
diff --git a/sys-apps/gzip/gzip-1.2.4a-r5.ebuild b/sys-apps/gzip/gzip-1.2.4a-r5.ebuild
new file mode 100644
index 000000000000..db89644a7309
--- /dev/null
+++ b/sys-apps/gzip/gzip-1.2.4a-r5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# Chad Huneycutt <chad.huneycutt@acm.org>
+# /home/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r3.ebuild,v 1.1 2001/02/27 16:44:48 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU compressor"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
+ ftp://prep.ai.mit.edu/gnu/gzip/${A}"
+HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
+ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try pmake
+ else
+ try pmake LDFLAGS=-static ${MAKEOPTS}
+ fi
+}
+
+src_install() {
+
+ dodir /usr/bin /usr/share/man/man1
+ try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
+
+ cd ${D}/bin
+ for i in gzexe zforce zgrep zmore znew zcmp
+ do
+ cp ${i} ${i}.orig
+ sed -e "1d" -e "s:${D}::" ${i}.orig > ${i}
+ rm ${i}.orig
+ chmod 755 ${i}
+ done
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ cd ${D}/usr/share/man/man1
+
+ for i in gzexe gzip zcat zcmp zdiff zforce \
+ zgrep zmore znew
+ do
+ rm ${i}.1
+ ln -s gunzip.1.gz ${i}.1.gz
+ done
+
+ cd ${S}
+ rm -rf ${D}/usr/man ${D}/usr/lib
+
+ dodoc ChangeLog COPYING NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+ else
+ rm -rf ${D}/usr
+ fi
+}
+
+
+
+
diff --git a/sys-libs/gdbm/files/digest-gdbm-1.8.0-r3 b/sys-libs/gdbm/files/digest-gdbm-1.8.0-r3
new file mode 100644
index 000000000000..cb8535ca1a05
--- /dev/null
+++ b/sys-libs/gdbm/files/digest-gdbm-1.8.0-r3
@@ -0,0 +1 @@
+MD5 cd543862287f55ad66e62cc9d82cc906 gdbm-1.8.0.tar.gz
diff --git a/sys-libs/gdbm/files/gdbm-1.8.0-r3-gentoo.diff b/sys-libs/gdbm/files/gdbm-1.8.0-r3-gentoo.diff
new file mode 100644
index 000000000000..c5bdc8a6045b
--- /dev/null
+++ b/sys-libs/gdbm/files/gdbm-1.8.0-r3-gentoo.diff
@@ -0,0 +1,175 @@
+diff -r -C2 -P gdbm-1.8.0.orig/gdbm.info gdbm-1.8.0/gdbm.info
+*** gdbm-1.8.0.orig/gdbm.info Wed May 19 00:15:45 1999
+--- gdbm-1.8.0/gdbm.info Thu Jul 26 23:22:27 2001
+***************
+*** 1,4 ****
+! This is Info file gdbm.info, produced by Makeinfo version 1.68 from the
+! input file ./gdbm.texinfo.
+
+ This file documents the GNU dbm utility.
+--- 1,8 ----
+! This is gdbm.info, produced by makeinfo version 4.0 from gdbm.texinfo.
+!
+! START-INFO-DIR-ENTRY
+! * gdbm: (gdbm). library of functions implementing a hashed
+! database on a disk file.
+! END-INFO-DIR-ENTRY
+
+ This file documents the GNU dbm utility.
+***************
+*** 89,93 ****
+
+ `gdbm' is currently distributed under the terms of the GNU General
+! Public License, Version 2. (*NOT* under the GNU General Library Public
+ License.) A copy the GNU General Public License is included with the
+ distribution of `gdbm'.
+--- 93,97 ----
+
+ `gdbm' is currently distributed under the terms of the GNU General
+! Public License, Version 2. (_NOT_ under the GNU General Library Public
+ License.) A copy the GNU General Public License is included with the
+ distribution of `gdbm'.
+***************
+*** 102,106 ****
+ extendible hashing and works similar to the standard UNIX `dbm'
+ functions. These routines are provided to a programmer needing to
+! create and manipulate a hashed database. (`gdbm' is *NOT* a complete
+ database package for an end user.)
+
+--- 106,110 ----
+ extendible hashing and works similar to the standard UNIX `dbm'
+ functions. These routines are provided to a programmer needing to
+! create and manipulate a hashed database. (`gdbm' is _NOT_ a complete
+ database package for an end user.)
+
+***************
+*** 452,456 ****
+
+ Unless your database was opened with the GDBM_SYNC flag, `gdbm' does
+! not wait for writes to the disk to complete before continuing. This
+ allows faster writing of databases at the risk of having a corrupted
+ database if the application terminates in an abnormal fashion. The
+--- 456,460 ----
+
+ Unless your database was opened with the GDBM_SYNC flag, `gdbm' does
+! not wait for writes to be flushed to the disk before continuing. This
+ allows faster writing of databases at the risk of having a corrupted
+ database if the application terminates in an abnormal fashion. The
+***************
+*** 522,527 ****
+ GDBM_FASTMODE - Set fast mode to either on or off. This allows
+ fast mode to be toggled on an already open and active database.
+! value (see below) should be set to either TRUE or FALSE. *This
+! option is now obsolete.*
+
+ GDBM_SYNCMODE - Turn on or off file system synchronization
+--- 526,531 ----
+ GDBM_FASTMODE - Set fast mode to either on or off. This allows
+ fast mode to be toggled on an already open and active database.
+! value (see below) should be set to either TRUE or FALSE. _This
+! option is now obsolete._
+
+ GDBM_SYNCMODE - Turn on or off file system synchronization
+***************
+*** 532,538 ****
+ The default is off, which is how previous versions of `Gdbm' handled
+ free blocks. If set, this option causes all subsequent free blocks
+! to be placed in the *global* pool, allowing (in theory) more file
+ space to be reused more quickly. value (see below) should be set to
+! either TRUE or FALSE. *NOTICE: This feature is still under study.*
+
+ GDBM_COALESCEBLKS - Set free block merging to either on or off.
+--- 536,542 ----
+ The default is off, which is how previous versions of `Gdbm' handled
+ free blocks. If set, this option causes all subsequent free blocks
+! to be placed in the _global_ pool, allowing (in theory) more file
+ space to be reused more quickly. value (see below) should be set to
+! either TRUE or FALSE. _NOTICE: This feature is still under study._
+
+ GDBM_COALESCEBLKS - Set free block merging to either on or off.
+***************
+*** 541,546 ****
+ merged. This can become a CPU expensive process with time, though,
+ especially if used in conjunction with GDBM_CENTFREE. value (see below)
+! should be set to either TRUE or FALSE. *NOTICE: This feature is
+! still under study.*
+
+ The return value will be -1 upon failure, or 0 upon success. The
+--- 545,550 ----
+ merged. This can become a CPU expensive process with time, though,
+ especially if used in conjunction with GDBM_CENTFREE. value (see below)
+! should be set to either TRUE or FALSE. _NOTICE: This feature is
+! still under study._
+
+ The return value will be -1 upon failure, or 0 upon success. The
+***************
+*** 574,577 ****
+--- 578,583 ----
+ The pointer returned by `gdbm_open'.
+
++ The return value will be the file descriptor of the database.
++
+ 
+ File: gdbm.info, Node: Variables, Next: Compatibility, Prev: Locking, Up: Top
+***************
+*** 586,590 ****
+ (`gdbm.h' has the definitions of the error values).
+
+! const char * gdbm_version
+ The string containing the version information.
+
+--- 592,596 ----
+ (`gdbm.h' has the definitions of the error values).
+
+! char * gdbm_version
+ The string containing the version information.
+
+***************
+*** 727,749 ****
+ 
+ Tag Table:
+! Node: Top775
+! Node: Copying2247
+! Node: Intro4029
+! Node: List5445
+! Node: Open6397
+! Node: Close9268
+! Node: Store9703
+! Node: Fetch11498
+! Node: Delete12747
+! Node: Sequential13413
+! Node: Reorganization15096
+! Node: Sync16051
+! Node: Errors17015
+! Node: Options17375
+! Node: Locking19724
+! Node: Variables20246
+! Node: Compatibility20676
+! Node: Conversion23050
+! Node: Bugs23864
+ 
+ End Tag Table
+--- 733,755 ----
+ 
+ Tag Table:
+! Node: Top878
+! Node: Copying2350
+! Node: Intro4132
+! Node: List5548
+! Node: Open6500
+! Node: Close9371
+! Node: Store9806
+! Node: Fetch11601
+! Node: Delete12850
+! Node: Sequential13516
+! Node: Reorganization15199
+! Node: Sync16154
+! Node: Errors17120
+! Node: Options17480
+! Node: Locking19829
+! Node: Variables20417
+! Node: Compatibility20841
+! Node: Conversion23215
+! Node: Bugs24029
+ 
+ End Tag Table
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r3.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r3.ebuild
new file mode 100644
index 000000000000..326cfba9d785
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.8.0-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# Chad Huneycutt <chad.huneycutt@acm.org>
+# /home/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r2.ebuild,v 1.3 2001/03/06 05:27:28 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gdbm/${A}
+ ftp://prep.ai.mit.edu/gnu/gdbm/${A}"
+
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+
+DEPEND="virtual/glibc
+ berkdb? ( =sys-libs/db-1.85-r1 )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
+ try make CFLAGS=\"${CFLAGS} -fomit-frame-pointer\" ${MAKEOPTS}
+}
+
+src_install() {
+
+ try make prefix=${D}/usr man3dir=${D}/usr/share/man/man3 \
+ infodir=${D}/usr/share/info install
+
+ dodoc COPYING ChangeLog NEWS README
+
+}