summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2002-11-02 15:48:23 +0000
committerChad Huneycutt <chadh@gentoo.org>2002-11-02 15:48:23 +0000
commit7b5212651edaced7b01291356b7ebe5625bc28b7 (patch)
treeb24296eee6c975f894e341573d78780e3ebdbac3
parentAdded patch (diff)
downloadgentoo-2-7b5212651edaced7b01291356b7ebe5625bc28b7.tar.gz
gentoo-2-7b5212651edaced7b01291356b7ebe5625bc28b7.tar.bz2
gentoo-2-7b5212651edaced7b01291356b7ebe5625bc28b7.zip
still wasn't working with xforms-1.0_pre4. This should fix it.
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r1.ebuild7
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r2.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r1.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r1.ebuild
index e76ff13f6b3c..0e090ea43615 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r1.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r1.ebuild,v 1.1 2002/10/21 22:57:41 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r1.ebuild,v 1.2 2002/11/02 15:48:23 chadh Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PCMCIA tools for Linux"
@@ -96,9 +96,12 @@ src_compile() {
# rather than the currently-running kernel. It's Gentoo Linux policy to configure for
# the kernel in /usr/src/linux
- sed -e "s/^HAS_FORMS=y/HAS_FORMS=n/" config.out > config.out.sed
+ sed -e "/^HAS_FORMS/d" config.out > config.out.sed
+ sed -e "/^HAS_FORMS/d" config.mk > config.mk.sed
sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out.sed > config.out
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.mk.sed > config.mk
rm -f config.out.sed
+ rm -f config.mk.sed
emake all || die "failed compiling"
}
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r2.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r2.ebuild
index 61c61f234bd4..477241a8864d 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r2.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r2.ebuild,v 1.1 2002/10/21 23:33:17 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.1-r2.ebuild,v 1.2 2002/11/02 15:48:23 chadh Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PCMCIA tools for Linux"
@@ -103,9 +103,12 @@ src_compile() {
# rather than the currently-running kernel. It's Gentoo Linux policy to configure for
# the kernel in /usr/src/linux
- sed -e "s/^HAS_FORMS=y/HAS_FORMS=n/" config.out > config.out.sed
+ sed -e "/^HAS_FORMS/d" config.out > config.out.sed
+ sed -e "/^HAS_FORMS/d" config.mk > config.mk.sed
sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out.sed > config.out
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.mk.sed > config.mk
rm -f config.out.sed
+ rm -f config.mk.sed
emake all || die "failed compiling"
}