summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-03-29 00:01:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-03-29 00:01:12 +0000
commit74964ae93e0e7e484604f7a57a23339e48e14ebd (patch)
tree95138767ebd457bb54e3816de698a96dbd499281
parentDisable tooldir related hack that breaks --libdir usage #462814 by Thomas Sac... (diff)
downloadgentoo-2-74964ae93e0e7e484604f7a57a23339e48e14ebd.tar.gz
gentoo-2-74964ae93e0e7e484604f7a57a23339e48e14ebd.tar.bz2
gentoo-2-74964ae93e0e7e484604f7a57a23339e48e14ebd.zip
export XDG_CONFIG_HOME to workaround sandbox problems. Bug #463380
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
-rw-r--r--app-doc/devmanual/ChangeLog6
-rw-r--r--app-doc/devmanual/devmanual-0_pre20130309.ebuild12
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild12
3 files changed, 27 insertions, 3 deletions
diff --git a/app-doc/devmanual/ChangeLog b/app-doc/devmanual/ChangeLog
index ada2f04c7789..364adf86ec4a 100644
--- a/app-doc/devmanual/ChangeLog
+++ b/app-doc/devmanual/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-doc/devmanual
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/ChangeLog,v 1.7 2013/03/09 17:13:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/ChangeLog,v 1.8 2013/03/29 00:01:12 hwoarang Exp $
+
+ 29 Mar 2013; Markos Chandras <hwoarang@gentoo.org>
+ devmanual-0_pre20130309.ebuild, devmanual-9999.ebuild:
+ export XDG_CONFIG_HOME to workaround sandbox problems. Bug #463380
*devmanual-0_pre20130309 (09 Mar 2013)
diff --git a/app-doc/devmanual/devmanual-0_pre20130309.ebuild b/app-doc/devmanual/devmanual-0_pre20130309.ebuild
index 3195c45cf412..b7b6633c0415 100644
--- a/app-doc/devmanual/devmanual-0_pre20130309.ebuild
+++ b/app-doc/devmanual/devmanual-0_pre20130309.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/devmanual-0_pre20130309.ebuild,v 1.1 2013/03/09 17:13:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/devmanual-0_pre20130309.ebuild,v 1.2 2013/03/29 00:01:12 hwoarang Exp $
EAPI=5
@@ -29,6 +29,16 @@ DOC_CONTENTS="In order to browse the Gentoo Development Guide in
offline mode, point your browser to the following url:
/usr/share/doc/devmanual/html/index.html"
+src_compile() {
+ # Imagemagick uses inkscape (if present) to delegate
+ # svg conversions.
+ # Inkscape uses g_get_user_config_dir () which in turn
+ # uses XDG_CONFIG_HOME to get the config directory for this
+ # user. See bug 463380
+ export XDG_CONFIG_HOME="${T}/inkscape_home"
+ emake
+}
+
src_install() {
dohtml -r *
einfo "Creating symlink from ${P} to ${PN} for preserving bookmarks"
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 88b87e41fc17..4992481fe7f9 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/devmanual-9999.ebuild,v 1.7 2013/03/09 17:13:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/devmanual/devmanual-9999.ebuild,v 1.8 2013/03/29 00:01:12 hwoarang Exp $
EAPI=5
@@ -24,6 +24,16 @@ DOC_CONTENTS="In order to browse the Gentoo Development Guide in
offline mode, point your browser to the following url:
/usr/share/doc/devmanual/html/index.html"
+src_compile() {
+ # Imagemagick uses inkscape (if present) to delegate
+ # svg conversions.
+ # Inkscape uses g_get_user_config_dir () which in turn
+ # uses XDG_CONFIG_HOME to get the config directory for this
+ # user. See bug 463380
+ export XDG_CONFIG_HOME="${T}/inkscape_home"
+ emake
+}
+
src_install() {
dohtml -r *
einfo "Creating symlink from ${P} to ${PN} for preserving bookmarks"