summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-10-16 20:42:15 +0000
committerMike Gilbert <floppym@gentoo.org>2012-10-16 20:42:15 +0000
commit6dd119330d1a99fd45a581498efedc87ebf02841 (patch)
tree9cfc0acace6fdf3f1e9b83295d24d206acdda5f4
parentsci-libs/mc: Remove virtual/fortran and always call fortran-2_pkg_setup as in... (diff)
downloadgentoo-2-6dd119330d1a99fd45a581498efedc87ebf02841.tar.gz
gentoo-2-6dd119330d1a99fd45a581498efedc87ebf02841.tar.bz2
gentoo-2-6dd119330d1a99fd45a581498efedc87ebf02841.zip
Apply upstream patch to fix TFTP issue, bug 438612 by Alexander Zubkov.
(Portage version: 2.2.0_alpha138/cvs/Linux x86_64, signed Manifest commit with key EA4843A4)
-rw-r--r--sys-boot/grub/ChangeLog9
-rw-r--r--sys-boot/grub/files/grub-2.00-tftp-endian.patch24
-rw-r--r--sys-boot/grub/grub-2.00-r1.ebuild (renamed from sys-boot/grub/grub-2.00.ebuild)3
-rw-r--r--sys-boot/grub/grub-9999.ebuild3
4 files changed, 36 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 4ce33a6dbb8d..ac6f72094e69 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.238 2012/10/11 02:14:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.239 2012/10/16 20:42:15 floppym Exp $
+
+*grub-2.00-r1 (16 Oct 2012)
+
+ 16 Oct 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/grub-2.00-tftp-endian.patch, +grub-2.00-r1.ebuild, -grub-2.00.ebuild,
+ grub-9999.ebuild:
+ Apply upstream patch to fix TFTP issue, bug 438612 by Alexander Zubkov.
11 Oct 2012; Mike Gilbert <floppym@gentoo.org> grub-2.00.ebuild,
grub-9999.ebuild:
diff --git a/sys-boot/grub/files/grub-2.00-tftp-endian.patch b/sys-boot/grub/files/grub-2.00-tftp-endian.patch
new file mode 100644
index 000000000000..f4e56445dd59
--- /dev/null
+++ b/sys-boot/grub/files/grub-2.00-tftp-endian.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/show_bug.cgi?id=438612
+
+=== modified file 'grub-core/net/tftp.c'
+--- grub-core/net/tftp.c 2012-06-22 20:04:16 +0000
++++ grub-core/net/tftp.c 2012-07-02 09:22:50 +0000
+@@ -143,7 +143,7 @@
+
+ tftph_ack = (struct tftphdr *) nb_ack.data;
+ tftph_ack->opcode = grub_cpu_to_be16 (TFTP_ACK);
+- tftph_ack->u.ack.block = block;
++ tftph_ack->u.ack.block = grub_cpu_to_be16 (block);
+
+ err = grub_net_send_udp_packet (data->sock, &nb_ack);
+ if (err)
+@@ -225,7 +225,7 @@
+ grub_priority_queue_pop (data->pq);
+
+ if (file->device->net->packs.count < 50)
+- err = ack (data, tftph->u.data.block);
++ err = ack (data, data->block + 1);
+ else
+ {
+ file->device->net->stall = 1;
+
diff --git a/sys-boot/grub/grub-2.00.ebuild b/sys-boot/grub/grub-2.00-r1.ebuild
index c30a0dd26021..6334155dfed8 100644
--- a/sys-boot/grub/grub-2.00.ebuild
+++ b/sys-boot/grub/grub-2.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.17 2012/10/11 02:14:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00-r1.ebuild,v 1.1 2012/10/16 20:42:15 floppym Exp $
EAPI=4
@@ -221,6 +221,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
epatch "${FILESDIR}/${P}-config-quoting.patch" #426364
+ epatch "${FILESDIR}/${P}-tftp-endian.patch" # 438612
fi
# fix texinfo file name, bug 416035
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 6f08a45a86e0..75aa2cd6df6f 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.82 2012/10/11 02:14:09 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.83 2012/10/16 20:42:15 floppym Exp $
EAPI=4
@@ -221,6 +221,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
epatch "${FILESDIR}/${P}-config-quoting.patch" #426364
+ epatch "${FILESDIR}/${P}-tftp-endian.patch" # 438612
fi
# fix texinfo file name, bug 416035