summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-11 19:04:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-11 19:04:23 +0000
commit6d462a39fe1bd65885082dacb790ff3c54c8417a (patch)
tree166641bd40f2bcdb76b732325c4db3bd66106359
parentstable ppc, bug #449230, thanks vincent (diff)
downloadgentoo-2-6d462a39fe1bd65885082dacb790ff3c54c8417a.tar.gz
gentoo-2-6d462a39fe1bd65885082dacb790ff3c54c8417a.tar.bz2
gentoo-2-6d462a39fe1bd65885082dacb790ff3c54c8417a.zip
migrate to distutils-r1, respect games variables
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
-rw-r--r--games-emulation/gfceux/ChangeLog9
-rw-r--r--games-emulation/gfceux/gfceux-2.1.1-r1.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/games-emulation/gfceux/ChangeLog b/games-emulation/gfceux/ChangeLog
index 59a3308036df..147e53907d3d 100644
--- a/games-emulation/gfceux/ChangeLog
+++ b/games-emulation/gfceux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/gfceux
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/ChangeLog,v 1.4 2011/04/06 20:02:40 arfrever Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/ChangeLog,v 1.5 2013/01/11 19:04:23 hasufell Exp $
+
+*gfceux-2.1.1-r1 (11 Jan 2013)
+
+ 11 Jan 2013; Julian Ospald <hasufell@gentoo.org> +gfceux-2.1.1-r1.ebuild:
+ migrate to distutils-r1, respect games variables
06 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gfceux-2.1.1.ebuild:
diff --git a/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..48dc700fa1df
--- /dev/null
+++ b/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gfceux/gfceux-2.1.1-r1.ebuild,v 1.1 2013/01/11 19:04:23 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+# inherit base explicitly to avoid overrides on distutils-r1
+inherit base eutils gnome2-utils distutils-r1 games
+
+DESCRIPTION="A graphical frontend for the FCEUX emulator"
+HOMEPAGE="http://fceux.com"
+SRC_URI="mirror://sourceforge/fceultra/fceux-${PV}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk"
+RDEPEND="${DEPEND}
+ games-emulation/fceux"
+
+S=${WORKDIR}/${PN}
+
+python_prepare_all() {
+ sed -i \
+ -e "s#data/gfceux.glade#${GAMES_DATADIR}/${PN}/gfceux.glade#" \
+ src/main.py || die
+}
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doicon -s 48 data/${PN}.png
+ newicon -s 128 data/${PN}_big.png ${PN}.png
+
+ # respect games variables
+ dodir "${GAMES_DATADIR}"/${PN}
+ mv "${ED}"/usr/share/${PN}/* "${ED}${GAMES_DATADIR}"/${PN}/ || die
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}