summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-01-09 18:01:15 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-01-09 18:01:15 +0000
commit680d83a404f09e23afee226ff49200f3656f3c8e (patch)
tree2b99da6f0e6fd561319f9187fd06f21ff2d26e4a
parentCompile fix: for USE=minimal, we need to remove mod_magnet as well. (diff)
downloadgentoo-2-680d83a404f09e23afee226ff49200f3656f3c8e.tar.gz
gentoo-2-680d83a404f09e23afee226ff49200f3656f3c8e.tar.bz2
gentoo-2-680d83a404f09e23afee226ff49200f3656f3c8e.zip
Added layman-1.0.10 to the tree. Fixes bugs #159695 and #160143.
(Portage version: 2.1.1)
-rw-r--r--app-portage/layman/ChangeLog8
-rw-r--r--app-portage/layman/files/digest-layman-1.0.103
-rw-r--r--app-portage/layman/layman-1.0.10.ebuild76
3 files changed, 86 insertions, 1 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
index 445cbc3f5a47..03df65ce686a 100644
--- a/app-portage/layman/ChangeLog
+++ b/app-portage/layman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/layman
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.32 2007/01/04 11:33:57 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.33 2007/01/09 18:01:15 wrobel Exp $
+
+*layman-1.0.10 (09 Jan 2007)
+
+ 09 Jan 2007; <wrobel@gentoo.org> -layman-1.0.9.ebuild,
+ +layman-1.0.10.ebuild:
+ Added layman-1.0.10 to the tree. Fixes bugs #159695 and #160143.
*layman-1.0.9 (04 Jan 2007)
diff --git a/app-portage/layman/files/digest-layman-1.0.10 b/app-portage/layman/files/digest-layman-1.0.10
new file mode 100644
index 000000000000..aa6cb1c52867
--- /dev/null
+++ b/app-portage/layman/files/digest-layman-1.0.10
@@ -0,0 +1,3 @@
+MD5 24a76ba254431e48856b7965658c03ef layman-1.0.10.tar.gz 34384
+RMD160 67442e123d468f4cc8284d34e49ded75178e4a52 layman-1.0.10.tar.gz 34384
+SHA256 c0b3bb5b6609ebbecaf4270d2ef7deb33e1ec61f72755a31d3dd7ca49d1acf03 layman-1.0.10.tar.gz 34384
diff --git a/app-portage/layman/layman-1.0.10.ebuild b/app-portage/layman/layman-1.0.10.ebuild
new file mode 100644
index 000000000000..f540805d44c8
--- /dev/null
+++ b/app-portage/layman/layman-1.0.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.0.10.ebuild,v 1.1 2007/01/09 18:01:15 wrobel Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="A python script for retrieving gentoo overlays."
+HOMEPAGE="http://projects.gunnarwrobel.de/scripts"
+SRC_URI="http://build.pardus.de/downloads/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND="dev-util/subversion"
+
+pkg_setup() {
+ if built_with_use dev-util/subversion nowebdav; then
+ eerror "You must rebuild your subversion without the nowebdav USE flag"
+ die "You must rebuild your subversion without the nowebdav USE flag"
+ fi
+}
+
+src_install() {
+
+ distutils_src_install
+
+ dodir /etc/layman
+ cp etc/* ${D}/etc/layman/
+
+ doman doc/layman.8
+ dohtml doc/layman.8.html
+
+}
+
+src_test() {
+ cd ${S}
+ einfo "Running layman doctests..."
+ echo
+ if ! PYTHONPATH="." ${python} layman/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+}
+
+pkg_postinst() {
+ einfo "You are now ready to add overlays into your system."
+ einfo
+ einfo "layman -L"
+ einfo
+ einfo "will display a list of available overlays."
+ einfo
+ ewarn "Use the -k switch to also list overlays that are"
+ ewarn "considered less secure."
+ einfo
+ elog "Select an overlay and add it using"
+ einfo
+ elog "layman -a overlay-name"
+ einfo
+ elog "If this is the very first overlay you add with layman,"
+ elog "you need to append the following statement to your"
+ elog "/etc/make.conf file:"
+ elog
+ elog "source /usr/portage/local/layman/make.conf"
+ elog
+ elog "If you modify the 'storage' parameter in the layman"
+ elog "configuration file (/etc/layman/layman.cfg) you will"
+ elog "need to adapt the path given above to the new storage"
+ elog "directory."
+ einfo
+ ewarn "Please add the 'source' statement to make.conf only AFTER "
+ ewarn "you added your first overlay. Otherwise portage will fail."
+ epause 5
+}