summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-07-20 14:34:15 +0000
committerCédric Krier <cedk@gentoo.org>2008-07-20 14:34:15 +0000
commit6401027cc2fcf58e2ecec7d47e6875f0a4ae5b53 (patch)
tree03f9fd01ef5676cd6a5abfa16c60df6b6fc297ec
parentRemoving vulnerable versions. (diff)
downloadgentoo-2-6401027cc2fcf58e2ecec7d47e6875f0a4ae5b53.tar.gz
gentoo-2-6401027cc2fcf58e2ecec7d47e6875f0a4ae5b53.tar.bz2
gentoo-2-6401027cc2fcf58e2ecec7d47e6875f0a4ae5b53.zip
Add patch for bug #231044
(Portage version: 2.1.4.4)
-rw-r--r--x11-misc/dmenu/ChangeLog8
-rw-r--r--x11-misc/dmenu/dmenu-3.7-r1.ebuild56
-rw-r--r--x11-misc/dmenu/files/dmenu-3.7.patch17
3 files changed, 80 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index 020800e1a21a..06865c0a4127 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.32 2008/07/18 11:05:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.33 2008/07/20 14:34:14 cedk Exp $
+
+*dmenu-3.7-r1 (20 Jul 2008)
+
+ 20 Jul 2008; Cédric Krier <cedk@gentoo.org> +files/dmenu-3.7.patch,
+ +dmenu-3.7-r1.ebuild:
+ Add patch for bug #231044
16 Jul 2008; Alexis Ballier <aballier@gentoo.org> dmenu-3.7.ebuild:
keyword ~x86-fbsd, thanks to Davide Italiano <dav_it@gentoo.org>, bug
diff --git a/x11-misc/dmenu/dmenu-3.7-r1.ebuild b/x11-misc/dmenu/dmenu-3.7-r1.ebuild
new file mode 100644
index 000000000000..944145dfcf3d
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-3.7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-3.7-r1.ebuild,v 1.1 2008/07/20 14:34:14 cedk Exp $
+
+inherit toolchain-funcs savedconfig eutils
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.suckless.org/programs/dmenu.html"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS += -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ config.mk || die "sed failed"
+
+ epatch "${FILESDIR}/${P}.patch"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+}
diff --git a/x11-misc/dmenu/files/dmenu-3.7.patch b/x11-misc/dmenu/files/dmenu-3.7.patch
new file mode 100644
index 000000000000..44bb70154846
--- /dev/null
+++ b/x11-misc/dmenu/files/dmenu-3.7.patch
@@ -0,0 +1,17 @@
+diff -ru dmenu-3.7~/dmenu.c dmenu-3.7/dmenu.c
+--- dmenu-3.7~/dmenu.c 2008-07-20 16:26:14.000000000 +0200
++++ dmenu-3.7/dmenu.c 2008-07-20 16:27:01.000000000 +0200
+@@ -477,11 +477,11 @@
+ calcoffsets();
+ break;
+ case XK_Return:
+- if((e->state & ShiftMask) && text)
++ if((e->state & ShiftMask) && *text)
+ fprintf(stdout, "%s", text);
+ else if(sel)
+ fprintf(stdout, "%s", sel->text);
+- else if(text)
++ else if(*text)
+ fprintf(stdout, "%s", text);
+ fflush(stdout);
+ running = False;