summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-25 22:25:34 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-25 22:25:34 +0000
commit5db50da1ce466abab9216e7d117effbf3bc5bdfe (patch)
tree1c4589956c55696f159684fb643216842cb4d6d3
parentFix the libbz2.so symlink #93867 and ldscript by psm. (diff)
downloadgentoo-2-5db50da1ce466abab9216e7d117effbf3bc5bdfe.tar.gz
gentoo-2-5db50da1ce466abab9216e7d117effbf3bc5bdfe.tar.bz2
gentoo-2-5db50da1ce466abab9216e7d117effbf3bc5bdfe.zip
add boundschecking support
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.0.01
-rw-r--r--sys-devel/gcc/gcc-4.0.0.ebuild18
2 files changed, 10 insertions, 9 deletions
diff --git a/sys-devel/gcc/files/digest-gcc-4.0.0 b/sys-devel/gcc/files/digest-gcc-4.0.0
index e19d8526f195..3b796b9dd935 100644
--- a/sys-devel/gcc/files/digest-gcc-4.0.0
+++ b/sys-devel/gcc/files/digest-gcc-4.0.0
@@ -1 +1,2 @@
MD5 55ee7df1b29f719138ec063c57b89db6 gcc-4.0.0.tar.bz2 31338477
+MD5 a49a70c99ac589efb5c6c39f37986b88 bounds-checking-gcc-4.0.0-1.00.patch.bz2 820067
diff --git a/sys-devel/gcc/gcc-4.0.0.ebuild b/sys-devel/gcc/gcc-4.0.0.ebuild
index 70e7aa99cd19..b4fa27e14f3b 100644
--- a/sys-devel/gcc/gcc-4.0.0.ebuild
+++ b/sys-devel/gcc/gcc-4.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.0.ebuild,v 1.2 2005/05/10 18:10:37 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.0.ebuild,v 1.3 2005/05/25 22:25:34 vapier Exp $
+
+HTB_VER="1.00"
ETYPE="gcc-compiler"
@@ -12,8 +14,7 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-*"
-RDEPEND="virtual/libc
- >=sys-devel/gcc-config-1.3.1
+RDEPEND=">=sys-devel/gcc-config-1.3.1
>=sys-libs/zlib-1.1.4
!sys-devel/hardened-gcc
!uclibc? (
@@ -41,15 +42,14 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.15.97"
-PDEPEND="sys-devel/gcc-config
- !nocxx? ( !n32? ( !n64? ( !uclibc? ( !build? ( sys-libs/libstdc++-v3 ) ) ) ) )"
+PDEPEND="sys-devel/gcc-config"
src_unpack() {
gcc_src_unpack
-
- cd ${S}
- for x in $(cat /tmp/gcc4/list); do
- [[ -f /tmp/gcc4/${x} ]] && epatch "/tmp/gcc4/${x}"
+ cd "${S}"
+ [[ ! -e /root/gcc4/list ]] && return 0
+ for x in $(</root/gcc4/list) ; do
+ [[ -f /root/gcc4/${x} ]] && epatch "/root/gcc4/${x}"
done
}