summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-10 17:09:55 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-10 17:09:55 +0000
commit571b13291da5d18235b65246209246c7078062f4 (patch)
tree11f08b8688b45f0d889aa2eeecd0882a731f2a80
parentadd wayland support wrt #504136 (diff)
downloadgentoo-2-571b13291da5d18235b65246209246c7078062f4.tar.gz
gentoo-2-571b13291da5d18235b65246209246c7078062f4.tar.bz2
gentoo-2-571b13291da5d18235b65246209246c7078062f4.zip
app-arch/p7zip: Add support for x32, #506602, patch by Luke-Jr
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--app-arch/p7zip/ChangeLog7
-rw-r--r--app-arch/p7zip/p7zip-9.20.1-r5.ebuild12
2 files changed, 13 insertions, 6 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index 6fc2333665f6..45a8df05b12a 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-arch/p7zip
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.161 2013/12/24 01:33:06 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.162 2014/05/10 17:09:55 jlec Exp $
+
+ 10 May 2014; Justin Lecher <jlec@gentoo.org> p7zip-9.20.1-r5.ebuild:
+ Add support for x32, #506602, patch by Luke-Jr
24 Dec 2013; Tom Wijsman <TomWij@gentoo.org> -files/9.04-kde4.patch,
-files/p7zip-9.13-QA.patch:
diff --git a/app-arch/p7zip/p7zip-9.20.1-r5.ebuild b/app-arch/p7zip/p7zip-9.20.1-r5.ebuild
index e6525f4ba812..292f4a14dcbc 100644
--- a/app-arch/p7zip/p7zip-9.20.1-r5.ebuild
+++ b/app-arch/p7zip/p7zip-9.20.1-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.20.1-r5.ebuild,v 1.3 2013/11/16 07:49:40 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-9.20.1-r5.ebuild,v 1.4 2014/05/10 17:09:55 jlec Exp $
EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
LICENSE="LGPL-2.1 rar? ( unRAR )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="doc kde rar +pch static wxwidgets"
+IUSE="doc kde rar +pch static wxwidgets abi_x86_x32"
REQUIRED_USE="kde? ( wxwidgets )"
@@ -24,6 +24,7 @@ RDEPEND="
wxwidgets? ( x11-libs/wxGTK:2.8[X,-odbc] )"
DEPEND="${RDEPEND}
amd64? ( dev-lang/yasm )
+ abi_x86_x32? ( >=dev-lang/yasm-1.2.0-r1 )
x86? ( dev-lang/nasm )"
S=${WORKDIR}/${PN}_${PV}
@@ -62,7 +63,10 @@ src_prepare() {
-e '/ALLFLAGS/s:-s ::' \
makefile* || die "changing makefiles"
- if use amd64; then
+ if use abi_x86_x32; then
+ sed -i -e "/^ASM=/s:amd64:x32:" makefile*
+ cp -f makefile.linux_amd64_asm makefile.machine || die
+ elif use amd64; then
cp -f makefile.linux_amd64_asm makefile.machine || die
elif use x86; then
cp -f makefile.linux_x86_asm_gcc_4.X makefile.machine || die