summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-01 00:45:34 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-01 00:45:34 +0000
commit46c4ab98b863367f588a207c870161ebfa4bdaef (patch)
treef4ec505bebeb467e2525929a9eff194560617492
parentaqbanking: remove obsolete use flags yellownet and geldkarte (diff)
downloadgentoo-2-46c4ab98b863367f588a207c870161ebfa4bdaef.tar.gz
gentoo-2-46c4ab98b863367f588a207c870161ebfa4bdaef.tar.bz2
gentoo-2-46c4ab98b863367f588a207c870161ebfa4bdaef.zip
Version bumped.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
-rw-r--r--app-emacs/navi2ch/ChangeLog7
-rw-r--r--app-emacs/navi2ch/navi2ch-1.8.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-emacs/navi2ch/ChangeLog b/app-emacs/navi2ch/ChangeLog
index c279cc6aa04c..7b9ec2f3a240 100644
--- a/app-emacs/navi2ch/ChangeLog
+++ b/app-emacs/navi2ch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/navi2ch
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.43 2008/06/14 14:03:14 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.44 2008/12/01 00:45:34 matsuu Exp $
+
+*navi2ch-1.8.1 (01 Dec 2008)
+
+ 01 Dec 2008; MATSUU Takuto <matsuu@gentoo.org> +navi2ch-1.8.1.ebuild:
+ Version bumped.
14 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
-navi2ch-1.7.5.ebuild:
diff --git a/app-emacs/navi2ch/navi2ch-1.8.1.ebuild b/app-emacs/navi2ch/navi2ch-1.8.1.ebuild
new file mode 100644
index 000000000000..5952a7b21e14
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/navi2ch-1.8.1.ebuild,v 1.1 2008/12/01 00:45:34 matsuu Exp $
+
+inherit elisp
+
+DESCRIPTION="A navigator for 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ econf \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-icondir=${SITEETC}/${PN} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ dodoc ChangeLog* NEWS README TODO
+ newdoc contrib/README README.contrib
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}