summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-08-30 16:56:47 +0000
committerTorsten Veller <tove@gentoo.org>2011-08-30 16:56:47 +0000
commit42686008aafafffe4482d65f2810eb04fc218c41 (patch)
tree43dfc3014123ec3ab33bb4f6f5024bda49279f30
parent[bump] dev-perl/indirect-0.250.0 (diff)
downloadgentoo-2-42686008aafafffe4482d65f2810eb04fc218c41.tar.gz
gentoo-2-42686008aafafffe4482d65f2810eb04fc218c41.tar.bz2
gentoo-2-42686008aafafffe4482d65f2810eb04fc218c41.zip
[bump] dev-perl/XML-LibXML-1.870.0
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
-rw-r--r--dev-perl/XML-LibXML/ChangeLog7
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.870.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-perl/XML-LibXML/ChangeLog b/dev-perl/XML-LibXML/ChangeLog
index 1f0753e45896..38ebee3520db 100644
--- a/dev-perl/XML-LibXML/ChangeLog
+++ b/dev-perl/XML-LibXML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/XML-LibXML
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.112 2011/07/29 12:31:54 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.113 2011/08/30 16:56:47 tove Exp $
+
+*XML-LibXML-1.870.0 (30 Aug 2011)
+
+ 30 Aug 2011; Torsten Veller <tove@gentoo.org> +XML-LibXML-1.870.0.ebuild:
+ Version bump
29 Jul 2011; Torsten Veller <tove@gentoo.org> -XML-LibXML-1.720.0.ebuild,
-XML-LibXML-1.730.0.ebuild, -XML-LibXML-1.750.0.ebuild,
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.870.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.870.0.ebuild
new file mode 100644
index 000000000000..56c44e539133
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-1.870.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.870.0.ebuild,v 1.1 2011/08/30 16:56:47 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=1.87
+inherit perl-module
+
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=">=dev-perl/XML-SAX-0.12
+ >=dev-libs/libxml2-2.6.21
+ >=dev-perl/XML-NamespaceSupport-1.07"
+RDEPEND="${DEPEND}
+ !dev-perl/XML-LibXML-Common"
+
+SRC_TEST="do"
+
+# rac can't discern any difference between the build with or without
+# this, and if somebody wants to reactivate it, get it out of global
+# scope.
+#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
+mytargets="pure_install doc_install"
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}