summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-05 09:17:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-05 09:17:46 +0000
commit3d200ab06fad479f89db891676777c0ad941905b (patch)
tree76a14cf8a1f64443c1ec38e9b67a6c965656f0e2
parentImprove init.d script detection of baselayout-1 wrt #270646#c52. (diff)
downloadgentoo-2-3d200ab06fad479f89db891676777c0ad941905b.tar.gz
gentoo-2-3d200ab06fad479f89db891676777c0ad941905b.tar.bz2
gentoo-2-3d200ab06fad479f89db891676777c0ad941905b.zip
EAPI3, apply conditional patch for sqlalchemy-0.7.1. Add post_inst message about optional runtime dependencies. Bug #377789
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
-rw-r--r--media-video/griffith/ChangeLog7
-rw-r--r--media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch39
-rw-r--r--media-video/griffith/griffith-0.12.1.ebuild15
-rw-r--r--media-video/griffith/griffith-9999.ebuild10
4 files changed, 66 insertions, 5 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 0b5fd8c61662..192b7559f6aa 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.55 2011/06/04 17:36:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.56 2011/08/05 09:17:45 hwoarang Exp $
+
+ 05 Aug 2011; Markos Chandras <hwoarang@gentoo.org> griffith-0.12.1.ebuild,
+ +files/griffith-0.12.1-sqlalchemy-0.7.patch, griffith-9999.ebuild:
+ EAPI3, apply conditional patch for sqlalchemy-0.7.1. Add post_inst message
+ about optional runtime dependencies. Bug #377789
04 Jun 2011; Pacho Ramos <pacho@gentoo.org> griffith-0.12.1.ebuild,
griffith-9999.ebuild:
diff --git a/media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch b/media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch
new file mode 100644
index 000000000000..d3e6a5b6e182
--- /dev/null
+++ b/media-video/griffith/files/griffith-0.12.1-sqlalchemy-0.7.patch
@@ -0,0 +1,39 @@
+Index: griffith-0.12.1/lib/add.py
+===================================================================
+--- griffith-0.12.1.orig/lib/add.py
++++ griffith-0.12.1/lib/add.py
+@@ -26,7 +26,7 @@ import logging
+ import os
+
+ import gtk
+-from sqlalchemy.exceptions import IntegrityError
++from sqlalchemy.exc import IntegrityError
+
+ import quick_filter
+ import db
+Index: griffith-0.12.1/lib/db/tables.py
+===================================================================
+--- griffith-0.12.1.orig/lib/db/tables.py
++++ griffith-0.12.1/lib/db/tables.py
+@@ -64,7 +64,7 @@ movies = Table('movies', metadata,
+ Column('poster_md5', ForeignKey(posters.c.md5sum)),
+ Column('loaned', Boolean, nullable=False, default=False),
+ Column('seen', Boolean, nullable=False, default=False),
+- Column('rating', SmallInteger(2)),
++ Column('rating', SmallInteger),
+ Column('color', SmallInteger),
+ Column('cond', SmallInteger), # MySQL will not accept name "condition"
+ Column('layers', SmallInteger),
+Index: griffith-0.12.1/lib/sql.py
+===================================================================
+--- griffith-0.12.1.orig/lib/sql.py
++++ griffith-0.12.1/lib/sql.py
+@@ -29,7 +29,7 @@ import logging
+ import os.path
+
+ from sqlalchemy import create_engine, or_, and_, not_, exists, asc, desc
+-from sqlalchemy.exceptions import OperationalError
++from sqlalchemy.exc import OperationalError
+ from sqlalchemy.orm import sessionmaker, scoped_session
+ from sqlalchemy.sql.expression import Update, Delete
+
diff --git a/media-video/griffith/griffith-0.12.1.ebuild b/media-video/griffith/griffith-0.12.1.ebuild
index ba3d51d1c68a..890292ea9f86 100644
--- a/media-video/griffith/griffith-0.12.1.ebuild
+++ b/media-video/griffith/griffith-0.12.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.12.1.ebuild,v 1.4 2011/06/04 17:36:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.12.1.ebuild,v 1.5 2011/08/05 09:17:45 hwoarang Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
@@ -46,6 +46,11 @@ src_prepare() {
-e 's/ISO-8859-1/UTF-8/' \
"${S}"/lib/gconsole.py || die "sed failed"
epatch "${FILESDIR}/0.10-fix_lib_path.patch"
+
+ #bug 377789
+ if has_version ">=dev-python/sqlalchemy-0.7.1"; then
+ epatch ${FILESDIR}/${P}-sqlalchemy-0.7.patch
+ fi
}
src_compile() {
@@ -67,6 +72,12 @@ src_install() {
pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/${PN}
+ einfo
+ einfo "${PN} can make use of the following optional dependencies"
+ einfo "dev-python/chardet: CSV file encoding detections"
+ einfo "dev-python/mysql-python: Python interface for MySQL connectivity"
+ einfo ">=dev-python/psycopg-2.4: Python interface for PostgreSQL connectivity"
+ einfo
}
pkg_postrm() {
diff --git a/media-video/griffith/griffith-9999.ebuild b/media-video/griffith/griffith-9999.ebuild
index b9576e128173..225e398f521e 100644
--- a/media-video/griffith/griffith-9999.ebuild
+++ b/media-video/griffith/griffith-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-9999.ebuild,v 1.5 2011/06/04 17:36:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-9999.ebuild,v 1.6 2011/08/05 09:17:45 hwoarang Exp $
-EAPI="1"
+EAPI="3"
ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/griffith/trunk"
inherit eutils python multilib subversion
@@ -78,6 +78,12 @@ src_install() {
pkg_postinst() {
python_mod_optimize /usr/$(get_libdir)/${PN}
+ einfo
+ einfo "${PN} can make use of the following optional dependencies"
+ einfo "dev-python/chardet: CSV file encoding detections"
+ einfo "dev-python/mysql-python: Python interface for MySQL connectivity"
+ einfo ">=dev-python/psycopg-2.4: Python interface for PostgreSQL connectivity"
+ einfo
}
pkg_postrm() {