summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-05-18 16:08:59 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-05-18 16:08:59 +0000
commit3415d74822800204eeea74d6bf45fd0a6f30c046 (patch)
tree47ec2d3dfa5ae5cac5c3c296a16ad0af4b6517d7
parentremoving guile-1.5.x from tree (diff)
downloadgentoo-2-3415d74822800204eeea74d6bf45fd0a6f30c046.tar.gz
gentoo-2-3415d74822800204eeea74d6bf45fd0a6f30c046.tar.bz2
gentoo-2-3415d74822800204eeea74d6bf45fd0a6f30c046.zip
Version bump to 0.9.21.
-rw-r--r--media-video/xine-ui/ChangeLog7
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.211
-rw-r--r--media-video/xine-ui/xine-ui-0.9.21.ebuild65
3 files changed, 72 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index f17b22960f23..9a3d2582ccc3 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.31 2003/04/29 07:37:49 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.32 2003/05/18 16:08:59 agenkin Exp $
29 Apr 2003; Brandon Low <lostlogic@gentoo.org> xine-ui-0.9.10-r1.ebuild,
xine-ui-0.9.10-r1.ebuild, xine-ui-0.9.12-r1.ebuild,
xine-ui-0.9.12-r1.ebuild:
Remove unneeded cruft
+*xine-ui-0.9.21 (25 Mar 2003)
+
+ 25 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
+
*xine-ui-0.9.20 (25 Mar 2003)
15 Apr 2003; Arcady Genkin <agenkin@gentoo.org> :
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.21 b/media-video/xine-ui/files/digest-xine-ui-0.9.21
new file mode 100644
index 000000000000..37622e3a35fa
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.21
@@ -0,0 +1 @@
+MD5 18baa9fbef7a87d4094e46b02f85d46a xine-ui-0.9.21.tar.gz 2551466
diff --git a/media-video/xine-ui/xine-ui-0.9.21.ebuild b/media-video/xine-ui/xine-ui-0.9.21.ebuild
new file mode 100644
index 000000000000..e0045af171f1
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.21.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.21.ebuild,v 1.1 2003/05/18 16:08:59 agenkin Exp $
+
+DESCRIPTION="Skinned front end for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1_beta12
+ >=net-ftp/curl-7.10.2
+ lirc? ( app-misc/lirc )
+ X? ( virtual/x11 )
+ aalib? ( media-libs/aalib )
+ gnome? ( gnome-base/ORBit )
+ directfb? ( media-libs/aalib
+ >=dev-libs/DirectFB-0.9.9 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+IUSE="X aalib gnome nls directfb lirc"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #patch -p1 < ${FILESDIR}/xine-ui-configure.patch || die "patch failed"
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}