summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-12-03 16:55:42 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-12-03 16:55:42 +0000
commit27180e3b220ad1710b1da2e4c1b44a5535e6cae6 (patch)
tree67ced9ddfa9d94f80b524c3521edf20d173dbe2f
parentAdded -fforce-addr to the list of filtered flags (diff)
downloadgentoo-2-27180e3b220ad1710b1da2e4c1b44a5535e6cae6.tar.gz
gentoo-2-27180e3b220ad1710b1da2e4c1b44a5535e6cae6.tar.bz2
gentoo-2-27180e3b220ad1710b1da2e4c1b44a5535e6cae6.zip
Added -fforce-addr to the list of filtered flags
-rw-r--r--dev-lang/squeak/ChangeLog7
-rw-r--r--dev-lang/squeak/Manifest5
-rw-r--r--dev-lang/squeak/files/digest-squeak-3.4.1-r21
-rw-r--r--dev-lang/squeak/metadata.xml8
-rw-r--r--dev-lang/squeak/squeak-3.4.1-r2.ebuild124
5 files changed, 142 insertions, 3 deletions
diff --git a/dev-lang/squeak/ChangeLog b/dev-lang/squeak/ChangeLog
index 96bb0b7d4d8e..e0c605dd0a92 100644
--- a/dev-lang/squeak/ChangeLog
+++ b/dev-lang/squeak/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-lang/squeak
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/ChangeLog,v 1.5 2003/10/30 22:26:04 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/ChangeLog,v 1.6 2003/12/03 16:55:39 jhhudso Exp $
+*squeak-3.4.1-r2 (03 Dec 2003)
+
+ 03 Dec 2003; Jared Hudson <jhhudso@gentoo.org> : Added -fforce-addr to the
+ list of gcc flags being filtered. Credit goes to dhx <xyx@gmx.at> via bug
+ #20498 for telling us.
*squeak-3.4.1-r1 (11 Oct 2003)
diff --git a/dev-lang/squeak/Manifest b/dev-lang/squeak/Manifest
index c536d4cdcc3c..d5f2fbed9380 100644
--- a/dev-lang/squeak/Manifest
+++ b/dev-lang/squeak/Manifest
@@ -1,5 +1,6 @@
-MD5 e024c954998213104fcd21b37f37f594 squeak-3.4.1-r2.ebuild 3340
-MD5 0cc511045612bd8bcd5019c53896bef4 ChangeLog 1102
+MD5 cd47f91f5382f6485ea0f715c6f17b9e squeak-3.4.1-r2.ebuild 3342
+MD5 2c3158204cfb4b9c36b8bc78e8421b16 metadata.xml 223
+MD5 a1a285dfff47605467caf3a7c55df8be ChangeLog 1104
MD5 142bce812145a8b5734d5b78d4ef4378 squeak-3.4.1-r1.ebuild 3325
MD5 479f2d1c5b28ac403ce1e966caded2be squeak-3.2.5.ebuild 2903
MD5 c5ee64830a6abb8992d522b313a0ab02 squeak-3.4.1.ebuild 2988
diff --git a/dev-lang/squeak/files/digest-squeak-3.4.1-r2 b/dev-lang/squeak/files/digest-squeak-3.4.1-r2
new file mode 100644
index 000000000000..bfbee3e7c2ec
--- /dev/null
+++ b/dev-lang/squeak/files/digest-squeak-3.4.1-r2
@@ -0,0 +1 @@
+MD5 780af1cf1cdc8d44c1ce30a527bdd508 Squeak-3.4-1.src.tar.gz 1890889
diff --git a/dev-lang/squeak/metadata.xml b/dev-lang/squeak/metadata.xml
new file mode 100644
index 000000000000..c5d67a611520
--- /dev/null
+++ b/dev-lang/squeak/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jhhudso@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-lang/squeak/squeak-3.4.1-r2.ebuild b/dev-lang/squeak/squeak-3.4.1-r2.ebuild
new file mode 100644
index 000000000000..9f9acd5a35b6
--- /dev/null
+++ b/dev-lang/squeak/squeak-3.4.1-r2.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.4.1-r2.ebuild,v 1.1 2003/12/03 16:55:39 jhhudso Exp $
+
+inherit libtool flag-o-matic eutils
+strip-flags
+filter-mfpmath sse
+filter-flags "-fPIC" "-maltivec" "-mabi=altivec" "-fstack-protector" "-pipe" "-g" "-mtune" "-march" "-mcpu" "-O" "-O1" "-O2" "-Os" "-O3" "-freorder-blocks" "-fprefetch-loop-array" "-fforce-addr"
+
+#Simply change these numbers for different versions
+MV=3.4
+NV=${MV}-1
+FV=${MV}.1
+
+DESCRIPTION="Highly-portable Smalltalk-80 implementation"
+HOMEPAGE="http://www.squeak.org/"
+SRC_URI="ftp://st.cs.uiuc.edu/Smalltalk/Squeak/${MV}/unix-linux/Squeak-${NV}.src.tar.gz"
+LICENSE="Apple"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X oss mmx mozilla"
+# a ffi flag would be nice
+
+DEPEND="virtual/glibc
+ X? ( x11-base/xfree )"
+RDEPEND="dev-lang/squeak-vm
+ virtual/glibc
+ X? ( x11-base/xfree )"
+
+S="${WORKDIR}/Squeak-${NV}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc33-string-fix.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ use X || myconf="--without-x"
+ use oss && myconf="${myconf} --with-audio=oss"
+ use mmx && myconf="${myconf} --enable-mpg-mmx"
+
+ cd ${S}
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "configure failed"
+ mv Makefile Makefile.tmp.$$
+ cat Makefile.tmp.$$|sed \
+ 's/$(prefix)\/doc\/squeak/$(prefix)\/share\/doc\/squeak-${FV}/g'\
+ > Makefile
+ rm -f Makefile.tmp.$$
+ emake || die
+ make npsqueak
+ # this is a bit paranoid, but we want to be sure it gets compiled now
+ cd nps
+ emake || die
+}
+
+src_install() {
+ cd ${S}/build
+
+ make DESTDIR=${D} ROOT=${D} install || die
+
+ exeinto /usr/bin
+ doexe inisqueak
+
+ ### the rest is all for the plugin
+
+ cd nps
+
+ # plugin sample, must be served to work, file:// doesnt work.
+
+ insinto /usr/share/doc/squeak-${FV}
+ doins test/plugintest.html
+ doins test/plugintest.sts
+
+ # fix the paths
+
+ SQ_DIR=/usr/lib/squeak
+ VM_VERSION=${NV}
+ NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakrun.in > npsqueakrun.in.2
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakregister.in > npsqueakregister
+ sed 's|^ensurefile|ensurefile "${HOME}/.npsqueak/SqueakPlugin.changes" "${SQ_DIR}/npsqueak.changes"\nensurefile|' npsqueakrun.in.2 > npsqueakrun
+
+ exeinto /usr/lib/squeak
+ doexe npsqueakregister
+ exeinto /usr/lib/squeak/${NV}
+ doexe npsqueakrun
+
+
+ # install in browsers (no opera use flags?)
+
+ dodir /opt/netscape/plugins
+ dosym /usr/lib/squeak/${NV}/npsqueak.so /opt/netscape/plugins
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/npsqueak.so \
+ /usr/lib/mozilla/plugins/npsqueak.so
+ fi
+
+ # maybe we should install the image here..
+
+ # dosym /usr/lib/squeak/SqueakV3.sources /usr/lib/squeak/${NV}/SqueakV3.sources
+ # doins npsqueak.image
+ # doins npsqueak.changes
+}
+
+pkg_postinst() {
+ einfo 'Run "inisqueak" to get a private copy of the VM image.'
+ einfo ''
+ einfo 'To setup the browser plugin, create a working set named npsqueak.* in /usr/lib/squeak/<version>/'
+}