summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-10-14 16:31:33 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-10-14 16:31:33 +0000
commit23f04e6c71ae2bf2d5df06abf40ce220941949f2 (patch)
tree64e77e5ba539103da5ca9f71dd9df519b0f94e1a
parentAdd missing deps (x11-libs/libXres and x11-libs/libxkbui). (diff)
downloadgentoo-2-23f04e6c71ae2bf2d5df06abf40ce220941949f2.tar.gz
gentoo-2-23f04e6c71ae2bf2d5df06abf40ce220941949f2.tar.bz2
gentoo-2-23f04e6c71ae2bf2d5df06abf40ce220941949f2.zip
Version bump.
(Portage version: 2.0.53_rc5)
-rw-r--r--sci-misc/gwyddion/ChangeLog7
-rw-r--r--sci-misc/gwyddion/Manifest16
-rw-r--r--sci-misc/gwyddion/files/digest-gwyddion-1.131
-rw-r--r--sci-misc/gwyddion/gwyddion-1.13.ebuild38
4 files changed, 49 insertions, 13 deletions
diff --git a/sci-misc/gwyddion/ChangeLog b/sci-misc/gwyddion/ChangeLog
index ff62ae03671a..330f75cb6c63 100644
--- a/sci-misc/gwyddion/ChangeLog
+++ b/sci-misc/gwyddion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/gwyddion
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gwyddion/ChangeLog,v 1.1 2005/08/24 22:30:06 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gwyddion/ChangeLog,v 1.2 2005/10/14 16:31:33 cryos Exp $
+
+*gwyddion-1.13 (14 Oct 2005)
+
+ 14 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> +gwyddion-1.13.ebuild:
+ Version bump.
*gwyddion-1.12 (24 Aug 2005)
diff --git a/sci-misc/gwyddion/Manifest b/sci-misc/gwyddion/Manifest
index 7f134a3fec1c..4d0b4192316e 100644
--- a/sci-misc/gwyddion/Manifest
+++ b/sci-misc/gwyddion/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 211a51df6c31d84ea53b5a40819380cb gwyddion-1.12.ebuild 1008
MD5 ef2d02ab0281811529af1852e5788962 ChangeLog 451
-MD5 8b540c5fcae8b4718136d43ae501f9fd metadata.xml 557
MD5 022fb0f1d0f2d3b498c88934cc2622c4 files/digest-gwyddion-1.12 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDDPT+ntT9W3vfTuoRAjrdAJ95pvANZEhqKQRK9VBFMKe3cx2M6QCdEPYz
-BvDWiCRAioDPlsqmlrtAdK8=
-=JGym
------END PGP SIGNATURE-----
+MD5 128d3ffbce1151a8127bdf85883bba43 files/digest-gwyddion-1.13 67
+MD5 211a51df6c31d84ea53b5a40819380cb gwyddion-1.12.ebuild 1008
+MD5 211a51df6c31d84ea53b5a40819380cb gwyddion-1.13.ebuild 1008
+MD5 8b540c5fcae8b4718136d43ae501f9fd metadata.xml 557
diff --git a/sci-misc/gwyddion/files/digest-gwyddion-1.13 b/sci-misc/gwyddion/files/digest-gwyddion-1.13
new file mode 100644
index 000000000000..71b1b9424e20
--- /dev/null
+++ b/sci-misc/gwyddion/files/digest-gwyddion-1.13
@@ -0,0 +1 @@
+MD5 d31ff420091d6ef175b799aa5bc8f4b6 gwyddion-1.13.tar.bz2 1497847
diff --git a/sci-misc/gwyddion/gwyddion-1.13.ebuild b/sci-misc/gwyddion/gwyddion-1.13.ebuild
new file mode 100644
index 000000000000..b135dd626e6f
--- /dev/null
+++ b/sci-misc/gwyddion/gwyddion-1.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gwyddion/gwyddion-1.13.ebuild,v 1.1 2005/10/14 16:31:33 cryos Exp $
+
+DESCRIPTION="A software framework for SPM data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python perl ruby nls X opengl"
+
+DEPEND="X? ( virtual/x11 )
+ opengl? ( virtual/opengl )
+ python? ( virtual/python )
+ perl? ( dev-lang/perl )
+ ruby? ( virtual/ruby )
+ >=x11-libs/gtk+-2.6
+ x11-libs/gtkglext"
+
+src_compile() {
+ econf \
+ $(use_enable python) \
+ $(use_enable perl) \
+ $(use_enable ruby) \
+ $(use_enable nls) \
+ $(use_with X x) \
+ $(use_with opengl gl) \
+ --disable-desktop-file-update \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed."
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}